<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
	<title>How To Build A SpriteKit Game In Swift 3 (Part 3) &ndash; Smashing Magazine</title>
	<meta charset="UTF-8" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[(new Date).getTime()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=NREUM;"undefined"==typeof window.newrelic&&(newrelic=f);var s=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit"],l="api-",p=l+"ixn-";a(s,function(e,t){f[t]=o(l+t,!0,"api")}),f.addPageAction=o(l+"addPageAction",!0),f.setCurrentRouteName=o(l+"routeName",!0),t.exports=newrelic,f.interaction=function(){return(new r).get()};var d=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(p+"tracer",[Date.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[Date.now(),r,o],n),o)try{return t.apply(this,arguments)}finally{c.emit("fn-end",[Date.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){d[t]=o(p+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,(new Date).getTime()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o){if(!p.aborted){e&&e(n,r,o);for(var i=t(o),a=v(n),u=a.length,c=0;c<u;c++)a[c].apply(i,r);var f=s[w[n]];return f&&f.push([y,n,r,i]),i}}function d(e,t){b[e]=v(e).concat(t)}function v(e){return b[e]||[]}function g(e){return l[e]=l[e]||o(n)}function m(e,t){f(e,function(e,n){t=t||"feature",w[n]=t,t in s||(s[t]=[])})}var b={},w={},y={on:d,emit:n,get:g,listeners:v,context:t,buffer:m,abort:a,aborted:!1};return y}function i(){return new r}function a(){(s.api||s.feature)&&(p.aborted=!0,s=p.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},l={},p=t.exports=o();p.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!h++){var e=y.info=NREUM.info,t=l.getElementsByTagName("script")[0];if(setTimeout(f.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return f.abort();c(b,function(t,n){e[t]||(e[t]=n)}),u("mark",["onload",a()],null,"api");var n=l.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===l.readyState&&i()}function i(){u("mark",["domContent",a()],null,"api")}function a(){return(new Date).getTime()}var u=e("handle"),c=e(2),f=e("ee"),s=window,l=s.document,p="addEventListener",d="attachEvent",v=s.XMLHttpRequest,g=v&&v.prototype;NREUM.o={ST:setTimeout,CT:clearTimeout,XHR:v,REQ:s.Request,EV:s.Event,PR:s.Promise,MO:s.MutationObserver},e(1);var m=""+location,b={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-998.min.js"},w=v&&g&&g[p]&&!/CriOS/.test(navigator.userAgent),y=t.exports={offset:a(),origin:m,features:{},xhrWrappable:w};l[p]?(l[p]("DOMContentLoaded",i,!1),s[p]("load",r,!1)):(l[d]("onreadystatechange",o),s[d]("onload",r)),u("mark",["firstbyte",a()],null,"api");var h=0},{}]},{},["loader"]);</script>
	<link rel="dns-prefetch" href="https://media-mediatemple.netdna-ssl.com/" />
	<link rel="dns-prefetch" href="https//auslieferung.commindo-media-resourcen.de/" />
	<link rel="preconnect" href="https://media-mediatemple.netdna-ssl.com" />
	<link rel="preconnect" href="https://auslieferung.commindo-media-resourcen.de/" />
	<style id="smash-above-the-fold-css">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</style><script>!function(e){"use strict";function t(e,t,n){e.addEventListener?e.addEventListener(t,n,!1):e.attachEvent&&e.attachEvent("on"+t,n)}function n(t,n){return e.localStorage&&localStorage[t+"_content"]&&localStorage[t+"_file"]===n}function o(t,o){if(e.localStorage&&e.XMLHttpRequest)n(t,o)?r(localStorage[t+"_content"]):a(t,o);else{var i=l.createElement("link");i.href=o,i.id=t,i.rel="stylesheet",i.type="text/css",l.getElementsByTagName("head")[0].appendChild(i),l.cookie=t}}function a(e,t){var n=new XMLHttpRequest;n.open("GET",t,!0),n.onreadystatechange=function(){4===n.readyState&&200===n.status&&(r(n.responseText),localStorage[e+"_content"]=n.responseText,localStorage[e+"_file"]=t)},n.send()}function r(e){var t=l.createElement("style");t.setAttribute("type","text/css"),l.getElementsByTagName("head")[0].appendChild(t),t.styleSheet?t.styleSheet.cssText=e:t.innerHTML=e}var l=e.document,i=function(e,t,n){function o(e){return l.body?e():void setTimeout(function(){o(e)})}function a(){i.addEventListener&&i.removeEventListener("load",a),i.media=n||"all"}var r,i=l.createElement("link");if(t)r=t;else{var s=(l.body||l.getElementsByTagName("head")[0]).childNodes;r=s[s.length-1]}var c=l.styleSheets;i.rel="stylesheet",i.href=e,i.media="only x",o(function(){r.parentNode.insertBefore(i,t?r:r.nextSibling)});var d=function(e){for(var t=i.href,n=c.length;n--;)if(c[n].href===t)return e();setTimeout(function(){d(e)})};return i.addEventListener&&i.addEventListener("load",a),i.onloadcssdefined=d,d(a),i};"undefined"!=typeof exports?exports.loadCSS=i:e.loadCSS=i,e.loadLocalStorageCSS=function(a,r){n(a,r)||l.cookie.indexOf(a)>-1?o(a,r):t(e,"load",function(){o(a,r)})}}(this);</script>
<link rel="preload" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/main.min.css?ver=6.4.5" as="style" onload="this.rel='stylesheet'" /><noscript><link rel='stylesheet' id='smash-main-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/main.min.css?ver=6.4.5' type='text/css' media='all' />
</noscript><link rel="preload" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/articles-only.min.css?ver=6.4.5" as="style" onload="this.rel='stylesheet'" /><noscript><link rel='stylesheet' id='smash-article-only-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/articles-only.min.css?ver=6.4.5' type='text/css' media='all' />
</noscript><script id="loadcss__smash-below-articles">loadCSS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/below-articles.min.css?ver=6.4.5", false, "all" );</script><noscript><link rel='stylesheet' id='smash-below-articles-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/below-articles.min.css?ver=6.4.5' type='text/css' media='all' />
</noscript><script id="loadcss__smash-comments">loadCSS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/comments.min.css?ver=6.4.5", false, "all" );</script><noscript><link rel='stylesheet' id='smash-comments-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/comments.min.css?ver=6.4.5' type='text/css' media='all' />
</noscript><link rel='stylesheet' id='smash-print-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/print.min.css?ver=6.4.5' type='text/css' media='print' />
<script id="loadcss__smash-webfonts">loadLocalStorageCSS( "smash-webfonts", "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/webfonts.min.css?ver=6.4.5" );</script><!--[if IE 8]>
<link rel='stylesheet' id='smash-ie8-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/ie8-nu.min.css?ver=6.4.5' type='text/css' media='all' />
<![endif]-->

<!-- This site is optimized with the Yoast SEO Premium plugin v3.5.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="This article is the third lesson of the SpriteKit game that is built in Swift 3. Follow along and find out how game-making has never been easier on iOS since the introduction of SpriteKit."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://www.smashingmagazine.com/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-3/" />
<link rel="publisher" href="https://plus.google.com/+SmashingMagazine‎"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How To Build A SpriteKit Game In Swift 3 (Part 3) &ndash; Smashing Magazine" />
<meta property="og:description" content="This article is the third lesson of the SpriteKit game that is built in Swift 3. Follow along and find out how game-making has never been easier on iOS since the introduction of SpriteKit." />
<meta property="og:url" content="https://www.smashingmagazine.com/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-3/" />
<meta property="og:site_name" content="Smashing Magazine" />
<meta property="article:publisher" content="https://www.facebook.com/smashmag" />
<meta property="article:tag" content="Apps" />
<meta property="article:tag" content="Games" />
<meta property="article:tag" content="iOS" />
<meta property="article:tag" content="Swift" />
<meta property="article:section" content="Mobile" />
<meta property="article:published_time" content="2016-12-13T12:11:12+01:00" />
<meta property="article:modified_time" content="2016-12-13T12:11:13+01:00" />
<meta property="og:updated_time" content="2016-12-13T12:11:13+01:00" />
<meta property="og:image" content="https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_header_sm-preview-opt-1.png" />
<meta property="og:image:width" content="500" />
<meta property="og:image:height" content="300" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="This article is the third lesson of the SpriteKit game that is built in Swift 3. Follow along and find out how game-making has never been easier on iOS since the introduction of SpriteKit." />
<meta name="twitter:title" content="How To Build A SpriteKit Game In Swift 3 (Part 3) &ndash; Smashing Magazine" />
<meta name="twitter:site" content="@smashingmag" />
<meta name="twitter:image" content="https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_header_sm-preview-opt-1.png" />
<meta name="twitter:creator" content="@marcvandehey" />
<meta property="DC.date.issued" content="2016-12-13T12:11:12+01:00" />
<!-- / Yoast SEO Premium plugin. -->

<link rel="alternate" type="application/rss+xml" title="Smashing Magazine &raquo; Feed" href="https://www.smashingmagazine.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Smashing Magazine &raquo; Comments Feed" href="https://www.smashingmagazine.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Smashing Magazine &raquo; How To Build A SpriteKit Game In Swift 3 (Part 3) Comments Feed" href="https://www.smashingmagazine.com/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-3/feed/" />

<script type='text/javascript'>
/* <![CDATA[ */
var SmashingServiceWorkerData = {"url":"https:\/\/www.smashingmagazine.com\/serviceWorker.js"};
/* ]]> */
</script>
<script>
var SmashingServiceWorkerData=SmashingServiceWorkerData||{url:""};(function(a,b){if(b.url&&"serviceWorker" in a){a.serviceWorker.register(b.url);window.addEventListener("load",function(){if(a.serviceWorker.controller){a.serviceWorker.controller.postMessage({command:"trimCaches"})}})}})(navigator,SmashingServiceWorkerData);
</script>
<!--[if IE 8]>
<script type='text/javascript' src='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/html5shiv.min.js?ver=6.4.5'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://www.smashingmagazine.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.smashingmagazine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.smashingmagazine.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.smashingmagazine.com/?p=272278' />
<link rel="alternate" type="application/json+oembed" href="https://www.smashingmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.smashingmagazine.com%2F2016%2F12%2Fhow-to-build-a-spritekit-game-in-swift-3-part-3%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.smashingmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.smashingmagazine.com%2F2016%2F12%2Fhow-to-build-a-spritekit-game-in-swift-3-part-3%2F&#038;format=xml" />
<!-- Stream WordPress user activity plugin v3.0.7 -->
	<script>
	dataLayer = [
		{
			'site': {"ID":"1","name":"Smashing Magazine","home":"https:\/\/www.smashingmagazine.com"},
			'user': {"isLoggedIn":false,"ID":0,"role":"visitor"}		}
	];
</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
		new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
		j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
		'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-NWC9FPF');
</script>

	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="mask-icon" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/s.svg" color="#e53b2c" sizes="any" />
<!--[if IE]><link href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/favicon.ico" rel="icon" /><![endif]-->
<link rel="icon" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/favicon.png" />
<meta name="application-name" content="Smashing Magazine" />
<meta name="msapplication-TileColor" content="#fff" />
<meta name="msapplication-square70x70logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-70-70.png" />
<meta name="msapplication-square150x150logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-150-150.png" />
<meta name="msapplication-wide310x150logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-310-150.png" />
<meta name="msapplication-square310x310logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-310-310.png" />
<meta name="msapplication-notification" content="frequency=30;polling-uri1=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=1;polling-uri2=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=2;polling-uri3=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=3;polling-uri4=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=4;cycle=1" />
<link rel="apple-touch-icon-precomposed" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-57x57-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-72x72-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-114x114-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-144x144-precomposed.png" />
</head>
<body id="top" class="single single-post postid-272278 single-format-standard www-section">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NWC9FPF" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div class="mnb">
	<a href="#mn" class="ntb js-toggle-btn" title="Jump to the main navigation">
		Menu	</a>
	<a href="#ms" class="stb js-toggle-btn" title="Jump to the search">
		Search    </a>
</div><a class="sr" href="#content">Jump to the content</a>
<header class="h" role="banner">
	<h1 class="logo">
		<span class="sr">Smashing Magazine</span>
		<a href="https://www.smashingmagazine.com/"><img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/logo.png" alt="Smashing Magazine Logo" srcset="https://media-mediatemple.netdna-ssl.com/wp-content/themes/smashing-magazine/assets/images/logo.svg" /></a>
	</h1>
</header>
<nav class="mn" id="mn" role="navigation menu">
	<h2>Smashing Pages:</h2>
	 <ul id="menu-smashing-mobile-network" class="mnu"><li id="menu-item-218248" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218248 menu-item-books"><a href="https://www.smashingmagazine.com/books/">Books</a></li>
<li id="menu-item-218247" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218247 menu-item-ebooks"><a href="https://www.smashingmagazine.com/ebooks/">eBooks</a></li>
<li id="menu-item-218249" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218249 menu-item-tickets"><a href="https://www.smashingmagazine.com/workshops/">Tickets</a></li>
<li id="menu-item-219109" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219109 menu-item-shop"><a href="https://shop.smashingmagazine.com/">Shop</a></li>
<li id="menu-item-188959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188959 menu-item-email-newsletter"><a href="https://www.smashingmagazine.com/the-smashing-newsletter/">Email Newsletter</a></li>
<li id="menu-item-188961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-188961 menu-item-jobs"><a href="http://jobs.smashingmagazine.com">Jobs</a></li>
<li id="menu-item-188958" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188958 menu-item-about-us-impressum"><a href="https://www.smashingmagazine.com/about/">About us / Impressum</a></li>
</ul>	<h2>Categories:</h2>
	 <ul id="menu-mobile-categories" class="mnu"><li id="menu-item-181575" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181575 menu-item-coding"><a href="https://www.smashingmagazine.com/category/coding/">Coding</a></li>
<li id="menu-item-181576" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181576 menu-item-design"><a href="https://www.smashingmagazine.com/category/design/">Design</a></li>
<li id="menu-item-181580" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-181580 menu-item-mobile"><a href="https://www.smashingmagazine.com/category/mobile/">Mobile</a></li>
<li id="menu-item-181579" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181579 menu-item-graphics"><a href="https://www.smashingmagazine.com/category/graphics/">Graphics</a></li>
<li id="menu-item-181577" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181577 menu-item-ux-design"><a href="https://www.smashingmagazine.com/category/uxdesign/">UX Design</a></li>
<li id="menu-item-181578" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181578 menu-item-wordpress"><a href="https://www.smashingmagazine.com/category/wordpress/"><span class="long"><span>Word</span><span>Press</span></span><span class="short">WP</span></a></li>
</ul></nav>
<a class="mnc js-toggle-btn" href="#top" data-toggle-target="mn" title="Close the navigation">X</a><div class="ms" id="ms" role="search">
  <form id="mobile-searching" class="sfm clearfix" method="get" action="https://www.smashingmagazine.com/search-results/" target="_top">
    <label for="mobile-search-input">Search on Smashing Magazine</label>
    <input name="q" id="mobile-search-input" type="text" placeholder="e.g. CSS" />
    <button class="submit" type="submit">Search</button>
    <input type="hidden" name="cx" value="partner-pub-6779860845561969:5884617103">
    <input type="hidden" name="cof" value="FORID:10">
    <input type="hidden" name="ie" value="UTF-8">
  </form>
</div>
<a role="button" class="msc js-toggle-btn" href="#top" data-toggle-target="ms" title="Close the search">X</a>
<nav class="tn clearfix" role="navigation">
	 <ul id="menu-network-menu" class="nw clearfix"><li class="current"><a href="https://www.smashingmagazine.com"><img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/logo.png" alt="Smashing Magazine" srcset="https://media-mediatemple.netdna-ssl.com/wp-content/themes/smashing-magazine/assets/images/logo.svg"  /></a></li><li id="menu-item-218245" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218245 menu-item-books"><a href="https://www.smashingmagazine.com/books/">Books</a></li>
<li id="menu-item-231721" class="cody menu-item menu-item-type-custom menu-item-object-custom menu-item-231721 menu-item-ebooks"><a href="https://shop.smashingmagazine.com/products/the-smashing-library">eBooks</a></li>
<li id="menu-item-218696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218696 menu-item-tickets"><a href="https://www.smashingmagazine.com/smashing-workshops/">Tickets</a></li>
<li id="menu-item-231722" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-231722 menu-item-shop"><a href="https://shop.smashingmagazine.com/">Shop</a></li>
<li id="menu-item-2" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2 menu-item-jobs"><a href="http://jobs.smashingmagazine.com/">Jobs</a></li>
</ul><nav id="social-media-nav" role="menu">
  <ul class="ch">
  	<li class="rss">
	    <a href="https://www.smashingmagazine.com/feed/" title="Subscribe to our RSS-feed (120K)">RSS</a>
    </li>
  	<li class="fb">
	    <a href="//www.facebook.com/smashmag" title="Join our Facebook page! (267k)">Facebook</a>
    </li>
  	<li class="tw">
	    <a href="//twitter.com/smashingmag" title="Follow us on Twitter! (956k)">Twitter</a>
    </li>
  	<li class="nl">
	    <a href="https://www.smashingmagazine.com/the-smashing-newsletter/" title="Subscribe to our Email Newsletter (180k)">Newsletter</a>
    </li>
  </ul>
</nav>
</nav>
<main>
	<div class="cc">
		<div class="fluid clearfix">
			<div class="grid clearfix">
				<section class="mise sf clearfix" role="search">
	<form id="search_1" method="get" action="https://www.smashingmagazine.com/search-results/" target="_top">
    <label class="sl" for="searching_1">Search on Smashing Magazine</label>
		<input id="searching_1" name="q" type="text" placeholder="e.g. JavaScript" />
		<button class="search_submit" type="submit">Search</button>
		<input type="hidden" name="cx" value="partner-pub-6779860845561969:5884617103">
		<input type="hidden" name="cof" value="FORID:10">
		<input type="hidden" name="ie" value="UTF-8">
	</form>
</section>
				<div class="col sn">
					<div class="sct"><ul id="menu-category-menu" class="clearfix"><li id="menu-item-116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-116 menu-item-coding"><a href="https://www.smashingmagazine.com/category/coding/">Coding</a>
<ul class="sub-menu">
	<li id="menu-item-2014" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2014 menu-item-css"><a href="https://www.smashingmagazine.com/tag/css/">CSS</a></li>
	<li id="menu-item-134810" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-134810 menu-item-html"><a href="https://www.smashingmagazine.com/tag/html/">HTML</a></li>
	<li id="menu-item-2015" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2015 menu-item-javascript"><a href="https://www.smashingmagazine.com/tag/javascript/">JavaScript</a></li>
	<li id="menu-item-2016" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2016 menu-item-techniques"><a href="https://www.smashingmagazine.com/tag/techniques/">Techniques</a></li>
</ul>
</li>
<li id="menu-item-117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-117 menu-item-design"><a href="https://www.smashingmagazine.com/category/design/">Design</a>
<ul class="sub-menu">
	<li id="menu-item-2017" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2017 menu-item-web-design"><a href="https://www.smashingmagazine.com/tag/web-design/">Web Design</a></li>
	<li id="menu-item-231166" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-231166 menu-item-responsive"><a title="Responsive Web Design" href="https://www.smashingmagazine.com/tag/responsive-web-design/">Responsive</a></li>
	<li id="menu-item-2032" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2032 menu-item-typography"><a href="https://www.smashingmagazine.com/tag/typography/">Typography</a></li>
	<li id="menu-item-2063" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2063 menu-item-inspiration"><a href="https://www.smashingmagazine.com/tag/inspiration/">Inspiration</a></li>
</ul>
</li>
<li id="menu-item-119" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-119 menu-item-mobile"><a href="https://www.smashingmagazine.com/category/mobile/">Mobile</a>
<ul class="sub-menu">
	<li id="menu-item-142132" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-142132 menu-item-iphone-ipad"><a href="https://www.smashingmagazine.com/tag/ios/">iPhone &#038; iPad</a></li>
	<li id="menu-item-143596" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143596 menu-item-android"><a href="https://www.smashingmagazine.com/tag/android/">Android</a></li>
	<li id="menu-item-143608" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143608 menu-item-design-patterns"><a href="https://www.smashingmagazine.com/tag/design-patterns/">Design Patterns</a></li>
</ul>
</li>
<li id="menu-item-118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-118 menu-item-graphics"><a href="https://www.smashingmagazine.com/category/graphics/">Graphics</a>
<ul class="sub-menu">
	<li id="menu-item-2264" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2264 menu-item-photoshop"><a href="https://www.smashingmagazine.com/tag/photoshop/">Photoshop</a></li>
	<li id="menu-item-160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-160 menu-item-fireworks"><a href="https://www.smashingmagazine.com/category/fireworks/">Fireworks</a></li>
	<li id="menu-item-2283" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2283 menu-item-wallpapers"><a href="https://www.smashingmagazine.com/tag/wallpapers/">Wallpapers</a></li>
	<li id="menu-item-2305" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2305 menu-item-freebies"><a href="https://www.smashingmagazine.com/tag/freebies/">Freebies</a></li>
</ul>
</li>
<li id="menu-item-120" class="menu-item-uxdesign menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-120 menu-item-ux-design"><a href="https://www.smashingmagazine.com/category/uxdesign/">UX Design</a>
<ul class="sub-menu">
	<li id="menu-item-143609" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143609 menu-item-usability"><a href="https://www.smashingmagazine.com/tag/usability/">Usability</a></li>
	<li id="menu-item-143610" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143610 menu-item-user-experience"><a href="https://www.smashingmagazine.com/tag/user-experience/">User Experience</a></li>
	<li id="menu-item-143611" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143611 menu-item-ui-design"><a href="https://www.smashingmagazine.com/tag/ui/">UI Design</a></li>
	<li id="menu-item-143612" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143612 menu-item-e-commerce"><a href="https://www.smashingmagazine.com/tag/e-commerce/">E-Commerce</a></li>
</ul>
</li>
<li id="menu-item-121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-121 menu-item-wordpress"><a href="https://www.smashingmagazine.com/category/wordpress/"><span class="long"><span>Word</span><span>Press</span></span><span class="short">WP</span></a>
<ul class="sub-menu">
	<li id="menu-item-143677" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143677 menu-item-essentials"><a href="https://www.smashingmagazine.com/tag/essentials/">Essentials</a></li>
	<li id="menu-item-143678" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143678 menu-item-techniques"><a href="https://www.smashingmagazine.com/tag/techniques-wp/">Techniques</a></li>
	<li id="menu-item-143679" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143679 menu-item-plugins"><a href="https://www.smashingmagazine.com/tag/plugins/">Plugins</a></li>
	<li id="menu-item-143680" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143680 menu-item-themes"><a href="https://www.smashingmagazine.com/tag/themes/">Themes</a></li>
</ul>
</li>
</ul></div>				</div>
				<div id="content" class="col main">
					<div id="blocked" class="blocked clearfix">

	<figure style="max-width: 24%;min-width: 90px;">
		<a href="https://smashingconf.com">
			<img src="https://www.smashingmagazine.com/wp-content/uploads/2016/11/smashingconf-san-francisco-2017-1.png" alt="Smashing Conf San Francisco">
		</a>
	</figure>

	<p style="font-size: calc(1em + ((0.4vw + 0.25vh) / 2));">
		<strong>We use ad-blockers as well, you know.</strong> We gotta keep those servers running though.
		Did you know that we publish <a href="https://www.smashingmagazine.com/books/">useful books</a> and run
		<a href="https://www.smashingmagazine.com/smashing-workshops/">friendly conferences</a>
		— crafted for pros like yourself? E.g. upcoming <a href="https://smashingconf.com">SmashingConf San Francisco</a>,
		dedicated to smart front-end techniques and design patterns.
	</p>
</div>
<article class="post-272278 post type-post status-publish format-standard has-post-thumbnail hentry category-mobile tag-apps tag-games tag-ios tag-swift" vocab="http://schema.org/" typeof="TechArticle">

		<h2>
		<a property="url" href="https://www.smashingmagazine.com/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-3/" rel="bookmark" title="Read 'How To Build A SpriteKit Game In Swift 3 (Part 3)'"><span property="name">How To Build A SpriteKit Game In Swift 3 (Part 3)</span></a>
	</h2>

			
<ul class="pmd clearfix">
	<li class="a" property="author" typeof="person" resource="#authorname">By <a href="https://www.smashingmagazine.com/author/marcvandehey/" title="Posts by Marc Vandehey" rel="author">Marc Vandehey</a></li>
				<li class="rd" property="datePublished" content="December 13th, 2016">December 13th, 2016</li>
				<li class="tags" property="keywords"><a href="https://www.smashingmagazine.com/tag/apps/">Apps</a><a href="https://www.smashingmagazine.com/tag/games/">Games</a><a href="https://www.smashingmagazine.com/tag/ios/">iOS</a></li>
		<li class="comments" property="discussionUrl"><a href="#comments" title="Comment on How To Build A SpriteKit Game In Swift 3 (Part 3)">0 Comments</a> </li>
		</ul>
	
	<div class="ad ed">
	<div class="oa_zone--ad cad" id="cad" data-ad-name="Medium Rectangle" data-ad-zone="22" data-ad-media="all"></div>
</div>

	<p>Have you ever wondered what it takes to create a <a href="https://developer.apple.com/spritekit/">SpriteKit</a><sup class="po" id="note-1"><a href="#1">1</a></sup> game? Do buttons seem like a bigger task than they should be? Ever wonder how to persist settings in a game? Game-making has never been easier on iOS since the introduction of SpriteKit. In part three of this three-part series, we will finish up our RainCat game and complete our introduction to SpriteKit.</p>
<p>If you missed out on the <a href="https://www.smashingmagazine.com/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-2/">previous lesson</a><sup class="po" id="note-5"><a href="#5">5</a></sup><sup class="po" id="note-2"><a href="#2">2</a></sup>, you can catch up by getting the code <a href="https://github.com/thirteen23/RainCat/releases/tag/smashing-magazine-lesson-two">on GitHub</a><sup class="po" id="note-3"><a href="#3">3</a></sup>. Remember that this tutorial requires Xcode 8 and Swift 3.</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_header_sm-preview-opt-1.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_header_sm-preview-opt-1.png" alt="Raincat, lesson 3" width="500" height="300" /></a><sup class="po" id="note-4"><a href="#4">4</a></sup><br />
<figcaption>RainCat, lesson 3</figcaption>
</figure>
<p>This is lesson three in our RainCat journey. In the <a href="https://www.smashingmagazine.com/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-2/">previous lesson</a><sup class="po" id="note-5"><a href="#5">5</a></sup><sup class="po" id="note-2"><a href="#2">2</a></sup>, we had a long day going though some simple animations, cat behaviors, quick sound effects and background music.</p>
<p>Today we will focus on the following:</p>
<ul>
<li>heads-up display (HUD) for scoring;</li>
<li>main menu — with buttons;</li>
<li>options for muting sounds;</li>
<li>game-quitting option.</li>
</ul>
<h4  id="even-more-assets">Even More Assets <a href="#even-more-assets" aria-label="Link to section 'Even More Assets'" class="sr hsl">Link</a></h4>
<p>The assets for the final lesson are <a href="https://github.com/thirteen23/RainCat/blob/smashing-day-3/dayThreeAssets.zip">available on GitHub</a><sup class="po" id="note-6"><a href="#6">6</a></sup>. Drag the images into <code>Assets.xcassets</code> again, just as we did in the previous lessons.</p>
<h3  id="heads-up">Heads Up! <a href="#heads-up" aria-label="Link to section 'Heads Up!'" class="sr hsl">Link</a></h3>
<p>We need a way to keep score. To do this, we can create a heads-up display (HUD). This will be pretty simple; it will be an <code>SKNode</code> that contains the score and a button to quit the game. For now, we will just focus on the score. The font we will be using is Pixel Digivolve, which you can <a href="http://www.dafont.com/pixel-digivolve.font">get at Dafont.com</a><sup class="po" id="note-7"><a href="#7">7</a></sup>. As with using images or sounds that are not yours, read the font&#8217;s license before using it. This one states that it is free for personal use, but if you really like the font, you can donate to the author from the page. You can&#8217;t always make everything yourself, so giving back to those who have helped you along the way is nice.</p>
<p>Next, we need to add the custom font to the project. This process can be tricky the first time.</p>
<p>Download and move the font into the project folder, under a &#8220;Fonts&#8221; folder. We&#8217;ve done this a few times in the previous lessons, so we&#8217;ll go through this process a little more quickly. Add a group named <code>Fonts</code> to the project, and add the <code>Pixel digivolve.otf</code> file.</p>
<p>Now comes the tricky part. If you miss this part, you probably won&#8217;t be able to use the font. We need to add it to our <code>Info.plist</code> file. This file is in the left pane of Xcode. Click it and you will see the property list (or <code>plist</code>). Right-click on the list, and click &#8220;Add Row.&#8221;</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2016/10/settings_infoplist-preview-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2016/10/settings_infoplist-preview-opt.png" alt="Add Row" width="500" height="" /></a><sup class="po" id="note-8"><a href="#8">8</a></sup><br />
<figcaption>Add a row to the <code>plist</code>.</figcaption>
</figure>
<p>When the new row comes up, enter in the following:</p>
<pre><code class="language-c">Fonts provided by application</code></pre>
<p>Then, under <code>Item 0</code>, we need to add our font&#8217;s name. The <code>plist</code> should look like the following:</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2016/10/settings_plistfont-preview-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2016/10/settings_plistfont-preview-opt.png" alt="Pixel digivolve.otf" width="448" height="63" /></a><sup class="po" id="note-9"><a href="#9">9</a></sup><br />
<figcaption>Font added to <code>plist</code> successfully!</figcaption>
</figure>
<p>The font should be ready to use! We should do a quick test to make sure it works as intended. Move to <code>GameScene.swift</code>, and in <code>sceneDidLoad</code> add the following code at the top of the function:</p>
<pre><code class="language-c">let label = SKLabelNode(fontNamed: "PixelDigivolve")
label.text = "Hello World!"
label.position = CGPoint(x: size.width / 2, y: size.height / 2)
label.zPosition = 1000

addChild(label)</code></pre>
<p>Does it work?</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2016/10/screen_withtext-preview-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2016/10/screen_withtext-preview-opt.png" alt="Hello world!" width="500" height="375" /></a><sup class="po" id="note-10"><a href="#10">10</a></sup><br />
<figcaption>Testing our <code>SKLabelNode</code>. Oh no! The &#8220;Hello World&#8221; label is back.</figcaption>
</figure>
<p>If it works, then you&#8217;ve done everything correctly. If not, then something is wrong. Code With Chris has a more in-depth <a href="http://codewithchris.com/common-mistakes-with-adding-custom-fonts-to-your-ios-app/">troubleshooting guide</a><sup class="po" id="note-11"><a href="#11">11</a></sup>, but note that it is for an older version of Swift, so you will have to make minor tweaks to bring it up to Swift 3.</p>
<p>Now that we can load in custom fonts, we can start on our HUD. Delete the &#8220;Hello World&#8221; label, because we only used it to make sure our font loads. The HUD will be an <code>SKNode</code>, acting like a container for our HUD elements. This is the same process we followed when creating the background node in lesson one.</p>
<p>Create the <code>HudNode.swift</code> file using the usual methods, and enter the following code:</p>
<pre><code class="language-c">import SpriteKit

class HudNode : SKNode {
  private let scoreKey = "RAINCAT_HIGHSCORE"
  private let scoreNode = SKLabelNode(fontNamed: "PixelDigivolve")
  private(set) var score : Int = 0
  private var highScore : Int = 0
  private var showingHighScore = false

  /// Set up HUD here.
  public func setup(size: CGSize) {
    let defaults = UserDefaults.standard

    highScore = defaults.integer(forKey: scoreKey)

    scoreNode.text = "\(score)"
    scoreNode.fontSize = 70
    scoreNode.position = CGPoint(x: size.width / 2, y: size.height - 100)
    scoreNode.zPosition = 1

    addChild(scoreNode)
  }

  /// Add point.
  /// - Increments the score.
  /// - Saves to user defaults.
  /// - If a high score is achieved, then enlarge the scoreNode and update the color.
  public func addPoint() {
    score += 1

    updateScoreboard()

    if score &gt; highScore {

      let defaults = UserDefaults.standard

      defaults.set(score, forKey: scoreKey)

      if !showingHighScore {
        showingHighScore = true

        scoreNode.run(SKAction.scale(to: 1.5, duration: 0.25))
        scoreNode.fontColor = SKColor(red:0.99, green:0.92, blue:0.55, alpha:1.0)
      }
    }
  }

  /// Reset points.
  /// - Sets score to zero.
  /// - Updates score label.
  /// - Resets color and size to default values.
  public func resetPoints() {
    score = 0

    updateScoreboard()

    if showingHighScore {
      showingHighScore = false

      scoreNode.run(SKAction.scale(to: 1.0, duration: 0.25))
      scoreNode.fontColor = SKColor.white
    }
  }

  /// Updates the score label to show the current score.
  private func updateScoreboard() {
    scoreNode.text = "\(score)"
  }
}</code></pre>
<p>Before we do anything else, open up <code>Constants.swift</code> and add the following line to the bottom of the file — we will be using it to retrieve and persist the high score:</p>
<pre><code class="language-c">let ScoreKey = "RAINCAT_HIGHSCORE"</code></pre>
<p>In the code, we have five variables that pertain to the scoreboard. The first variable is the actual <code>SKLabelNode</code>, which we use to present the label. Next is our variable to hold the current score; then the variable that holds the best score. The last variable is a boolean that tells us whether we are currently presenting the high score (we use this to establish whether we need to run an <code>SKAction</code> to increase the scale of the scoreboard and to colorize it to the yellow of the floor).</p>
<p>The first function, <code>setup(size:)</code>, is there just to set everything up. We set up the <code>SKLabelNode</code> the same way we did earlier. The <code>SKNode</code> class does not have any size properties by default, so we need to create a way to set a size to position our <code>scoreNode</code> label. We&#8217;re also fetching the current high score from <a href="https://developer.apple.com/reference/foundation/userdefaults"><code>UserDefaults</code></a><sup class="po" id="note-12"><a href="#12">12</a></sup>. This is a quick and easy way to save small chunks of data, but it isn&#8217;t secure. Because we&#8217;re not worried about security for this example, <code>UserDefaults</code> is perfectly fine.</p>
<p>In our <code>addPoint()</code>, we&#8217;re incrementing the current <code>score</code> variable and checking whether the user has gotten a high score. If they have a high score, then we save that score to <code>UserDefaults</code> and check whether we are currently showing the best score. If the user has achieved a high score, we can animate the size and color of <code>scoreNode</code>.</p>
<p>In the <code>resetPoints()</code> function, we set the current score to <code>0</code>. We then need to check whether we were showing the high score, and reset the size and color to the default values if needed.</p>
<p>Finally, we have a small function named <code>updateScoreboard</code>. This is an internal function to set the score to <code>scoreNode</code>&#8216;s text. This is called in both <code>addPoint()</code> and <code>resetPoints()</code>.</p>
<h3  id="hooking-up-the-hud">Hooking Up The HUD <a href="#hooking-up-the-hud" aria-label="Link to section 'Hooking Up The HUD'" class="sr hsl">Link</a></h3>
<p>We need to test whether our HUD is working correctly. Move over to <code>GameScene.swift</code>, and add the following line below the <code>foodNode</code> variable at the top of the file:</p>
<pre><code class="language-c">private let hudNode = HudNode()</code></pre>
<p>Add the following two lines in the <code>sceneDidLoad()</code> function, near the top:</p>
<pre><code class="language-c">hudNode.setup(size: size)
addChild(hudNode)</code></pre>
<p>Then, in the <code>spawnCat()</code> function, reset the points in case the cat has fallen off the screen. Add the following line after adding the cat sprite to the scene:</p>
<pre><code class="language-c">hudNode.resetPoints()</code></pre>
<p>Next, in the <code>handleCatCollision(contact:)</code> function, we need to reset the score again when the cat is hit by rain. In the <code>switch</code> statement at the end of the function — when the other body is a <code>RainDropCategory</code> — add the following line:</p>
<pre><code class="language-c">hudNode.resetPoints()</code></pre>
<p>Finally, we need to tell the scoreboard when the user has earned points. At the end of the file in <code>handleFoodHit(contact:)</code>, find the following lines up to here:</p>
<pre><code class="language-c">//TODO increment points
print("fed cat")</code></pre>
<p>And replace them with this:</p>
<pre><code class="language-c">hudNode.addPoint()</code></pre>
<p>Voilà!</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_scoring-preview-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_scoring-preview-opt.png" alt="HUD unlocked!" width="500" height="375" /></a><sup class="po" id="note-13"><a href="#13">13</a></sup><br />
<figcaption>HUD unlocked!</figcaption>
</figure>
<p>You should see the HUD in action. Run around and collect some food. The first time you collect food, you should see the score turn yellow and grow in scale. When you see this happen, let the cat get hit. If the score resets, then you&#8217;ll know you are on the right track!</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_scoreincrease-preview-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_scoreincrease-preview-opt.png" alt="High Score!" width="500" height="375" /></a><sup class="po" id="note-14"><a href="#14">14</a></sup><br />
<figcaption>Highest score ever (… at the time of writing)!</figcaption>
</figure>
<h3  id="the-next-scene">The Next Scene <a href="#the-next-scene" aria-label="Link to section 'The Next Scene'" class="sr hsl">Link</a></h3>
<p>That&#8217;s right, we are moving to another scene! In fact, when completed, this will be the first screen of our app. Before you do anything else, open up <code>Constants.swift</code> and add the following line to the bottom of the file — we will be using it to retrieve and persist the high score:</p>
<pre><code class="language-c">let ScoreKey = "RAINCAT_HIGHSCORE"</code></pre>
<p>Create the new scene, place it under the &#8220;Scenes&#8221; folder, and call it <code>MenuScene.swift</code>. Enter the following code in the <code>MenuScene.swift</code> file:</p>
<pre><code class="language-c">import SpriteKit

class MenuScene : SKScene {
  let startButtonTexture = SKTexture(imageNamed: "button_start")
  let startButtonPressedTexture = SKTexture(imageNamed: "button_start_pressed")
  let soundButtonTexture = SKTexture(imageNamed: "speaker_on")
  let soundButtonTextureOff = SKTexture(imageNamed: "speaker_off")

  let logoSprite = SKSpriteNode(imageNamed: "logo")
  var startButton : SKSpriteNode! = nil
  var soundButton : SKSpriteNode! = nil

  let highScoreNode = SKLabelNode(fontNamed: "PixelDigivolve")

  var selectedButton : SKSpriteNode?

  override func sceneDidLoad() {
    backgroundColor = SKColor(red:0.30, green:0.81, blue:0.89, alpha:1.0)

    //Set up logo - sprite initialized earlier
    logoSprite.position = CGPoint(x: size.width / 2, y: size.height / 2 + 100)

    addChild(logoSprite)

    //Set up start button
    startButton = SKSpriteNode(texture: startButtonTexture)
    startButton.position = CGPoint(x: size.width / 2, y: size.height / 2 - startButton.size.height / 2)

    addChild(startButton)

    let edgeMargin : CGFloat = 25

    //Set up sound button
    soundButton = SKSpriteNode(texture: soundButtonTexture)
    soundButton.position = CGPoint(x: size.width - soundButton.size.width / 2 - edgeMargin, y: soundButton.size.height / 2 + edgeMargin)

    addChild(soundButton)

    //Set up high-score node
    let defaults = UserDefaults.standard

    let highScore = defaults.integer(forKey: ScoreKey)

    highScoreNode.text = "\(highScore)"
    highScoreNode.fontSize = 90
    highScoreNode.verticalAlignmentMode = .top
    highScoreNode.position = CGPoint(x: size.width / 2, y: startButton.position.y - startButton.size.height / 2 - 50)
    highScoreNode.zPosition = 1

    addChild(highScoreNode)
  }
}</code></pre>
<p>Because this scene is relatively simple, we won&#8217;t be creating any special classes. Our scene will consist of two buttons. These could be (and possibly deserve to be) their own class of <code>SKSpriteNodes</code>, but because they are different enough, we will not need to create new classes for them. This is an important tip for when you build your own game: You need to be able to determine where to stop and refactor code when things get complex. Once you&#8217;ve added more than three or four buttons to a game, it might be time to stop and refactor the menu button&#8217;s code into its own class.</p>
<p>The code above isn&#8217;t doing anything special; it is setting the positions of four sprites. We are also setting the scene&#8217;s background color, so that the whole background is the correct value. A nice tool to generate color codes from HEX strings for Xcode is <a href="http://uicolor.xyz/">UI Color</a><sup class="po" id="note-15"><a href="#15">15</a></sup>. The code above is also setting the textures for our button states. The button to start the game has a normal state and a pressed state, whereas the sound button is a toggle. To simplify things for the toggle, we will be changing the alpha value of the sound button upon the user&#8217;s press. We are also pulling and setting the high-score <code>SKLabelNode</code>.</p>
<p>Our <code>MenuScene</code> is looking pretty good. Now we need to show the scene when the app loads. Move to <code>GameViewController.swift</code> and find the following line:</p>
<pre><code class="language-c">let sceneNode = GameScene(size: view.frame.size)</code></pre>
<p>Replace it with this:</p>
<pre><code class="language-c">let sceneNode = MenuScene(size: view.frame.size)</code></pre>
<p>This small change will load <code>MenuScene</code> by default, instead of <code>GameScene</code>.</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_newscene-preview-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_newscene-preview-opt.png" alt="Our new scene!" width="500" height="375" /></a><sup class="po" id="note-16"><a href="#16">16</a></sup><br />
<figcaption>Our new scene! Note the 1.0 frames per second: Nothing is moving, so no need to update anything.</figcaption>
</figure>
<h3  id="button-states">Button States <a href="#button-states" aria-label="Link to section 'Button States'" class="sr hsl">Link</a></h3>
<p>Buttons can be tricky in SpriteKit. Plenty of third-party options are available (I even made one myself), but in theory you only need to know the three touch methods:</p>
<ul>
<li><code>touchesBegan(_ touches: with event:)</code></li>
<li><code>touchesMoved(_ touches: with event:)</code></li>
<li><code>touchesEnded(_ touches: with event:)</code></li>
</ul>
<p>We covered this briefly when updating the umbrella, but now we need to know the following: which button was touched, whether the user released their tap or clicked that button, and whether the user is still touching it. This is where our <code>selectedButton</code> variable comes into play. When a touch begin, we can capture the button that the user started clicking with that variable. If they drag outside the button, we can handle this and give the appropriate texture to it. When they release the touch, we can then see whether they are still touching inside the button. If they are, then we can apply the associated action to it. Add the following lines to the bottom of <code>MenuScene.swift</code>:</p>
<pre><code class="language-c">override func touchesBegan(_ touches: Set, with event: UIEvent?) {
  if let touch = touches.first {
    if selectedButton != nil {
      handleStartButtonHover(isHovering: false)
      handleSoundButtonHover(isHovering: false)
    }

    // Check which button was clicked (if any)
    if startButton.contains(touch.location(in: self)) {
      selectedButton = startButton
      handleStartButtonHover(isHovering: true)
    } else if soundButton.contains(touch.location(in: self)) {
      selectedButton = soundButton
      handleSoundButtonHover(isHovering: true)
    }
  }
}

override func touchesMoved(_ touches: Set, with event: UIEvent?) {
  if let touch = touches.first {

    // Check which button was clicked (if any)
    if selectedButton == startButton {
      handleStartButtonHover(isHovering: (startButton.contains(touch.location(in: self))))
    } else if selectedButton == soundButton {
      handleSoundButtonHover(isHovering: (soundButton.contains(touch.location(in: self))))
    }
  }
}

override func touchesEnded(_ touches: Set, with event: UIEvent?) {
  if let touch = touches.first {

    if selectedButton == startButton {
      // Start button clicked
      handleStartButtonHover(isHovering: false)

      if (startButton.contains(touch.location(in: self))) {
        handleStartButtonClick()
      }

    } else if selectedButton == soundButton {
      // Sound button clicked
      handleSoundButtonHover(isHovering: false)

      if (soundButton.contains(touch.location(in: self))) {
        handleSoundButtonClick()
      }
    }
  }

  selectedButton = nil
}

/// Handles start button hover behavior
func handleStartButtonHover(isHovering : Bool) {
  if isHovering {
    startButton.texture = startButtonPressedTexture
  } else {
    startButton.texture = startButtonTexture
  }
}

/// Handles sound button hover behavior
func handleSoundButtonHover(isHovering : Bool) {
  if isHovering {
    soundButton.alpha = 0.5
  } else {
    soundButton.alpha = 1.0
  }
}

/// Stubbed out start button on click method
func handleStartButtonClick() {
  print("start clicked")
}

/// Stubbed out sound button on click method
func handleSoundButtonClick() {
  print("sound clicked")
}</code></pre>
<p>This is simple button-handling for our two buttons. In <code>touchesBegan(_ touches: with events:)</code>, we start off by checking whether we have any currently selected buttons. If we do, we need to reset the state of the button to unpressed. Then, we need to check whether any button is pressed. If one is pressed, it will show the highlighted state for the button. Then, we set <code>selectedButton</code> to the button for use in the other two methods.</p>
<p>In <code>touchesMoved(_ touches: with events:)</code>, we check which button was originally touched. Then, we check whether the current touch is still within the bounds of <code>selectedButton</code>, and we update the highlighted state from there. The <code>startButton</code>&#8216;s highlighted state changes the texture to the pressed-state&#8217;s texture, where the <code>soundButton</code>&#8216;s highlighted state has the alpha value of the sprite set to 50%.</p>
<p>Finally, in <code>touchesEnded(_ touches: with event:)</code>, we check again which button is selected, if any, and then whether the touch is still within the bounds of the button. If all cases are satisfied, we call <code>handleStartButtonClick()</code> or <code>handleSoundButtonClick()</code> for the correct button.</p>
<h3  id="a-time-for-action">A Time For Action <a href="#a-time-for-action" aria-label="Link to section 'A Time For Action'" class="sr hsl">Link</a></h3>
<p>Now that we have the basic button behavior down, we need an event to trigger when they are clicked. The easier button to implement is <code>startButton</code>. On click, we only need to present the <code>GameScene</code>. Update <code>handleStartButtonClick()</code> in the <code>MenuScene.swift</code> function to the following code:</p>
<pre><code class="language-c">func handleStartButtonClick() {
  let transition = SKTransition.reveal(with: .down, duration: 0.75)
  let gameScene = GameScene(size: size)
  gameScene.scaleMode = scaleMode
  view?.presentScene(gameScene, transition: transition)
}</code></pre>
<p>If you run the app now and press the button, the game will start!</p>
<p>Now we need to implement the mute toggle. We already have a sound manager, but we need to be able to tell it whether muting is on or off. In <code>Constants.swift</code>, we need to add a key to persist when muting is on. Add the following line:</p>
<pre><code class="language-c">let MuteKey = "RAINCAT_MUTED"</code></pre>
<p>We will use this to save a boolean value to <code>UserDefaults</code>. Now that this is set up, we can move into <code>SoundManager.swift</code>. This is where we will check and set <code>UserDefaults</code> to see whether muting is on or off. At the top of the file, under the <code>trackPosition</code> variable, add the following line:</p>
<pre><code class="language-c">private(set) var isMuted = false</code></pre>
<p>This is the variable that the main menu (and anything else that will play sound) checks to determine whether sound is allowed. We initialize it as <code>false</code>, but now we need to check <code>UserDefaults</code> to see what the user wants. Replace the <code>init()</code> function with the following:</p>
<pre><code class="language-c">private override init() {
  //This is private, so you can only have one Sound Manager ever.
  trackPosition = Int(arc4random_uniform(UInt32(SoundManager.tracks.count)))

  let defaults = UserDefaults.standard

  isMuted = defaults.bool(forKey: MuteKey)
}
</code></pre>
<p>Now that we have a default value for <code>isMuted</code>, we need the ability to change it. Add the following code to the bottom of <code>SoundManager.swift</code>:</p>
<pre><code class="language-c">func toggleMute() -&gt; Bool {
  isMuted = !isMuted

  let defaults = UserDefaults.standard
  defaults.set(isMuted, forKey: MuteKey)
  defaults.synchronize()

  if isMuted {
    audioPlayer?.stop()
  } else {
    startPlaying()
  }

  return isMuted
}</code></pre>
<p>This method will toggle our muted variable, as well as update <code>UserDefaults</code>. If the new value is not muted, playback of the music will begin; if the new value is muted, playback will not begin. Otherwise, we will stop the current track from playing. After this, we need to edit the <code>if</code> statement in <code>startPlaying()</code>.</p>
<p>Find the following line:</p>
<pre><code class="language-c">if audioPlayer == nil || audioPlayer?.isPlaying == false {</code></pre>
<p>And replace it with this:</p>
<pre><code class="language-c">if !isMuted &amp;&amp; (audioPlayer == nil || audioPlayer?.isPlaying == false) {</code></pre>
<p>Now, if muting is off and either the audio player is not set or the current audio player is no longer playing, we will play the next track.</p>
<p>From here, we can move back into <code>MenuScene.swift</code> to finish up our mute button. Replace <code>handleSoundbuttonClick()</code> with the following code:</p>
<pre><code class="language-c">func handleSoundButtonClick() {
  if SoundManager.sharedInstance.toggleMute() {
    //Is muted
    soundButton.texture = soundButtonTextureOff
  } else {
    //Is not muted
    soundButton.texture = soundButtonTexture
  }
}</code></pre>
<p>This toggles the sound in <code>SoundManager</code>, checks the result and then appropriately sets the texture to show the user whether the sound is muted or not. We are almost done! We only need to set the initial texture of the button on launch. In <code>sceneDidLoad()</code>, find the following line:</p>
<pre><code class="language-c">soundButton = SKSpriteNode(texture: soundButtonTexture)</code></pre>
<p>And replace it with this:</p>
<pre><code class="language-c">soundButton = SKSpriteNode(texture: SoundManager.sharedInstance.isMuted ?
  soundButtonTextureOff : soundButtonTexture)</code></pre>
<p>The example above uses a <a href="https://developer.apple.com/library/ios/documentation/Swift/Conceptual/Swift_Programming_Language/BasicOperators.html#//apple_ref/doc/uid/TP40014097-CH6-ID60">ternary operator</a><sup class="po" id="note-17"><a href="#17">17</a></sup> to set the correct texture.</p>
<p>Now that the music is hooked up, we can move to <code>CatSprite.swift</code> to disable the cat meowing when muting is on. In the <code>hitByRain()</code>, we can add the following <code>if</code> statement after removing the walking action:</p>
<pre><code class="language-c">if SoundManager.sharedInstance.isMuted {
  return
}</code></pre>
<p>This statement will return whether the user has muted the app. Because of this, we will completely ignore our <code>currentRainHits</code>, <code>maxRainHits</code> and meowing sound effects.</p>
<p>After all of that, now it is time to try out our mute button. Run the app and verify whether it is playing and muting sounds appropriately. Mute the sound, close the app, and reopen it. Make sure that the mute setting persists. Note that if you just mute and rerun the app from Xcode, you might not have given enough time for <code>UserDefaults</code> to save. Play the game, and make sure the cat never meows when you are muted.</p>
<figure><iframe src="https://player.vimeo.com/video/189700402" width="640" height="481" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe></p>
<figcaption>Testing out the button functionality.</figcaption>
</figure>
<h3  id="exiting-the-game">Exiting The Game <a href="#exiting-the-game" aria-label="Link to section 'Exiting The Game'" class="sr hsl">Link</a></h3>
<p>Now that we have the first type of button for the main menu, we can get into some tricky business by adding the quit button to our game scene. Some interesting interactions can come up with our style of game; currently, the umbrella will move to wherever the user touches or moves their touch. Obviously, the umbrella moving to the quit button when the user is attempting to exit the game is a pretty poor user experience, so we will attempt to stop this from happening.</p>
<p>The quit button we are implementing will mimic the start game button that we added earlier, with much of the process staying the same. The change will be in how we handle touches. Get your <code>quit_button</code> and <code>quit_button_pressed</code> assets into the <code>Assets.xcassets</code> file, and add the following code to the <code>HudNode.swift</code> file:</p>
<pre><code class="language-c">private var quitButton : SKSpriteNode!
private let quitButtonTexture = SKTexture(imageNamed: "quit_button")
private let quitButtonPressedTexture = SKTexture(imageNamed: "quit_button_pressed")</code></pre>
<p>This will handle our <code>quitButton</code> reference, along with the textures that we will set for the button states. To ensure that we don&#8217;t inadvertently update the umbrella while trying to quit, we need a variable that tells the HUD (and the game scene) that we are interacting with the quit button and not the umbrella. Add the following code below the <code>showingHighScore</code> boolean variable:</p>
<pre><code class="language-c">private(set) var quitButtonPressed = false</code></pre>
<p>Again, this is a variable that only the <code>HudNode</code> can set but that other classes can check. Now that our variables are set up, we can add in the button to the HUD. Add the following code to the <code>setup(size:)</code> function:</p>
<pre><code class="language-c">quitButton = SKSpriteNode(texture: quitButtonTexture)
let margin : CGFloat = 15
quitButton.position = CGPoint(x: size.width - quitButton.size.width - margin, y: size.height - quitButton.size.height - margin)
quitButton.zPosition = 1000

addChild(quitButton)</code></pre>
<p>The code above will set the quit button with the texture of our non-pressed state. We&#8217;re also setting the position to the upper-right corner and setting the <code>zPosition</code> to a high number in order to force it to always draw on top. If you run the game now, it will show up in <code>GameScene</code>, but it will not be clickable yet.</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_quit-preview-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_quit-preview-opt.png" alt="Quit button" width="500" height="375" /></a><sup class="po" id="note-18"><a href="#18">18</a></sup><br />
<figcaption>Note the new quit button in our HUD.</figcaption>
</figure>
<p>Now that the button has been positioned, we need to be able to interact with it. Right now, the only place where we have interaction in <code>GameScene</code> is when we are interacting with <code>umbrellaSprite</code>. In our example, the HUD will have priority over the umbrella, so that users don&#8217;t have to move the umbrella out of the way in order to exit. We can create the same functions in <code>HudNode.swift</code> to mimic the touch functionality in <code>GameScene.swift</code>. Add the following code to <code>HudNode.swift</code>:</p>
<pre><code class="language-c">func touchBeganAtPoint(point: CGPoint) {
  let containsPoint = quitButton.contains(point)

  if quitButtonPressed &amp;&amp; !containsPoint {
    //Cancel the last click
    quitButtonPressed = false
    quitButton.texture = quitButtonTexture
  } else if containsPoint {
    quitButton.texture = quitButtonPressedTexture
    quitButtonPressed = true
  }
}

func touchMovedToPoint(point: CGPoint) {
  if quitButtonPressed {
    if quitButton.contains(point) {
      quitButton.texture = quitButtonPressedTexture
    } else {
      quitButton.texture = quitButtonTexture
    }
  }
}

func touchEndedAtPoint(point: CGPoint) {
  if quitButton.contains(point) {
    //TODO tell the gamescene to quit the game
  }

  quitButton.texture = quitButtonTexture
}</code></pre>
<p>The code above is a lot like the code that we created for <code>MenuScene</code>. The difference is that there is only one button to keep track of, so we can handle everything within these touch methods. Also, because we will know the location of the touch in <code>GameScene</code>, we can just check whether our button contains the touch point.</p>
<p>Move over to <code>GameScene.swift</code>, and replace the <code>touchesBegan(_ touches with event:)</code> and <code>touchesMoved(_ touches: with event:)</code> methods with the following code:</p>
<pre><code class="language-c">override func touchesBegan(_ touches: Set, with event: UIEvent?) {
  let touchPoint = touches.first?.location(in: self)

  if let point = touchPoint {
    hudNode.touchBeganAtPoint(point: point)

    if !hudNode.quitButtonPressed {
      umbrellaNode.setDestination(destination: point)
    }
  }
}

override func touchesMoved(_ touches: Set, with event: UIEvent?) {
  let touchPoint = touches.first?.location(in: self)

  if let point = touchPoint {
    hudNode.touchMovedToPoint(point: point)

    if !hudNode.quitButtonPressed {
      umbrellaNode.setDestination(destination: point)
    }
  }
}

override func touchesEnded(_ touches: Set, with event: UIEvent?) {
  let touchPoint = touches.first?.location(in: self)

  if let point = touchPoint {
    hudNode.touchEndedAtPoint(point: point)
  }
}
</code></pre>
<p>Here, each method handles everything in pretty much the same way. We&#8217;re telling the HUD that the user has interacted with the scene. Then, we check whether the quit button is currently capturing the touches. If it is not, then we move the umbrella. We&#8217;ve also added the <code>touchesEnded(_ touches: with event:)</code> function to handle the end of the click for the quit button, but we are still not using it for <code>umbrellaSprite</code>.</p>
<figure><iframe src="https://player.vimeo.com/video/189701318" width="640" height="482" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe></p>
<figcaption>Clicking the quit button will not move the umbrella, but clicking elsewhere will.</figcaption>
</figure>
</figure>
<p>Now that we have a button, we need a way to have it affect <code>GameScene</code>. Add the following line to the top of <code>HudeNode.swift</code>:</p>
<pre><code class="language-c">var quitButtonAction : (() -&gt; ())?</code></pre>
<p>This is a generic <a href="https://www.weheartswift.com/closures/">closure</a><sup class="po" id="note-19"><a href="#19">19</a></sup> that has no input and no output. We will set this with code in the <code>GameScene.swift</code> file and call it when we click the button in <code>HudNode.swift</code>. Then, we can replace the <code>TODO</code> in the code we created earlier in the <code>touchEndedAtPoint(point:)</code> function with this:</p>
<pre><code class="language-c">if quitButton.contains(point) &amp;&amp; quitButtonAction != nil {
  quitButtonAction!()
}</code></pre>
<p>Now, if we set the <code>quitButtonAction</code> closure, it will be called from this point.</p>
<p>To set up the <code>quitButtonAction</code> closure, we need to move over to <code>GameScene.swift</code>. In <code>sceneDidLoad()</code>, we can replace our HUD setup with the following code:</p>
<pre><code class="language-c">hudNode.setup(size: size)

hudNode.quitButtonAction = {
  let transition = SKTransition.reveal(with: .up, duration: 0.75)

  let gameScene = MenuScene(size: self.size)
  gameScene.scaleMode = self.scaleMode

  self.view?.presentScene(gameScene, transition: transition)

  self.hudNode.quitButtonAction = nil
}

addChild(hudNode)
</code></pre>
<p>Run the app, press play, and then press quit. If you are back at the main menu, then your quit button is working as intended. In the closure that we created, we initialized a transition to the <code>MenuScene</code>. And we set this closure to the <code>HUD</code> node to run when the quit button is clicked. Another important line here is when we set the <code>quitButtonAction</code> to <code>nil</code>. The reason for this is that a retain cycle is occurring. The scene is holding a reference to the HUD where the HUD is holding a reference to the scene. Because there is a reference to both objects, neither will be disposed of when it comes time for garbage collection. In this case, every time we enter and leave <code>GameScene</code>, another instance of it will be created and never released. This is bad for performance, and the app will eventually run out of memory. There are a number of ways to avoid this, but in our case we can just remove the reference to <code>GameScene</code> from the HUD, and the scene and HUD will be terminated once we go back to the <code>MenuScene</code>. <a href="http://krakendev.io/blog/weak-and-unowned-references-in-swift">Krakendev has a deeper explanation</a><sup class="po" id="note-20"><a href="#20">20</a></sup> of reference types and how to avoid these cycles.</p>
<p>Now, move to <code>GameViewController.swift</code>, and remove or comment out the following three lines of code:</p>
<pre><code class="language-c">view.showsPhysics = true
view.showsFPS = true
view.showsNodeCount = true</code></pre>
<p>With the debugging data out of the way, the game is looking really good! Congratulations: We are currently into beta! Check out the final code from today <a href="https://github.com/thirteen23/RainCat/releases/tag/smashing-magazine-lesson-three">on GitHub</a><sup class="po" id="note-21"><a href="#21">21</a></sup>.</p>
<h3  id="final-thoughts">Final Thoughts <a href="#final-thoughts" aria-label="Link to section 'Final Thoughts'" class="sr hsl">Link</a></h3>
<p>This is the final lesson of a three-part tutorial, and if you made it this far, you just did a lot of work on your game. In this tutorial, you went from a scene that had absolutely nothing in it, to a completed game. Congrats! In <a href="https://www.smashingmagazine.com/2016/11/how-to-build-a-spritekit-game-in-swift-3-part-1/">lesson one</a><sup class="po" id="note-22"><a href="#22">22</a></sup>, we added the floor, raindrops, background and umbrella sprites. We also played around with physics and made sure that our raindrops don&#8217;t pile up. We started out with collision detection and worked on culling nodes so that we would not run out of memory. We also added some user interaction by allowing the umbrella to move around towards where the user touches on the screen.</p>
<p>In <a href="https://www.smashingmagazine.com/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-2/">lesson two</a><sup class="po" id="note-23"><a href="#23">23</a></sup>, we added the cat and food, along with custom spawning methods for each of them. We updated our collision detection to allow for the cat and food sprites. We also worked on the movement of the cat. The cat gained a purpose: Eat every bit of food available. We added simple animation for the cat and added custom interactions between the cat and the rain. Finally, we added sound effects and music to make it feel like a complete game.</p>
<p>In this last lesson, we created a heads-up display to hold our score label, as well as our quit button. We handled actions across nodes and enabled the user to quit with a callback from the HUD node. We also added another scene that the user can launch into and can get back to after clicking the quit button. We handled the process for starting the game and for controlling sound in the game.</p>
<h4  id="where-to-go-from-here">Where To Go From Here <a href="#where-to-go-from-here" aria-label="Link to section 'Where To Go From Here'" class="sr hsl">Link</a></h4>
<p>We put in a lot of time to get this far, but there is still a lot of work that can go into this game. RainCat continues development still, and it is <a href="https://itunes.apple.com/us/app/raincat/id1152624676?ls=1&amp;mt=8">available in the App Store</a><sup class="po" id="note-24"><a href="#24">24</a></sup>. Below is a list of wants and needs to be added. Some of the items have been added, while others are still pending:</p>
<ul>
<li>Add in icons and a splash screen.</li>
<li>Finalize the main menu (simplified for the tutorial).</li>
<li>Fix bugs, including rogue raindrops and multiple food spawning.</li>
<li>Refactor and optimize the code.</li>
<li>Change the color palette of the game based on the score.</li>
<li>Update the difficulty based on the score.</li>
<li>Animate the cat when food is right above it.</li>
<li>Integrate Game Center.</li>
<li>Give credit (including proper credit for music tracks).</li>
</ul>
<p><a href="https://github.com/thirteen23/RainCat">Keep track on GitHub</a><sup class="po" id="note-25"><a href="#25">25</a></sup> because these changes will be made in future. If you have any questions about the code, feel free to drop us a line at <a href="mailto:hello@thirteen23.com">hello@thirteen23.com</a><sup class="po" id="note-26"><a href="#26">26</a></sup> and we can discuss it. If certain topics get enough attention, maybe we can write another article discussing the topic.</p>
<h4  id="thank-you">Thank You! <a href="#thank-you" aria-label="Link to section 'Thank You!'" class="sr hsl">Link</a></h4>
<p>I want to thank all of the people who helped in the process of creating the game and developing the articles that go along with it.</p>
<ul>
<li><a href="https://www.thirteen23.com/about/#cathryn-rowe">Cathryn Rowe</a><sup class="po" id="note-27"><a href="#27">27</a></sup><br />
For the initial art, design and editing, and for publishing the articles in our <a href="https://www.thirteen23.com/garage/">Garage</a><sup class="po" id="note-28"><a href="#28">28</a></sup>.</li>
<li><a href="https://www.thirteen23.com/about/#morgan-wheaton">Morgan Wheaton</a><sup class="po" id="note-29"><a href="#29">29</a></sup><br />
For the final menu design and color palettes (which will look awesome once I actually implement these features — stay tuned).</li>
<li><a href="https://www.thirteen23.com/about/#nikki-clark">Nikki Clark</a><sup class="po" id="note-30"><a href="#30">30</a></sup><br />
For the awesome headers and dividers in the articles and for help with editing the articles.</li>
<li><a href="https://www.thirteen23.com/about/#laura-levisay">Laura Levisay</a><sup class="po" id="note-31"><a href="#31">31</a></sup><br />
For all of the awesome GIFs in the articles and for sending me cute cat GIFs for moral support.</li>
<li><a href="https://www.thirteen23.com/about/#tom-hudson">Tom Hudson</a><sup class="po" id="note-32"><a href="#32">32</a></sup><br />
For help with editing the articles and without whom this series would not have been made at all.</li>
<li><a href="https://www.thirteen23.com/about/#lani-deguire">Lani DeGuire</a><sup class="po" id="note-33"><a href="#33">33</a></sup><br />
For help with editing the articles, which was a ton of work.</li>
<li><a href="https://www.thirteen23.com/about/#jeffrey-moon">Jeff Moon</a><sup class="po" id="note-34"><a href="#34">34</a></sup><br />
For help editing lesson three and the ping-pong. Lots of ping-pong.</li>
<li><a href="https://www.thirteen23.com/about/#tom-nelson">Tom Nelson</a><sup class="po" id="note-35"><a href="#35">35</a></sup><br />
For helping to make sure that the tutorial works as it should.</li>
</ul>
<p>Seriously, it took a ton of people to get everything ready for this article and to release it to the store.</p>
<p>Thank you to everyone who reads this sentence, too.</p>
<p><em property="editor">(da, il, al)</em></p>
<h4  class="po" id="footnotes">Footnotes <a href="#footnotes" aria-label="Link to section 'Footnotes'" class="sr hsl">Link</a></h4><ol class="po"><li id="#1"><a href="#note-1">1 https://developer.apple.com/spritekit/</a></li><li id="#2"><a href="#note-2">2 https://www.smashingmagazine.com/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-2/</a></li><li id="#3"><a href="#note-3">3 https://github.com/thirteen23/RainCat/releases/tag/smashing-magazine-lesson-two</a></li><li id="#4"><a href="#note-4">4 https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_header_sm-preview-opt-1.png</a></li><li id="#5"><a href="#note-5">5 https://www.smashingmagazine.com/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-2/</a></li><li id="#6"><a href="#note-6">6 https://github.com/thirteen23/RainCat/blob/smashing-day-3/dayThreeAssets.zip</a></li><li id="#7"><a href="#note-7">7 http://www.dafont.com/pixel-digivolve.font</a></li><li id="#8"><a href="#note-8">8 https://www.smashingmagazine.com/wp-content/uploads/2016/10/settings_infoplist-preview-opt.png</a></li><li id="#9"><a href="#note-9">9 https://www.smashingmagazine.com/wp-content/uploads/2016/10/settings_plistfont-preview-opt.png</a></li><li id="#10"><a href="#note-10">10 https://www.smashingmagazine.com/wp-content/uploads/2016/10/screen_withtext-preview-opt.png</a></li><li id="#11"><a href="#note-11">11 http://codewithchris.com/common-mistakes-with-adding-custom-fonts-to-your-ios-app/</a></li><li id="#12"><a href="#note-12">12 https://developer.apple.com/reference/foundation/userdefaults</a></li><li id="#13"><a href="#note-13">13 https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_scoring-preview-opt.png</a></li><li id="#14"><a href="#note-14">14 https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_scoreincrease-preview-opt.png</a></li><li id="#15"><a href="#note-15">15 http://uicolor.xyz/</a></li><li id="#16"><a href="#note-16">16 https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_newscene-preview-opt.png</a></li><li id="#17"><a href="#note-17">17 https://developer.apple.com/library/ios/documentation/Swift/Conceptual/Swift_Programming_Language/BasicOperators.html#//apple_ref/doc/uid/TP40014097-CH6-ID60</a></li><li id="#18"><a href="#note-18">18 https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_quit-preview-opt.png</a></li><li id="#19"><a href="#note-19">19 https://www.weheartswift.com/closures/</a></li><li id="#20"><a href="#note-20">20 http://krakendev.io/blog/weak-and-unowned-references-in-swift</a></li><li id="#21"><a href="#note-21">21 https://github.com/thirteen23/RainCat/releases/tag/smashing-magazine-lesson-three</a></li><li id="#22"><a href="#note-22">22 https://www.smashingmagazine.com/2016/11/how-to-build-a-spritekit-game-in-swift-3-part-1/</a></li><li id="#23"><a href="#note-23">23 https://www.smashingmagazine.com/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-2/</a></li><li id="#24"><a href="#note-24">24 https://itunes.apple.com/us/app/raincat/id1152624676?ls=1&amp;mt=8</a></li><li id="#25"><a href="#note-25">25 https://github.com/thirteen23/RainCat</a></li><li id="#26"><a href="#note-26">26 mailto:hello@thirteen23.com</a></li><li id="#27"><a href="#note-27">27 https://www.thirteen23.com/about/#cathryn-rowe</a></li><li id="#28"><a href="#note-28">28 https://www.thirteen23.com/garage/</a></li><li id="#29"><a href="#note-29">29 https://www.thirteen23.com/about/#morgan-wheaton</a></li><li id="#30"><a href="#note-30">30 https://www.thirteen23.com/about/#nikki-clark</a></li><li id="#31"><a href="#note-31">31 https://www.thirteen23.com/about/#laura-levisay</a></li><li id="#32"><a href="#note-32">32 https://www.thirteen23.com/about/#tom-hudson</a></li><li id="#33"><a href="#note-33">33 https://www.thirteen23.com/about/#lani-deguire</a></li><li id="#34"><a href="#note-34">34 https://www.thirteen23.com/about/#jeffrey-moon</a></li><li id="#35"><a href="#note-35">35 https://www.thirteen23.com/about/#tom-nelson</a></li></ol>
	
	
	<div class="lt"><a href="https://www.smashingmagazine.com/tag/apps/">Apps</a><a href="https://www.smashingmagazine.com/tag/games/">Games</a><a href="https://www.smashingmagazine.com/tag/ios/">iOS</a></div>
<p>
	<a href="#top" class="top">&uarr; Back to top</a>

	<a onclick="clicky.log('#sharelink-clicked');" class="sot single" href="https://twitter.com/intent/tweet?original_referer=https://www.smashingmagazine.com/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-3/&#038;source=tweetbutton&#038;text=How%20To%20Build%20A%20SpriteKit%20Game%20In%20Swift%203%20%28Part%203%29&#038;url=https://www.smashingmagazine.com/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-3/&#038;via=smashingmag">Tweet it</a><a onclick="clicky.log('#sharelink-clicked');" class="sot single" href="http://www.facebook.com/sharer/sharer.php?u=https://www.smashingmagazine.com/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-3/">Share on Facebook</a></p>
	</p>

</article>
<div class="bio clearfix">
  <div class="grv">
    <img src="https://secure.gravatar.com/avatar/?s=78&amp;d=mm&amp;r=g" data-src="https://secure.gravatar.com/avatar/c6b2ce6db26059c58e01dcd6f4b96798?s=78&amp;d=mm&amp;r=g" data-src-retina="https://secure.gravatar.com/avatar/c6b2ce6db26059c58e01dcd6f4b96798?s=156&amp;d=mm&amp;r=g" class="avatar" height="78" width="78" >	</div>
	<div class="about">
		<a rel="author" class="poa" href="https://www.smashingmagazine.com/author/marcvandehey/?rel=author" title="Posts by Marc Vandehey">Marc Vandehey</a>		<p><p>Marc is a senior iOS and Android developer at <a href="http://thirteen23.com">thirteen23</a>, a software design and development firm in Austin, Texas. Marc has a passion for playing games and tinkering around with the latest technologies.</p></p>
	</div>
</div>	<div class="ras clearfix">
		<h2>Related Articles</h2>
					<div class="ra clearfix">
				<a class="pp" href="https://www.smashingmagazine.com/2016/12/app-development-showdown-native-hybrid-debate/">
					<img data-src="https://www.smashingmagazine.com/wp-content/uploads/2016/11/1-app-development-showdown-frontpage-opt-178x118.png" width="178" height="178" alt="118" class="wp-post-image" />					<h3>App Development Showdown: Why You Should Care About Revisiting The Native Vs. Hybrid Debate In 2017</h3>
				</a>
			</div>
					<div class="ra clearfix">
				<a class="pp" href="https://www.smashingmagazine.com/2016/12/the-not-so-secret-powers-of-the-mobile-browser/">
					<img data-src="https://www.smashingmagazine.com/wp-content/uploads/2016/12/application-shell-500-opt-178x118.jpeg" width="178" height="178" alt="118" class="wp-post-image" />					<h3>The (Not So) Secret Powers Of The Mobile Browser</h3>
				</a>
			</div>
					<div class="ra clearfix">
				<a class="pp" href="https://www.smashingmagazine.com/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-2/">
					<img data-src="https://www.smashingmagazine.com/wp-content/uploads/2016/10/raincat_header_sm-preview-opt-178x118.png" width="178" height="178" alt="118" class="wp-post-image" />					<h3>How To Build A SpriteKit Game In Swift 3 (Part 2)</h3>
				</a>
			</div>
			</div>
<div class="adv">
	<div class="oa_zone--ad commentspnsrtarget" id="commentspnsrtarget" data-ad-name="Comment Sponsor" data-ad-zone="26" data-ad-media="all"></div>
</div>

<ul id="comments" class="sub-tabs clearfix">
	<li><a href="#show-comments" class="active">0 Comments</a></li>
	</ul>
<div id="discussion" class="subtab-pages discussion">
	<div id="show-comments">
									<ol id="cs" class="cl">
					<li><span class="cn">00</span>
						<div class="c">
							<p>
								No comments have been posted yet. Please feel free to <a href="#respond">comment first</a>!								<br/>
								<em>
									Note: Make sure your comment is related to the topic of the article above. Let's start a personal and meaningful conversation!								</em>
							</p>
						</div>
					</li>
				</ol>
						</div>
	</div>


					<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-3/#respond" style="display:none;">Click here to cancel reply.</a></small></h3>				<form action="https://www.smashingmagazine.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
					<div class="ccr right"><small><a rel="nofollow" id="cancel-comment-reply-link" href="/2016/12/how-to-build-a-spritekit-game-in-swift-3-part-3/#respond" style="display:none;">Click here to cancel reply.</a></small></div><label for="comment">Your message</label><p>You may use simple HTML to add links or lists to your comment. Also, use <code>&lt;pre>&lt;code class="language-*">...&lt;/code>&lt;/pre></code> to mark up code snippets. We support -js, -markup and -css for comments.</p><textarea name="1f4b0-comment" id="comment" rows="10" class="input textarea" required></textarea><textarea name="comment" style="display:none" rows="1" cols="1"></textarea><div class="clearfix"><p class="input-half"><label for="comment_author">Your name</label><input type="text" name="author" id="comment_author" value="" class="input" required /></p></div>
<div class="clearfix"><p class="input-half"><label for="email">Your email</label><input type="text" name="email" id="email" value="" class="input" required /></p></div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='272278' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>				</form>
					</div><!-- #respond -->
		
			</div>		</div>		<p><a href="#top" class="top" title="Jump to the top of the page">&uarr; Back to top</a></p>
	</div></div></main>
<aside id="wpsidebar" class="sb" role="complementary">
	<div class="col side">
		<section class="mise sf clearfix" role="search">
	<form id="search_2" method="get" action="https://www.smashingmagazine.com/search-results/" target="_top">
    <label class="sl" for="searching_2">Search on Smashing Magazine</label>
		<input id="searching_2" name="q" type="text" placeholder="e.g. JavaScript" />
		<button class="search_submit" type="submit">Search</button>
		<input type="hidden" name="cx" value="partner-pub-6779860845561969:5884617103">
		<input type="hidden" name="cof" value="FORID:10">
		<input type="hidden" name="ie" value="UTF-8">
	</form>
</section>

		<section class="bw faw">
  <p class="awithus">
      <a class="ed-us" href="mailto:&#115;p&#111;ns&#111;r&#105;&#110;g&#64;&#115;m&#97;s&#104;i&#110;&#103;&#109;&#97;&#103;&#97;&#122;i&#110;&#101;&#46;&#99;o&#109;">
	      Become a sponsor!      </a>
  </p>
  <div id="spnsrlist-a" class="oa_zone--sponsor" data-sponsor-lines="1"></div>
</section>
		
<section class="sf wg">
  <h3>
    <a href="https://www.smashingmagazine.com/the-smashing-newsletter/">
      <img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smnl.png" alt="198,064 fine folks have signed up to our Newsletter already, when will you?" />
      Smashing Newsletter
    </a>
  </h3>
  <p>Subscribe to our email newsletter for useful tips and valuable resources, sent out every second Tuesday.</p>
  <div id="mc_embed_signup" class="mcf">
    <form action="//smashingmagazine.us1.list-manage.com/subscribe/post?u=16b832d9ad4b28edf261f34df&amp;id=a1666656e0" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate">
      <label for="mcer-EMAIL" class="sr">Please provide us with your email address:</label>
      <input id="mcer-EMAIL" name="EMAIL" type="text" placeholder="email address" />
      <button id="mc-embedded-subscribe" name="subscribe" class="submit" type="submit">Subscribe</button>
    </form>
    <a href="https://www.smashingmagazine.com/the-smashing-newsletter/"><img class="mcc" src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/mc-counter.svg" alt="Currently, we have 191728 subscribers to our newsletter" /></a>
  </div>
</section>

		<section class="bw">
  <div id="spnsrlist-b" class="oa_zone--sponsor" data-sponsor-lines="3"></div>
</section>

		<section class="so wg">
	<div class="fir">
		<a href="https://www.smashingmagazine.com/2015/03/31/real-life-responsive-web-design-smashing-book-5/?utm_source=magazine&utm_medium=sidebar-ad&utm_campaign=sb5" style="border:0;">
			<img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/sidebar-sb5.png" alt="The Smashing Book #5" width="94" height="135">
		</a>
		<p>
			Smashing Book 5: "Real-Life Responsive Web Design", our playbook to master all the tricky facets and hurdles of <strong>responsive web design</strong>. Gorgeous hardcover with 584 pages. The eBook is included. Free worldwide shipping. <a href="https://www.smashingmagazine.com/2015/03/31/real-life-responsive-web-design-smashing-book-5/?utm_source=magazine&utm_medium=sidebar-ad&utm_campaign=sb5">Get your book now!</a>
		</p>
	</div>
	<div class="sec">
		<a href="https://www.smashingmagazine.com/inclusive-design-patterns" style="border: 0;">
			<img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/inclusive-design-patterns.png" alt="Inclusive Design Patterns by Heydon Pickering" width="94" height="135">
		</a>
		<p>
			Today, too many websites are still inaccessible. In our new book <em>Inclusive Design Patterns</em>, we explore how to craft <strong>flexible front-end design patterns</strong> and make future-proof and accessible interfaces without extra effort. Hardcover, 312 pages. <a href="https://www.smashingmagazine.com/inclusive-design-patterns">Get the book →</a>
		</p>
	</div>
	<div class="thi">
		<a href="https://www.smashingmagazine.com/sketch-handbook" style="border:0;">
			<img src="https://www.smashingmagazine.com/wp-content/uploads/2016/11/sketch-handbook-sidebar-opt-v2.png" alt="The Sketch Handbook, with tips and tricks for designing with Sketch." width="94" height="142"></a>
		<p>Meet the new <em>Sketch Handbook</em>, our brand <strong>new Smashing book</strong> that will help you master all the tricky, advanced facets of Sketch. Filled with <strong>practical examples and tutorials in 12 chapters</strong>, the book will help you become more proficient in your work. <a href="https://www.smashingmagazine.com/sketch-handbook">Get the book</a>.</p>
	</div>

</section>


		<section class="bw">
  <div id="spnsrlist-c" class="oa_zone--sponsor" data-sponsor-lines="2"></div>
</section>

		<section class="mt wg">
  <a href="http://mediatemple.net">
    <img data-src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/mediatemple.svg" alt="Media Temple Logo" width="94" height="94" />
  </a>
  <p>We are proudly hosted on<br /><a href="http://mediatemple.net/webhosting/vps/dedicated-server/">Media Temple Dedicated Servers</a>. Performance matters.</p>
</section>

		<section>
	<div class="oa_zone--ad" id="sidebar_special-1" data-ad-name="Sidebar Special 1" data-ad-zone="72"></div>
</section>
<section>
	<div class="oa_zone--ad" id="sidebar_special-2" data-ad-name="Sidebar Special 2" data-ad-zone="72"></div>
</section>
<section>
	<div class="oa_zone--ad" id="sidebar_special-3" data-ad-name="Sidebar Special 3" data-ad-zone="72"></div>
</section>
<section>
	<div class="oa_zone--ad" id="sidebar_special-4" data-ad-name="Sidebar Special 4" data-ad-zone="72"></div>
</section>

		
<section class="wg">
	<div id="jobs">
		<h3>
			<a href="http://jobs.smashingmagazine.com/?pk_campaign=sm&amp;piwik_kwd=widget">
				<span>Smashing Job Board</span>
				<img data-src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/sm-jobs.png" alt="Smashing Jobs" width="36" height="34" />
			</a>
		</h3>
		<ul class="tl"><li class="clearfix"><a href="http://feedproxy.google.com/~r/smjobs/~3/K0xclIuGncI/2457450">UI Designer - Potato - (London, UK) - Freelance</a><p>We’re looking for UI/visual designers to join our team at our office in central London, designing websites, tools and apps for huge audiences. We are a part of the...</p></li><li class="clearfix"><a href="http://feedproxy.google.com/~r/smjobs/~3/GvBrN06OHxc/2456319">WordPress Developer  - The Hero Company - (Remote ) - FullTime</a><p>The Hero Company is a digital marketing company, whose mission is to help each customer become the hero of his or her own life. We create incredible, life-changing i...</p></li></ul>		<a class="cr" href="http://jobs.smashingmagazine.com?pk_campaign=sm&amp;piwik_kwd=widget">
			View more job openings&hellip;		</a>
	</div>
</section>

		<section class="clearfix">
	<div class="oa_zone--ad sidebar_sky" id="sidebar_sky-1" data-ad-name="Sidebar 1" data-ad-zone="40"></div>
</section>

<section class="clearfix">
	<div class="oa_zone--ad sidebar_sky" id="sidebar_sky-2" data-ad-name="Sidebar 2" data-ad-zone="40"></div>
</section>

		<section class="so wg conf">
	<div class="thi">
		<a href="https://smashingconf.com/" style="border: 0px none;"><img alt="SmashingConf San Francisco 2017" src="https://www.smashingmagazine.com/wp-content/uploads/2016/11/smashingconf-san-francisco-2017-2.png" width="90" height="90"></a>
		<p>Meet <strong>SmashingConf San Francisco 2017</strong>, featuring <strong>front-end</strong> ingredients, <strong>UX</strong> recipes and nothing but practical beats from the hidden corners of the web. Only <strong>practical, real-life techniques</strong> and recipes you can learn from. <a href="https://smashingconf.com/"><strong>Get your ticket now!</strong></a></p>
	</div>
</section>

		<section class="bw">
  <div id="spnsrlist-d" class="oa_zone--sponsor" data-sponsor-lines="2"></div>
</section>

		<section class="clearfix">
  <div class="oa_zone--ad sidebar_sky" id="sidebar_sky-3" data-ad-name="Sidebar 3" data-ad-zone="40"></div>
</section>

	</div>
</aside>
<footer class="f" id="footer" role="contentinfo">
		<p class="stmt">
		<em>With a commitment to quality content for the design community.</em>
		<br />Founded by Vitaly Friedman and Sven Lennartz. 2006-2016.		<br />Made in Germany.		<span class="flinks">
			&#9998;
			<a href="https://www.smashingmagazine.com/write-for-us/">Write for us</a> –
			<a href="https://www.smashingmagazine.com/contact/">Contact us</a> –
			<a href="https://www.smashingmagazine.com/privacy-policy-2/">Datenschutzerklärung</a> –
			<a href="https://www.smashingmagazine.com/about/">Impressum</a>.
		</span>
	</p>
</footer>
<script type='text/javascript'>
/* <![CDATA[ */
var iec_config = {"ajax_url":"https:\/\/www.smashingmagazine.com\/wp-json\/inpsyde-extended-comments\/rate\/","nonce":"dcb9d29201"};
/* ]]> */
</script>
<script id="loadjs__inpsyde_extended_comments_rating">!function(a){"use strict";a.loadOnloadJS=function(b,c){a.addEventListener("load",function(){loadJS(b,c)},!1)},a.loadJS=function(b,c){var d=a.document.createElement("script");d.src=b,d.async=c||!1,a.document.body.appendChild(d)}}(window);
 loadOnloadJS( "https://www.smashingmagazine.com/wp-content/plugins/extended-comments/assets/js/build.min.js?ver=1.0", 1 );</script><script id="inlinejs__preload-polfill">!function(t){"use strict";var e=t.document,r={};r.isPreloadSupported=function(){try{return e.createElement("link").relList.supports("preload")}catch(t){return!1}},r.init=function(){for(var t=e.getElementsByTagName("link"),r=0;r<t.length;r++){var n=t[r];"preload"===n.rel&&"style"===n.getAttribute("as")&&(loadCSS(n.href,n),n.rel=null)}},window.loadCSS&&!r.isPreloadSupported()&&r.init()}(this);</script><script id="loadjs__comment-reply"> loadOnloadJS( "https://www.smashingmagazine.com/wp-includes/js/comment-reply.min.js", 1 );</script><script id="loadjs__smash-onload"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/onload.min.js?ver=6.4.5", 1 );</script><script id="loadjs__smash-fastclick"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/fastclick.min.js?ver=6.4.5", 1 );</script><script id="loadjs__smash-lazy-images"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/lazy-images.min.js?ver=6.4.5", 1 );</script><script id="loadjs__smash-blocked"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/blocked.min.js?ver=6.4.5", 1 );</script><script id="loadjs__codepen"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/codepen.js?ver=6.4.5", 1 );</script><script id="loadjs__prism"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/prism.js?ver=6.4.5", 1 );</script><script type='text/javascript'>
/* <![CDATA[ */
var AdsI18N = {"Advertisement":"Advertisement"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/ads.min.js?ver=6.4.5'></script>
<script id="inlinejs__wp-embed">!function(a,b){"use strict";function c(){if(!e){e=!0;var a,c,d,f,g=-1!==navigator.appVersion.indexOf("MSIE 10"),h=!!navigator.userAgent.match(/Trident.*rv:11\./),i=b.querySelectorAll("iframe.wp-embedded-content");for(c=0;c<i.length;c++)if(d=i[c],!d.getAttribute("data-secret")){if(f=Math.random().toString(36).substr(2,10),d.src+="#?secret="+f,d.setAttribute("data-secret",f),g||h)a=d.cloneNode(!0),a.removeAttribute("security"),d.parentNode.replaceChild(a,d)}else;}}var d=!1,e=!1;if(b.querySelector)if(a.addEventListener)d=!0;if(a.wp=a.wp||{},!a.wp.receiveEmbedMessage)if(a.wp.receiveEmbedMessage=function(c){var d=c.data;if(d.secret||d.message||d.value)if(!/[^a-zA-Z0-9]/.test(d.secret)){var e,f,g,h,i,j=b.querySelectorAll('iframe[data-secret="'+d.secret+'"]'),k=b.querySelectorAll('blockquote[data-secret="'+d.secret+'"]');for(e=0;e<k.length;e++)k[e].style.display="none";for(e=0;e<j.length;e++)if(f=j[e],c.source===f.contentWindow){if(f.removeAttribute("style"),"height"===d.message){if(g=parseInt(d.value,10),g>1e3)g=1e3;else if(200>~~g)g=200;f.height=g}if("link"===d.message)if(h=b.createElement("a"),i=b.createElement("a"),h.href=f.getAttribute("src"),i.href=d.value,i.host===h.host)if(b.activeElement===f)a.top.location.href=d.value}else;}},d)a.addEventListener("message",a.wp.receiveEmbedMessage,!1),b.addEventListener("DOMContentLoaded",c,!1),a.addEventListener("load",c,!1)}(window,document);</script>
		<script>try {
			SmashingAds.loadAds();
		} catch ( e ) {
		}</script>

		<script>try {
			SmashingAds.render( OA_output );
		} catch ( e ) {
		}</script>

	<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"86b694293f","applicationID":"11250242","transactionName":"NgMAbEZVV0cAWxZYXg9JI1tAXVZaTksLX1YNAw==","queueTime":0,"applicationTime":264,"atts":"GkQDGg5PREk=","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>
