<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
	<title>Which Responsive Design Framework Is Best? Of Course, It Depends. &ndash; Smashing Magazine</title>
	<meta charset="UTF-8" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[(new Date).getTime()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=NREUM;"undefined"==typeof window.newrelic&&(newrelic=f);var s=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],l="api-",p=l+"ixn-";a(s,function(e,t){f[t]=o(l+t,!0,"api")}),f.addPageAction=o(l+"addPageAction",!0),f.setCurrentRouteName=o(l+"routeName",!0),t.exports=newrelic,f.interaction=function(){return(new r).get()};var d=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(p+"tracer",[Date.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[Date.now(),r,o],n),o)try{return t.apply(this,arguments)}finally{c.emit("fn-end",[Date.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){d[t]=o(p+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,(new Date).getTime()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o){if(!p.aborted){e&&e(n,r,o);for(var i=t(o),a=v(n),u=a.length,c=0;c<u;c++)a[c].apply(i,r);var f=s[w[n]];return f&&f.push([y,n,r,i]),i}}function d(e,t){b[e]=v(e).concat(t)}function v(e){return b[e]||[]}function g(e){return l[e]=l[e]||o(n)}function m(e,t){f(e,function(e,n){t=t||"feature",w[n]=t,t in s||(s[t]=[])})}var b={},w={},y={on:d,emit:n,get:g,listeners:v,context:t,buffer:m,abort:a,aborted:!1};return y}function i(){return new r}function a(){(s.api||s.feature)&&(p.aborted=!0,s=p.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},l={},p=t.exports=o();p.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!h++){var e=y.info=NREUM.info,t=l.getElementsByTagName("script")[0];if(setTimeout(f.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return f.abort();c(b,function(t,n){e[t]||(e[t]=n)}),u("mark",["onload",a()],null,"api");var n=l.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===l.readyState&&i()}function i(){u("mark",["domContent",a()],null,"api")}function a(){return(new Date).getTime()}var u=e("handle"),c=e(2),f=e("ee"),s=window,l=s.document,p="addEventListener",d="attachEvent",v=s.XMLHttpRequest,g=v&&v.prototype;NREUM.o={ST:setTimeout,CT:clearTimeout,XHR:v,REQ:s.Request,EV:s.Event,PR:s.Promise,MO:s.MutationObserver},e(1);var m=""+location,b={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1016.min.js"},w=v&&g&&g[p]&&!/CriOS/.test(navigator.userAgent),y=t.exports={offset:a(),origin:m,features:{},xhrWrappable:w};l[p]?(l[p]("DOMContentLoaded",i,!1),s[p]("load",r,!1)):(l[d]("onreadystatechange",o),s[d]("onload",r)),u("mark",["firstbyte",a()],null,"api");var h=0},{}]},{},["loader"]);</script>
	<link rel="dns-prefetch" href="https://media-mediatemple.netdna-ssl.com/" />
	<link rel="dns-prefetch" href="https//auslieferung.commindo-media-resourcen.de/" />
	<link rel="preconnect" href="https://media-mediatemple.netdna-ssl.com" />
	<link rel="preconnect" href="https://auslieferung.commindo-media-resourcen.de/" />
	<style id="smash-above-the-fold-css">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</style><script>!function(e){"use strict";function t(e,t,n){e.addEventListener?e.addEventListener(t,n,!1):e.attachEvent&&e.attachEvent("on"+t,n)}function n(t,n){return e.localStorage&&localStorage[t+"_content"]&&localStorage[t+"_file"]===n}function o(t,o){if(e.localStorage&&e.XMLHttpRequest)n(t,o)?r(localStorage[t+"_content"]):a(t,o);else{var i=l.createElement("link");i.href=o,i.id=t,i.rel="stylesheet",i.type="text/css",l.getElementsByTagName("head")[0].appendChild(i),l.cookie=t}}function a(e,t){var n=new XMLHttpRequest;n.open("GET",t,!0),n.onreadystatechange=function(){4===n.readyState&&200===n.status&&(r(n.responseText),localStorage[e+"_content"]=n.responseText,localStorage[e+"_file"]=t)},n.send()}function r(e){var t=l.createElement("style");t.setAttribute("type","text/css"),l.getElementsByTagName("head")[0].appendChild(t),t.styleSheet?t.styleSheet.cssText=e:t.innerHTML=e}var l=e.document,i=function(e,t,n){function o(e){return l.body?e():void setTimeout(function(){o(e)})}function a(){i.addEventListener&&i.removeEventListener("load",a),i.media=n||"all"}var r,i=l.createElement("link");if(t)r=t;else{var s=(l.body||l.getElementsByTagName("head")[0]).childNodes;r=s[s.length-1]}var c=l.styleSheets;i.rel="stylesheet",i.href=e,i.media="only x",o(function(){r.parentNode.insertBefore(i,t?r:r.nextSibling)});var d=function(e){for(var t=i.href,n=c.length;n--;)if(c[n].href===t)return e();setTimeout(function(){d(e)})};return i.addEventListener&&i.addEventListener("load",a),i.onloadcssdefined=d,d(a),i};"undefined"!=typeof exports?exports.loadCSS=i:e.loadCSS=i,e.loadLocalStorageCSS=function(a,r){n(a,r)||l.cookie.indexOf(a)>-1?o(a,r):t(e,"load",function(){o(a,r)})}}(this);</script>
<link rel="preload" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/main.min.css?ver=6.4.7" as="style" onload="this.rel='stylesheet'" /><noscript><link rel='stylesheet' id='smash-main-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/main.min.css?ver=6.4.7' type='text/css' media='all' />
</noscript><link rel="preload" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/articles-only.min.css?ver=6.4.7" as="style" onload="this.rel='stylesheet'" /><noscript><link rel='stylesheet' id='smash-article-only-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/articles-only.min.css?ver=6.4.7' type='text/css' media='all' />
</noscript><script id="loadcss__smash-below-articles">loadCSS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/below-articles.min.css?ver=6.4.7", false, "all" );</script><noscript><link rel='stylesheet' id='smash-below-articles-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/below-articles.min.css?ver=6.4.7' type='text/css' media='all' />
</noscript><script id="loadcss__smash-comments">loadCSS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/comments.min.css?ver=6.4.7", false, "all" );</script><noscript><link rel='stylesheet' id='smash-comments-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/comments.min.css?ver=6.4.7' type='text/css' media='all' />
</noscript><link rel='stylesheet' id='smash-print-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/print.min.css?ver=6.4.7' type='text/css' media='print' />
<script id="loadcss__smash-webfonts">loadLocalStorageCSS( "smash-webfonts", "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/webfonts.min.css?ver=6.4.7" );</script><!--[if IE 8]>
<link rel='stylesheet' id='smash-ie8-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/ie8-nu.min.css?ver=6.4.7' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='tablesaw-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/tablesaw.min.css?ver=6.4.7' type='text/css' media='all' />

<!-- This site is optimized with the Yoast SEO Premium plugin v3.5.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Which framework should we be using, and why? Also, should we be using the whole framework or just parts of it? Find out in this article."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/" />
<link rel="publisher" href="https://plus.google.com/+SmashingMagazine‎"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Which Responsive Design Framework Is Best? Of Course, It Depends. &ndash; Smashing Magazine" />
<meta property="og:description" content="Which framework should we be using, and why? Also, should we be using the whole framework or just parts of it? Find out in this article." />
<meta property="og:url" content="https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/" />
<meta property="og:site_name" content="Smashing Magazine" />
<meta property="article:publisher" content="https://www.facebook.com/smashmag" />
<meta property="article:tag" content="Frameworks" />
<meta property="article:tag" content="Mobile" />
<meta property="article:tag" content="Responsive Web Design" />
<meta property="article:tag" content="Tools" />
<meta property="article:section" content="Mobile" />
<meta property="article:published_time" content="2017-03-20T11:04:13+01:00" />
<meta property="article:modified_time" content="2017-03-20T13:41:34+01:00" />
<meta property="og:updated_time" content="2017-03-20T13:41:34+01:00" />
<meta property="og:image" content="https://www.smashingmagazine.com/wp-content/uploads/2014/02/responsive-frameworks-opt2.png" />
<meta property="og:image:width" content="500" />
<meta property="og:image:height" content="335" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Which framework should we be using, and why? Also, should we be using the whole framework or just parts of it? Find out in this article." />
<meta name="twitter:title" content="Which Responsive Design Framework Is Best? Of Course, It Depends. &ndash; Smashing Magazine" />
<meta name="twitter:site" content="@smashingmag" />
<meta name="twitter:image" content="https://www.smashingmagazine.com/wp-content/uploads/2014/02/responsive-frameworks-opt2.png" />
<meta name="twitter:creator" content="@jen4web" />
<meta property="DC.date.issued" content="2017-03-20T11:04:13+01:00" />
<!-- / Yoast SEO Premium plugin. -->

<link rel="alternate" type="application/rss+xml" title="Smashing Magazine &raquo; Feed" href="https://www.smashingmagazine.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Smashing Magazine &raquo; Comments Feed" href="https://www.smashingmagazine.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Smashing Magazine &raquo; Which Responsive Design Framework Is Best? Of Course, It Depends. Comments Feed" href="https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/feed/" />

<script type='text/javascript'>
/* <![CDATA[ */
var SmashingServiceWorkerData = {"url":"https:\/\/www.smashingmagazine.com\/serviceWorker.js"};
/* ]]> */
</script>
<script>
var SmashingServiceWorkerData=SmashingServiceWorkerData||{url:""};(function(a,b){if(b.url&&"serviceWorker" in a){a.serviceWorker.register(b.url);window.addEventListener("load",function(){if(a.serviceWorker.controller){a.serviceWorker.controller.postMessage({command:"trimCaches"})}})}})(navigator,SmashingServiceWorkerData);
</script>
<!--[if IE 8]>
<script type='text/javascript' src='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/html5shiv.min.js?ver=6.4.7'></script>
<![endif]-->
<script type='text/javascript' src='https://www.smashingmagazine.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<link rel='https://api.w.org/' href='https://www.smashingmagazine.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.smashingmagazine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.smashingmagazine.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.smashingmagazine.com/?p=284535' />
<link rel="alternate" type="application/json+oembed" href="https://www.smashingmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.smashingmagazine.com%2F2017%2F03%2Fwhich-responsive-design-framework-is-best%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.smashingmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.smashingmagazine.com%2F2017%2F03%2Fwhich-responsive-design-framework-is-best%2F&#038;format=xml" />
<!-- Stream WordPress user activity plugin v3.0.7 -->
<link rel="manifest" href="/manifest.json">	<script>
	dataLayer = [
		{
			'site': {"ID":"1","name":"Smashing Magazine","home":"https:\/\/www.smashingmagazine.com"},
			'user': {"isLoggedIn":false,"ID":0,"role":"visitor"}		}
	];
</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
		new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
		j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
		'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-NWC9FPF');
</script>

	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="mask-icon" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/s.svg" color="#e53b2c" sizes="any" />
<!--[if IE]><link href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/favicon.ico" rel="icon" /><![endif]-->
<link rel="icon" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/favicon.png" />
<meta name="application-name" content="Smashing Magazine" />
<meta name="msapplication-TileColor" content="#fff" />
<meta name="msapplication-square70x70logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-70-70.png" />
<meta name="msapplication-square150x150logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-150-150.png" />
<meta name="msapplication-wide310x150logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-310-150.png" />
<meta name="msapplication-square310x310logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-310-310.png" />
<meta name="msapplication-notification" content="frequency=30;polling-uri1=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=1;polling-uri2=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=2;polling-uri3=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=3;polling-uri4=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=4;cycle=1" />
<link rel="apple-touch-icon-precomposed" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-57x57-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-72x72-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-114x114-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-144x144-precomposed.png" />
</head>
<body id="top" class="single single-post postid-284535 single-format-standard www-section">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NWC9FPF" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div class="mnb">
	<a href="#mn" class="ntb js-toggle-btn" title="Jump to the main navigation">
		Menu	</a>
	<a href="#ms" class="stb js-toggle-btn" title="Jump to the search">
		Search    </a>
</div><a class="sr" href="#content">Jump to the content</a>
<header class="h" role="banner">
	<h1 class="logo">
		<span class="sr">Smashing Magazine</span>
		<a href="https://www.smashingmagazine.com/"><img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/logo.png" alt="Smashing Magazine Logo" srcset="https://media-mediatemple.netdna-ssl.com/wp-content/themes/smashing-magazine/assets/images/logo.svg" /></a>
	</h1>
</header>
<nav class="mn" id="mn" role="navigation menu">
	<h2>Smashing Pages:</h2>
	 <ul id="menu-smashing-mobile-network" class="mnu"><li id="menu-item-218248" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218248 menu-item-books"><a href="https://www.smashingmagazine.com/books/">Books</a></li>
<li id="menu-item-218249" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218249 menu-item-tickets"><a href="https://www.smashingmagazine.com/workshops/">Tickets</a></li>
<li id="menu-item-219109" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219109 menu-item-shop"><a href="https://shop.smashingmagazine.com/">Shop</a></li>
<li id="menu-item-188959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188959 menu-item-email-newsletter"><a href="https://www.smashingmagazine.com/the-smashing-newsletter/">Email Newsletter</a></li>
<li id="menu-item-188961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-188961 menu-item-jobs"><a href="http://jobs.smashingmagazine.com">Jobs</a></li>
<li id="menu-item-188958" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188958 menu-item-about-us-impressum"><a href="https://www.smashingmagazine.com/about/">About us / Impressum</a></li>
</ul>	<h2>Categories:</h2>
	 <ul id="menu-mobile-categories" class="mnu"><li id="menu-item-181575" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181575 menu-item-coding"><a href="https://www.smashingmagazine.com/category/coding/">Coding</a></li>
<li id="menu-item-181576" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181576 menu-item-design"><a href="https://www.smashingmagazine.com/category/design/">Design</a></li>
<li id="menu-item-181580" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-181580 menu-item-mobile"><a href="https://www.smashingmagazine.com/category/mobile/">Mobile</a></li>
<li id="menu-item-181579" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181579 menu-item-graphics"><a href="https://www.smashingmagazine.com/category/graphics/">Graphics</a></li>
<li id="menu-item-181577" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181577 menu-item-ux-design"><a href="https://www.smashingmagazine.com/category/uxdesign/">UX Design</a></li>
<li id="menu-item-181578" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181578 menu-item-wordpress"><a href="https://www.smashingmagazine.com/category/wordpress/"><span class="long"><span>Word</span><span>Press</span></span><span class="short">WP</span></a></li>
</ul></nav>
<a class="mnc js-toggle-btn" href="#top" data-toggle-target="mn" title="Close the navigation">X</a><div class="ms" id="ms" role="search">
  <form id="mobile-searching" class="sfm clearfix" method="get" action="https://www.smashingmagazine.com/search-results/" target="_top">
    <label for="mobile-search-input">Search on Smashing Magazine</label>
    <input name="q" id="mobile-search-input" type="text" placeholder="e.g. CSS" />
    <button class="submit" type="submit">Search</button>
    <input type="hidden" name="cx" value="partner-pub-6779860845561969:5884617103">
    <input type="hidden" name="cof" value="FORID:10">
    <input type="hidden" name="ie" value="UTF-8">
  </form>
</div>
<a role="button" class="msc js-toggle-btn" href="#top" data-toggle-target="ms" title="Close the search">X</a>
<nav class="tn clearfix" role="navigation">
	 <ul id="menu-network-menu" class="nw clearfix"><li class="current"><a href="https://www.smashingmagazine.com"><img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/logo.png" alt="Smashing Magazine" srcset="https://media-mediatemple.netdna-ssl.com/wp-content/themes/smashing-magazine/assets/images/logo.svg"  /></a></li><li id="menu-item-218245" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218245 menu-item-books"><a href="https://www.smashingmagazine.com/books/">Books</a></li>
<li id="menu-item-231721" class="cody menu-item menu-item-type-custom menu-item-object-custom menu-item-231721 menu-item-ebooks"><a href="https://shop.smashingmagazine.com/products/the-smashing-library">eBooks</a></li>
<li id="menu-item-218696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218696 menu-item-tickets"><a href="https://www.smashingmagazine.com/smashing-workshops/">Tickets</a></li>
<li id="menu-item-231722" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-231722 menu-item-shop"><a href="https://shop.smashingmagazine.com/">Shop</a></li>
<li id="menu-item-2" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2 menu-item-jobs"><a href="http://jobs.smashingmagazine.com/">Jobs</a></li>
</ul><nav id="social-media-nav" role="menu">
  <ul class="ch">
  	<li class="rss">
	    <a href="https://www.smashingmagazine.com/feed/" title="Subscribe to our RSS-feed (120K)">RSS</a>
    </li>
  	<li class="fb">
	    <a href="//www.facebook.com/smashmag" title="Join our Facebook page! (267k)">Facebook</a>
    </li>
  	<li class="tw">
	    <a href="//twitter.com/smashingmag" title="Follow us on Twitter! (956k)">Twitter</a>
    </li>
  	<li class="nl">
	    <a href="https://www.smashingmagazine.com/the-smashing-newsletter/" title="Subscribe to our Email Newsletter (180k)">Newsletter</a>
    </li>
  </ul>
</nav>
</nav>
<main>
	<div class="cc">
		<div class="fluid clearfix">
			<div class="grid clearfix">
				<section class="mise sf clearfix" role="search">
	<form id="search_1" method="get" action="https://www.smashingmagazine.com/search-results/" target="_top">
    <label class="sl" for="searching_1">Search on Smashing Magazine</label>
		<input id="searching_1" name="q" type="text" placeholder="e.g. JavaScript" />
		<button class="search_submit" type="submit">Search</button>
		<input type="hidden" name="cx" value="partner-pub-6779860845561969:5884617103">
		<input type="hidden" name="cof" value="FORID:10">
		<input type="hidden" name="ie" value="UTF-8">
	</form>
</section>
				<div class="col sn">
					<div class="sct"><ul id="menu-category-menu" class="clearfix"><li id="menu-item-116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-116 menu-item-coding"><a href="https://www.smashingmagazine.com/category/coding/">Coding</a>
<ul class="sub-menu">
	<li id="menu-item-2014" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2014 menu-item-css"><a href="https://www.smashingmagazine.com/tag/css/">CSS</a></li>
	<li id="menu-item-134810" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-134810 menu-item-html"><a href="https://www.smashingmagazine.com/tag/html/">HTML</a></li>
	<li id="menu-item-2015" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2015 menu-item-javascript"><a href="https://www.smashingmagazine.com/tag/javascript/">JavaScript</a></li>
	<li id="menu-item-2016" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2016 menu-item-techniques"><a href="https://www.smashingmagazine.com/tag/techniques/">Techniques</a></li>
</ul>
</li>
<li id="menu-item-117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-117 menu-item-design"><a href="https://www.smashingmagazine.com/category/design/">Design</a>
<ul class="sub-menu">
	<li id="menu-item-2017" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2017 menu-item-web-design"><a href="https://www.smashingmagazine.com/tag/web-design/">Web Design</a></li>
	<li id="menu-item-231166" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-231166 menu-item-responsive"><a title="Responsive Web Design" href="https://www.smashingmagazine.com/tag/responsive-web-design/">Responsive</a></li>
	<li id="menu-item-2032" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2032 menu-item-typography"><a href="https://www.smashingmagazine.com/tag/typography/">Typography</a></li>
	<li id="menu-item-2063" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2063 menu-item-inspiration"><a href="https://www.smashingmagazine.com/tag/inspiration/">Inspiration</a></li>
</ul>
</li>
<li id="menu-item-119" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-119 menu-item-mobile"><a href="https://www.smashingmagazine.com/category/mobile/">Mobile</a>
<ul class="sub-menu">
	<li id="menu-item-142132" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-142132 menu-item-iphone-ipad"><a href="https://www.smashingmagazine.com/tag/ios/">iPhone &#038; iPad</a></li>
	<li id="menu-item-143596" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143596 menu-item-android"><a href="https://www.smashingmagazine.com/tag/android/">Android</a></li>
	<li id="menu-item-143608" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143608 menu-item-design-patterns"><a href="https://www.smashingmagazine.com/tag/design-patterns/">Design Patterns</a></li>
</ul>
</li>
<li id="menu-item-118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-118 menu-item-graphics"><a href="https://www.smashingmagazine.com/category/graphics/">Graphics</a>
<ul class="sub-menu">
	<li id="menu-item-2264" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2264 menu-item-photoshop"><a href="https://www.smashingmagazine.com/tag/photoshop/">Photoshop</a></li>
	<li id="menu-item-160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-160 menu-item-fireworks"><a href="https://www.smashingmagazine.com/category/fireworks/">Fireworks</a></li>
	<li id="menu-item-2283" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2283 menu-item-wallpapers"><a href="https://www.smashingmagazine.com/tag/wallpapers/">Wallpapers</a></li>
	<li id="menu-item-2305" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2305 menu-item-freebies"><a href="https://www.smashingmagazine.com/tag/freebies/">Freebies</a></li>
</ul>
</li>
<li id="menu-item-120" class="menu-item-uxdesign menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-120 menu-item-ux-design"><a href="https://www.smashingmagazine.com/category/uxdesign/">UX Design</a>
<ul class="sub-menu">
	<li id="menu-item-143609" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143609 menu-item-usability"><a href="https://www.smashingmagazine.com/tag/usability/">Usability</a></li>
	<li id="menu-item-143610" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143610 menu-item-user-experience"><a href="https://www.smashingmagazine.com/tag/user-experience/">User Experience</a></li>
	<li id="menu-item-143611" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143611 menu-item-ui-design"><a href="https://www.smashingmagazine.com/tag/ui/">UI Design</a></li>
	<li id="menu-item-143612" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143612 menu-item-e-commerce"><a href="https://www.smashingmagazine.com/tag/e-commerce/">E-Commerce</a></li>
</ul>
</li>
<li id="menu-item-121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-121 menu-item-wordpress"><a href="https://www.smashingmagazine.com/category/wordpress/"><span class="long"><span>Word</span><span>Press</span></span><span class="short">WP</span></a>
<ul class="sub-menu">
	<li id="menu-item-143677" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143677 menu-item-essentials"><a href="https://www.smashingmagazine.com/tag/essentials/">Essentials</a></li>
	<li id="menu-item-143678" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143678 menu-item-techniques"><a href="https://www.smashingmagazine.com/tag/techniques-wp/">Techniques</a></li>
	<li id="menu-item-143679" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143679 menu-item-plugins"><a href="https://www.smashingmagazine.com/tag/plugins/">Plugins</a></li>
	<li id="menu-item-143680" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143680 menu-item-themes"><a href="https://www.smashingmagazine.com/tag/themes/">Themes</a></li>
</ul>
</li>
</ul></div>				</div>
				<div id="content" class="col main">
					<div id="blocked" class="blocked clearfix">

	<figure style="max-width: 24%;min-width: 90px;">
		<a href="https://smashingconf.com">
			<img src="https://www.smashingmagazine.com/wp-content/uploads/2016/11/smashingconf-san-francisco-2017-1.png" alt="Smashing Conf San Francisco">
		</a>
	</figure>

	<p style="font-size: calc(1em + ((0.4vw + 0.25vh) / 2));">
		<strong>We use ad-blockers as well, you know.</strong> We gotta keep those servers running though.
		Did you know that we publish <a href="https://www.smashingmagazine.com/books/">useful books</a> and run
		<a href="https://www.smashingmagazine.com/smashing-workshops/">friendly conferences</a>
		— crafted for pros like yourself? E.g. upcoming <a href="https://smashingconf.com">SmashingConf San Francisco</a>,
		dedicated to smart front-end techniques and design patterns.
	</p>
</div>
<article class="post-284535 post type-post status-publish format-standard has-post-thumbnail hentry category-mobile tag-frameworks tag-mobile tag-responsive-web-design tag-tools" vocab="http://schema.org/" typeof="TechArticle">

		<h2>
		<a property="url" href="https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/" rel="bookmark" title="Read 'Which Responsive Design Framework Is Best? Of Course, It Depends.'"><span property="name">Which Responsive Design Framework Is Best? Of Course, It Depends.</span></a>
	</h2>

			
<ul class="pmd clearfix">
	<li class="a" property="author" typeof="person" resource="#authorname">By <a href="https://www.smashingmagazine.com/author/jen-kramer/" title="Posts by Jen Kramer" rel="author">Jen Kramer</a></li>
				<li class="rd" property="datePublished" content="March 20th, 2017">March 20th, 2017</li>
				<li class="tags" property="keywords"><a href="https://www.smashingmagazine.com/tag/frameworks/">Frameworks</a><a href="https://www.smashingmagazine.com/tag/mobile/">Mobile</a><a href="https://www.smashingmagazine.com/tag/responsive-web-design/">Responsive Web Design</a></li>
		<li class="comments" property="discussionUrl"><a href="#comments" title="Comment on Which Responsive Design Framework Is Best? Of Course, It Depends.">4 Comments</a> </li>
		</ul>
	
	<div class="ad ed">
	<div class="oa_zone--ad cad" id="cad" data-ad-name="Medium Rectangle" data-ad-zone="22" data-ad-media="all"></div>
</div>

	<p>In 2017, the question is not whether we should use a responsive design framework. Increasingly, we are using them. The question is which framework should we be using, and why, and whether we should use the whole framework or just parts of it.</p>
<p>With dozens of responsive design frameworks available to download, many web developers appear to be unaware of any except for Bootstrap. Like most of web development, <strong>responsive design frameworks are not one-size-fits-all</strong>. Let&#8217;s compare the latest versions of Bootstrap, Foundation and UIkit for their similarities and differences.</p>
<p>Three years ago, I wrote an article for Smashing Magazine, &#8220;<a title="Read 'Responsive Design Frameworks: Just Because You Can, Should You?'" href="https://www.smashingmagazine.com/2014/02/responsive-design-frameworks-just-because-you-can-should-you/">Responsive Design Frameworks: Just Because You Can, Should You?</a><sup class="po" id="note-1"><a href="#1">1</a></sup>&#8221; In the article, I argued that responsive design frameworks should be used by professionals under the right circumstances and for appropriate projects. Custom design still has its place, of course. However, a fully customized approach is not appropriate to every website, under every timeline, every budget and every set of browser support guidelines.</p>
<p>Since that time, the industry has evolved at its typical breakneck pace. Sass, the CSS preprocessor, has become standard to most workflows. We&#8217;re more accustomed to adjusting Sass variables to customize existing code. We confidently work with mixins, building our own styles. We&#8217;ve even got <a href="http://tallys.github.io/color-theory/">Sass formulas for generating color schemes</a><sup class="po" id="note-2"><a href="#2">2</a></sup> that we can incorporate in our work.</p>
<p>Workflows themselves have become standard, making use of technologies such as Node.js, Bower, Grunt, Gulp, Git and more. Old browsers continue to fall away, allowing front-end developers to confidently use more features of HTML5 and CSS3, with fewer worries about significant cross-browser compatibility issues.</p>
<p>Revisiting the 131 comments on my 2014 article, I saw readers suggesting a number of approaches to making use of responsive design frameworks:</p>
<ul>
<li>Some suggested using part of a framework with your own custom code.</li>
<li>Several developers plugged their own framework, either written from scratch or with code forked from another framework.</li>
<li>Several developers suggested frameworks that I did not cover, including Susy, Singularity, Breakpoint, UIkit, Pattern Lab, Toolkit, Pure, Cardinal, Skeleton, ResponsiveBP and many others.</li>
</ul>
<p>All of these are legitimate approaches. Hundreds of frameworks are available. Many who have been in the business for some time have a favorite, whether it&#8217;s an established framework or one they&#8217;ve created.</p>
<p>However, increasingly, I see students, clients and web development firms defaulting to Bootstrap as their starting point, often with little critical evaluation of whether it&#8217;s an appropriate solution to the task at hand. Clients hire me for training in Bootstrap, for example, and then ask how they can add functionality that&#8217;s native to Foundation. When I ask, &#8220;Why not use Foundation?,&#8221; they tell me they&#8217;ve never heard of it and didn&#8217;t know there are options beyond Bootstrap for responsive design.</p>
<p>There is no way I could review the dozens, if not hundreds, of responsive design frameworks. However, given that Bootstrap is the 500-pound gorilla of responsive design, I&#8217;ve chosen two other frameworks to evaluate compared to <a href="http://getbootstrap.com/">Bootstrap</a><sup class="po" id="note-3"><a href="#3">3</a></sup>: <a href="http://foundation.zurb.com/">Foundation</a><sup class="po" id="note-4"><a href="#4">4</a></sup> and <a href="https://getuikit.com/">GetUIkit</a><sup class="po" id="note-5"><a href="#5">5</a></sup>. <strong>I&#8217;ve chosen these three frameworks based on the characteristics they share</strong>, in that they are full-service responsive design frameworks. They offer grid systems, SCSS with piles of variables and mixins for customizations, basic styling of nearly all HTML5 tags, prestyled components such as badges, labels and cards, and piles of JavaScript-based features such as dropdown menus, accordions, tabs, image galleries, image carousels and so much more. All three frameworks offer ways of reducing file sizes to just those styles and functionalities needed to work on a given website. They are all in active development.</p>
<p>Again, I am not suggesting that these are the only responsive design frameworks, nor am I implying that they are the best frameworks. These are, however, popular frameworks with piles of features out of the box, making them attractive to many development firms wanting to work with &#8220;Bootstrap or a close equivalent.&#8221;</p>
<h3  id="background-information">Background Information <a href="#background-information" aria-label="Link to section 'Background Information'" class="sr hsl">Link</a></h3>
<p>To start the discussion, let&#8217;s examine some of the basic background features of each framework.</p>
<table class="tablesaw" data-tablesaw-mode="swipe" data-tablesaw-minimap>
<thead>
<tr>
<th data-tablesaw-priority="persist"></th>
<th>Bootstrap 4</th>
<th>Foundation for Sites 6</th>
<th>UIkit 3</th>
</tr>
</thead>
<tbody>
<tr>
<th>Current version, release date</th>
<th>4.0.0-alpha 6, released January 2017</td>
<th>6.3.0, released January 2017</td>
<th>3.00 beta 9, released February 2017</td>
</tr>
<tr>
<th>Owned by</th>
<td>Originally developed at Twitter by Mark Otto and Jacob Thornton, now an open-source project</td>
<td>ZURB, a web development company in Campbell, California</td>
<td>YOOtheme, a WordPress and Joomla theme development company in Hamburg, Germany</td>
</tr>
<tr>
<th>Website</th>
<td><a href="http://v4-alpha.getbootstrap.com/">Bootstrap</a><sup class="po" id="note-6"><a href="#6">6</a></sup></td>
<td><a href="http://foundation.zurb.com/sites/docs/">Foundation</a><sup class="po" id="note-7"><a href="#7">7</a></sup></td>
<td><a href="http://getuikit.com/"GetUiKit</a></td>
</tr>
<tr>
<th>Standard distribution package includes</th>
<td>Required CSS (1 minified, 1 standard, both with <code>.map</code> files); required JavaScript (1 minified, 1 standard). Former theme is incorporated in Sass files, activated by variables. (Glyphicons are not distributed with Bootstrap 4.) Also contains two additional sets of CSS files (1 minified, 1 standard, both with <code>.map</code> files): bootstrap-grid, which appears to be a flexbox-based grid system, possibly redundant at this point; and bootstrap-reboot, based on normalize.css. A CDN is available for standard distribution files.</td>
<td><a href="http://foundation.zurb.com/sites/download/">Four distributions</a><sup class="po" id="note-8"><a href="#8">8</a></sup>: Complete, Essential, Custom, Sass. Complete version includes compiled CSS (minified and not), plus compiled JavaScript, including individual vendor files. Essential includes typography, grid, Reveal, and Interchange only. Custom can be customized on the website for downloading, and the developer can choose elements to include and change a few variables. The Sass version can only be downloaded using the command line, Foundation CLI or Yeti Launcher. A CDN is available for standard distribution files.</td>
<td>Distribution includes a single minified CSS file, a single minified JavaScript file and 26 SVG graphics. LESS, CSS, and JavaScript source files are available via Bower or npm. A CDN is available for standard distribution files.</td>
</tr>
<tr>
<th>Additional JavaScript libraries required?</th>
<td>Yes, you must download or link to a CDN separately: jQuery 3.1.1 Slim, Tether 1.4.0. Files are linked to just before end of <code>body</code> element.</td>
<td>All dependencies are bundled in the distribution. jQuery is required, but it is part of the distribution. Files are linked to just before end of <code>body</code> element.</td>
<td>All dependencies are bundled in the distribution. jQuery is required, but it is part of the distribution. Linking to files in the <code>head</code> is recommended.</td>
</tr>
<tr>
<th>Browser support</th>
<td>Latest versions of: Chrome (macOS, Windows, iOS and Android), Safari (macOS and iOS), Firefox (macOS, Windows, Android, iOS) (latest version of Firefox plus Extended Support Release), Edge (Windows, Windows 10 Mobile), Opera (macOS, Windows), Android Browser &amp; WebView 5.0+, Windows 10 Mobile, Internet Explorer 10+</td>
<td>Last two versions of Chrome, Firefox, Safari, Opera, mobile Safari, Internet Explorer mobile, as well as Internet Explorer 9+ and Android browser 2.3+</td>
<td>Latest versions of Chrome, Firefox, Opera, Edge, Safari 7.1+, Internet Explorer 10+, No mention of mobile-specific browsers</td>
</tr>
<tr>
<th>Internet Explorer support</th>
<td>Internet Explorer 10 and higher (Bootstrap 3 recommended for Internet Explorer 8 and 9)</td>
<td>Internet Explorer 9 and higher</td>
<td>Internet Explorer 10 and higher</td>
</tr>
<tr>
<th>Other browser support notes</th>
<td>&#8220;Unofficially, Bootstrap should look and behave well enough in Chromium and Chrome for Linux, Firefox for Linux, and Internet Explorer 9, though they are not officially supported.&#8221; (<a href="http://v4-alpha.getbootstrap.com/getting-started/browsers-devices/">source</a><sup class="po" id="note-9"><a href="#9">9</a></sup>)</td>
<td>&#8220;JavaScript: Our plugins use a number of handy ECMAScript 5 features that aren&#8217;t supported in IE8.&#8221; (<a href="http://foundation.zurb.com/sites/docs/compatibility.html">source</a><sup class="po" id="note-10"><a href="#10">10</a></sup>)</td>
<td></td>
</tr>
<tr>
<th>License and copyright</th>
<td>Code and documentation copyright (2011 to 2017) of the Bootstrap authors and Twitter, Inc. Code released under the MIT License. Docs released under Creative Commons.</td>
<td>MIT license, no mention of copyright</td>
<td>MIT license, copyright of YOOtheme GmbH</td>
</tr>
<tr>
<th>Build tools</th>
<td>&#8220;Bootstrap uses Grunt for its CSS and JavaScript build system and Jekyll for the written documentation. Our Gruntfile includes convenient methods for working with the framework, including compiling code, running tests, and more.&#8221; (<a href="https://v4-alpha.getbootstrap.com/getting-started/build-tools/">source</a><sup class="po" id="note-11"><a href="#11">11</a></sup>)</td>
<td><a href="http://foundation.zurb.com/sites/docs/installation.html">To access Sass files</a><sup class="po" id="note-12"><a href="#12">12</a></sup>, you must install using the command line, the Node.js-powered Foundation CLI, or with its Yeti Launch application (Mac only). &#8220;Foundation is available on npm, Bower, Meteor, and Composer. The package includes all of the source SCSS and JavaScript files, as well as compiled CSS and JavaScript, in uncompressed and compressed flavors.&#8221; Other versions of Foundation are available as simple downloads without using these tools, but without SCSS files.</td>
<td>Bower and npm. Offer a SublimeText plugin and an Atom plugin for working with UIkit 3 as well.</td>
</tr>
</tbody>
</table>
<p>In general, all three frameworks are in active development (all were updated in January or February 2017) and are mobile-first. All generally have some type of CSS preprocessor. UIkit version 3 beta currently only offers LESS. It will offer a SCSS port, as it&#8217;s offered in previous versions of UIkit, in future releases.</p>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en"><a href="https://twitter.com/jen4web">@jen4web</a><sup class="po" id="note-19"><a href="#19">19</a></sup><sup class="po" id="note-13"><a href="#13">13</a></sup> Yes, we will have a SASS port too. (like we have in UIkit 2)</p>
<p>— UIkit (@getuikit) <a href="https://twitter.com/getuikit/status/829680161968775168">February 9, 2017</a><sup class="po" id="note-14"><a href="#14">14</a></sup></p></blockquote>
<p>Bootstrap transitioned from LESS to SCSS as part of its version 4 update. Foundation has always been written in SCSS, because ZURB is a Ruby on Rails shop, and Sass hails from the Ruby on Rails world.</p>
<p>There are notable differences with the build tools. Foundation is extremely picky about you using its workflow when working with the framework, if you wish to work with SCSS files. Unfortunately, Foundation offers few choices in tools. Bootstrap is much less picky about workflow, offering several options, including no workflow at all, even with its SCSS files. All frameworks offer at least one distribution ZIP file, containing all elements of the framework. Foundation offers a way to choose only certain elements in a download. Bootstrap 4 alpha and UIkit 3 beta do not offer this functionality currently, but they have previously offered this in older Bootstrap and UIkit versions. We can assume that once these frameworks reach their stable releases, this functionality will be offered as well.</p>
<h3  id="grid-system">Grid System <a href="#grid-system" aria-label="Link to section 'Grid System'" class="sr hsl">Link</a></h3>
<p>Each framework comes with a grid system, as one might expect. Bootstrap and Foundation&#8217;s grid systems include multiple breakpoints, nested grids, offsets and source ordering (i.e. changing the order of content on collapse). Exact breakpoint values vary, but the breakpoints are generally customizable with SCSS. UIkit&#8217;s grid is radically different and is described below.</p>
<p>With the most recent alpha 6 release, Bootstrap features a flexbox-based grid system by default. (This is partly the reason for its Internet Explorer 10+ browser support.) By default, Foundation features a floated grid system (which helps, in part, with its Internet Explorer 9+ support). Optionally in Foundation, you can compile a flexbox-based grid system by toggling an appropriate Sass variable and recompiling to CSS. Foundation notes that flexbox is not supported in Internet Explorer 9, so keep this in mind if this is a target browser for you.</p>
<p>Foundation offers a few more grid features than Bootstrap, including centered columns, incomplete rows, responsive gutters, semantic grid options and fluid rows.</p>
<p>Equal-height columns are a common problem when working with float-based grid systems. Foundation includes a JavaScript component named Equalizer. Because UIkit and Bootstrap are based on flexbox and not floats, equal-height columns are built into the grid system and are never an issue.</p>
<p>UIkit has a very different grid than Foundation and Bootstrap. Rather than a standard 12-column system, UIkit has broken its layouts into three components: grid, flex and width. <a href="https://getuikit.com/docs/grid#usage">Starting with the grid component</a><sup class="po" id="note-15"><a href="#15">15</a></sup>, you can create as many columns as you wish:</p>
<blockquote><p>To create the grid container, add the <code>uk-grid</code> attribute to a <code>&lt;div&gt;</code> element. There&#8217;s no need to add a class. Add child <code>&lt;div&gt;</code> elements to create the cells. By default, all grid cells are stacked. To place them side by side, add one of the classes from the Width component. Using <code>uk-child-width-expand</code> will automatically apply equal width to items, regardless of how many there are.</p></blockquote>
<p>As implied in the documentation, grid sets up the boxes that might be next to each other in some layouts, while width determines the width of those boxes, and flex determines the layout within each box, using flexbox properties. Finally, unlike other grid systems, UIkit offers a border between grid columns.</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2017/02/foundation-grid-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/02/foundation-grid-opt.png" alt="Foundation's equalizer demonstrated." width="800" height="260" /></a><sup class="po" id="note-16"><a href="#16">16</a></sup><br />
<figcaption>Foundation&#8217;s equalizer is designed to create equal-height columns. (Image: <a href="http://foundation.zurb.com/sites/docs/equalizer.html">Foundation Docs</a><sup class="po" id="note-17"><a href="#17">17</a></sup>) (<a href="https://www.smashingmagazine.com/wp-content/uploads/2017/02/foundation-grid-opt.png">View large version</a><sup class="po" id="note-18"><a href="#18">18</a></sup>)</figcaption>
</figure>
<h3  id="css-and-default-styling">CSS And Default Styling <a href="#css-and-default-styling" aria-label="Link to section 'CSS And Default Styling'" class="sr hsl">Link</a></h3>
<p>All three frameworks come with some level of CSS styling. The styling can be changed through an overriding style sheet or by modifying the provided SCSS or LESS preprocessor files. Generally speaking, basic styling is provided for all, or nearly all, HTML5 elements. All frameworks provide some quantity of utility classes, generally used for printing, responsiveness and the visibility of elements. Foundation and UIkit offer right-to-left support for languages written in that direction. UIkit states that it will feature a RTL version and the option to compile UIkit with a custom prefix.</p>
<blockquote class="twitter-tweet"><p>
<a href="https://twitter.com/jen4web">@jen4web</a><sup class="po" id="note-19"><a href="#19">19</a></sup><sup class="po" id="note-13"><a href="#13">13</a></sup> Also a RTL version and the option to compile UIkit with a custom prefix (like ba- instead of uk-)</p>
<p>— UIkit (@getuikit) <a href="https://twitter.com/getuikit/status/829680541179985920">February 9, 2017</a><sup class="po" id="note-20"><a href="#20">20</a></sup></p></blockquote>
<p>It is unclear from its documentation whether Bootstrap 4 is offering RTL support, but it has been available in previous versions. It seems like this might be part of a <a href="https://github.com/twbs/bootstrap/issues/19555">future stable release</a><sup class="po" id="note-21"><a href="#21">21</a></sup>. There is much interest in including this feature in the Bootstrap community.</p>
<p>The framework with the least out-of-the-box styling is Foundation. This framework has long assumed that its users are more advanced developers who will want to write their own styling for their projects. Therefore, ZURB has always provided less styling out of the box by design, meaning there will be fewer styles to override later.</p>
<p>UIkit offers two color options, accessible via the Inverse component. They include the standard scheme (light backgrounds and dark text) and a contrast scheme (dark backgrounds and light text). UIkit also offers some unique styled components, such as Articles and Comments, as well as Placeholder, which provides an empty space for drag-and-drop file-uploading interfaces. If you recall YOOtheme&#8217;s WordPress and Joomla theming roots, these features make perfect sense. Neither Bootstrap nor Foundation includes this styling specific to content management systems, so this is a distinguishing characteristic of the framework.</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2017/02/uikit-comment-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/02/uikit-comment-opt.png" alt="UIkit's comment styling." width="682" height="608" /></a><sup class="po" id="note-22"><a href="#22">22</a></sup><br />
<figcaption>UIkit offers comment styling out of the box, one of its unique styling features. (Image: <a href="https://getuikit.com/docs/comment#lists">UIkit Docs</a><sup class="po" id="note-23"><a href="#23">23</a></sup>) (<a href="https://www.smashingmagazine.com/wp-content/uploads/2017/02/uikit-comment-opt.png">View large version</a><sup class="po" id="note-24"><a href="#24">24</a></sup>)</figcaption>
</figure>
<p>Bootstrap offers much more than Foundation. Indeed, Bootstrap&#8217;s distinctive look has permeated websites for several years. Bootstrap 4 has a similar look to Bootstrap 3. Bootstrap still offers several colors, such as &#8220;warning,&#8221; &#8220;danger,&#8221; &#8220;primary,&#8221; &#8220;info&#8221; and &#8220;success,&#8221; and it typically offers a few variations on styling certain HTML elements, such as tables and forms.</p>
<p>It&#8217;s also worth comparing the CSS units in each framework. Bootstrap 4 uses rem as its primary CSS unit throughout. However, it states, &#8220;pixels are still used for media queries and grid behavior as viewports are not affected by type size.&#8221; Bootstrap also increased its base font size from 14 pixels in version 3 to 16 pixels in version 4.</p>
<p><a href="http://foundation.zurb.com/sites/docs/typography-base.html">Foundation says</a><sup class="po" id="note-25"><a href="#25">25</a></sup>, &#8220;We use the rem unit nearly everywhere in Foundation, and even wrote a Sass function to make it a little easier. The <code>rem-calc()</code> function can take one or more pixel values and convert them to proper rem values.&#8221;</p>
<p>Finally, UIkit seems to use pixels as a primary size unit, although occasionally uses percentages and rems in a few places in its LESS files. Its CSS size philosophy is not addressed in its documentation.</p>
<h3  id="navigation-and-navigation-elements">Navigation And Navigation Elements <a href="#navigation-and-navigation-elements" aria-label="Link to section 'Navigation And Navigation Elements'" class="sr hsl">Link</a></h3>
<p>All three frameworks ship with responsive navigation elements. All include some fairly common navigation components, like formatted breadcrumbs, tabs, accordions and pagination. There are minor variations between these, but they all typically work as expected.</p>
<p>All three frameworks ship with dropdown menus. In general, these dropdowns may be used in several scenarios: with standard responsive navbars, with tabs, with buttons, etc. All three include vertical dropdowns. Foundation and UIkit also include horizontal dropdowns, in which the dropdown is displayed as a row rather than a column.</p>
<p>Navigation bars are present in all three frameworks. Each navbar can accommodate website branding and search and can be made sticky, and elements can be aligned left or right in the bar. All navigation bars collapse, but they may present collapsed content differently (some via a hamburger button plus a dropdown, some via an off-canvas menu). The navigation bars also have a few differences among themselves.</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2017/02/bootstrap-nav-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/02/bootstrap-nav-opt.png" alt="Bootstrap's nav demonstrated." width="724" height="202" /></a><sup class="po" id="note-26"><a href="#26">26</a></sup><br />
<figcaption>Bootstrap&#8217;s iconic navigation bar now comes with easy color options by combining class names, or an inline color option. (Image: <a href="http://v4-alpha.getbootstrap.com/components/navbar/">Bootstrap Docs</a><sup class="po" id="note-27"><a href="#27">27</a></sup>) (<a href="https://www.smashingmagazine.com/wp-content/uploads/2017/02/bootstrap-nav-opt.png">View large version</a><sup class="po" id="note-28"><a href="#28">28</a></sup>)</figcaption>
</figure>
<p>Bootstrap offers some basic horizontal and vertical navigation bars with different styling options (tabs, pills, stacked pills, justified or plain styling). It offers a separate horizontal responsive navigation bar, which creates a hamburger button on collapse. Two color schemes are available, with colors and breakpoints customizable through SCSS.</p>
<p>Foundation had a responsive navigation bar in previous versions similar to Bootstrap&#8217;s. In version 6, it has turned several navigation bar treatments into individual elements that can be combined. For example, on collapse, the navigation may be hidden behind a hamburger button, behind an off-canvas treatment or behind a drilldown menu, in which the user loads screens of menu items. These types of navigation treatment may be changed at specific screen sizes. For example, the full navigation bar may be available at desktop dimensions but switch to a drilldown for mobile.</p>
<p>UIkit&#8217;s bar offers functionality similar to Bootstrap&#8217;s. By default, it does not have a built-in toggle, but this is easily added with the appropriate CSS classes and JavaScript. Collapsed content is typically behind a hamburger button, and it may be coupled with off-canvas functionality. UIkit also specifically offers an icon-based navigation bar (iconbar). It ships with 26 SVG icons, which can be integrated in this bar, with the promise of more icons in the future.</p>
<h3  id="javascript-components">JavaScript Components <a href="#javascript-components" aria-label="Link to section 'JavaScript Components'" class="sr hsl">Link</a></h3>
<p>All three frameworks depend on jQuery for their JavaScript-based components. Foundation and UIkit ship with a copy of jQuery, while Bootstrap relies on connecting to jQuery via a CDN or a download.</p>
<p>All three frameworks contain similar types of functionality: tooltips, modal windows, accordions, tabs, dropdown menus, image carousels, etc.</p>
<p>Foundation has two handy components that set it apart. One is Abide, a full-featured HTML5 form-validation library. It can handle client-side error-checking of forms. The other is Interchange, a JavaScript-based responsive image loader. It&#8217;s compatible with images and with bits of HTML and text. It loads the appropriate content on the page based on media queries. Despite the fact that one of the defining characteristics of responsive design is images that resize, neither Bootstrap nor UIkit offers similar functionality.</p>
<p>UIkit combines its styles and JavaScript components in its documentation, calling it all &#8220;components.&#8221; Some of the unique JavaScript-based components currently available in its beta release include Scroll, which allows smooth scrolling to other parts of the web page, and Sortable, which enables drag-and-drop grids on the page.</p>
<p><a href="https://yootheme.com/blog/2017/01/09/uikit-3-beta-released">In future versions of UIkit</a><sup class="po" id="note-29"><a href="#29">29</a></sup>, we are promised many components from UIkit 2, including &#8220;Slideshow, Slider, Slideset, Parallax, Nestable, Lightbox, Dynamic Grid, HTML editor, Date- and Timepicker components.&#8221; It&#8217;s worth highlighting HTML Editor, and the Date- and Timepicker components, because these are typically used in administrative interfaces and in applications. Remember that YOOtheme creates Joomla and WordPress themes as part of its business, so these are important components for it. Neither Foundation nor Bootstrap includes these admin-friendly widgets, so this is a distinguishing characteristic of this framework.</p>
<p>One of UIkit&#8217;s most <a href="https://getuikit.com/docs/javascript#uikit-and-reactive-javascript-frameworks">distinguishing JavaScript features</a><sup class="po" id="note-30"><a href="#30">30</a></sup>, however, is this:</p>
<blockquote><p>UIkit is listening for DOM manipulations and will automatically initialize, connect and disconnect components as they are inserted or removed from the DOM. That way it can easily be used with JavaScript frameworks like Vue.js and React.</p></blockquote>
<h3  id="so-which-is-best">So, Which Is Best? <a href="#so-which-is-best" aria-label="Link to section 'So, Which Is Best?'" class="sr hsl">Link</a></h3>
<p>It depends! All three projects are actively maintained and have devoted followers. In the end, the right framework for you will depend on your project&#8217;s requirements, where you need help in programming (making it pretty? coding functionality?) and your personal coding philosophy (rems versus pixels? LESS versus Sass?). As with all technology, there is no perfect choice, and you will have to make compromises on features, functionality and code styles.</p>
<p>With this in mind, here are some points to weigh in making your decision.</p>
<ul>
<li><strong>Browser support</strong><br />
The framework versions reviewed here support similar browsers. However, going back one framework version, or following the instructions for incorporating polyfills, might increase support for important browsers. In particular, if you need Internet Explorer 8 support, you might want to look at Bootstrap 3.</li>
<li><strong>CSS unit differences</strong><br />
Foundation keeps nearly all of its units in ems and rems. Bootstrap uses mostly ems and rems, with pixels for media queries. UIkit uses mostly pixel measurements. Some developers have strong opinions about these approaches and might choose a framework based on them.</li>
<li><strong>Quantity of styling</strong><br />
UIkit has a lot of out-of-the box styling. Foundation has much less. Bootstrap is somewhere in between. How much styling do you need to override? How much styling do you want to be present already? Do you want to write very little or none?</li>
<li><strong>CSS preprocessors</strong><br />
Foundation was written in SCSS natively. Bootstrap had a port from LESS to SCSS in version 3, then rewrote its SCSS in version 4. UIkit continues to work in LESS while in beta, but it will offer a SCSS port in future releases. This could also affect your choice of framework.</li>
<li><strong>Workflow</strong><br />
If you wish to modify SCSS files, know that Foundation will lock you into a fairly rigid workflow. Bootstrap and UIkit offer a workflow, but you can choose a different workflow or no workflow at all.</li>
<li><strong>JavaScript components</strong><br />
Foundation offers form validation and responsive content management. UIkit is specifically built to work with reactive JavaScript frameworks, and it includes components for building an admin interface. Depending on the components you require, this could sway your decision.</li>
<li><strong>Grid differences</strong><br />
Bootstrap and Foundation offer 12-column grids. UIkit offers a very different approach to grid layout, with very different styling. Foundation&#8217;s grid can easily be modified to greater or fewer columns with SCSS, and it can be made semantic as well. Grids for UIkit and Bootstrap are flexbox-based by default, while Foundation&#8217;s are float-based, but convertible to flexbox through SCSS.</li>
</ul>
<p><em property="editor">(da, al, il)</em></p>
<h4  class="po" id="footnotes">Footnotes <a href="#footnotes" aria-label="Link to section 'Footnotes'" class="sr hsl">Link</a></h4><ol class="po"><li id="#1"><a href="#note-1">1 https://www.smashingmagazine.com/2014/02/responsive-design-frameworks-just-because-you-can-should-you/</a></li><li id="#2"><a href="#note-2">2 http://tallys.github.io/color-theory/</a></li><li id="#3"><a href="#note-3">3 http://getbootstrap.com/</a></li><li id="#4"><a href="#note-4">4 http://foundation.zurb.com/</a></li><li id="#5"><a href="#note-5">5 https://getuikit.com/</a></li><li id="#6"><a href="#note-6">6 http://v4-alpha.getbootstrap.com/</a></li><li id="#7"><a href="#note-7">7 http://foundation.zurb.com/sites/docs/</a></li><li id="#8"><a href="#note-8">8 http://getuikit.com/</a></li><li id="#9"><a href="#note-9">9 http://v4-alpha.getbootstrap.com/getting-started/browsers-devices/</a></li><li id="#10"><a href="#note-10">10 http://foundation.zurb.com/sites/docs/compatibility.html</a></li><li id="#11"><a href="#note-11">11 https://v4-alpha.getbootstrap.com/getting-started/build-tools/</a></li><li id="#12"><a href="#note-12">12 http://foundation.zurb.com/sites/docs/installation.html</a></li><li id="#13"><a href="#note-13">13 https://twitter.com/jen4web</a></li><li id="#14"><a href="#note-14">14 https://twitter.com/getuikit/status/829680161968775168</a></li><li id="#15"><a href="#note-15">15 https://getuikit.com/docs/grid#usage</a></li><li id="#16"><a href="#note-16">16 https://www.smashingmagazine.com/wp-content/uploads/2017/02/foundation-grid-opt.png</a></li><li id="#17"><a href="#note-17">17 http://foundation.zurb.com/sites/docs/equalizer.html</a></li><li id="#18"><a href="#note-18">18 https://www.smashingmagazine.com/wp-content/uploads/2017/02/foundation-grid-opt.png</a></li><li id="#19"><a href="#note-19">19 https://twitter.com/jen4web</a></li><li id="#20"><a href="#note-20">20 https://twitter.com/getuikit/status/829680541179985920</a></li><li id="#21"><a href="#note-21">21 https://github.com/twbs/bootstrap/issues/19555</a></li><li id="#22"><a href="#note-22">22 https://www.smashingmagazine.com/wp-content/uploads/2017/02/uikit-comment-opt.png</a></li><li id="#23"><a href="#note-23">23 https://getuikit.com/docs/comment#lists</a></li><li id="#24"><a href="#note-24">24 https://www.smashingmagazine.com/wp-content/uploads/2017/02/uikit-comment-opt.png</a></li><li id="#25"><a href="#note-25">25 http://foundation.zurb.com/sites/docs/typography-base.html</a></li><li id="#26"><a href="#note-26">26 https://www.smashingmagazine.com/wp-content/uploads/2017/02/bootstrap-nav-opt.png</a></li><li id="#27"><a href="#note-27">27 http://v4-alpha.getbootstrap.com/components/navbar/</a></li><li id="#28"><a href="#note-28">28 https://www.smashingmagazine.com/wp-content/uploads/2017/02/bootstrap-nav-opt.png</a></li><li id="#29"><a href="#note-29">29 https://yootheme.com/blog/2017/01/09/uikit-3-beta-released</a></li><li id="#30"><a href="#note-30">30 https://getuikit.com/docs/javascript#uikit-and-reactive-javascript-frameworks</a></li></ol>
	
	
	<div class="lt"><a href="https://www.smashingmagazine.com/tag/frameworks/">Frameworks</a><a href="https://www.smashingmagazine.com/tag/mobile/">Mobile</a><a href="https://www.smashingmagazine.com/tag/responsive-web-design/">Responsive Web Design</a></div>
<p>
	<a href="#top" class="top">&uarr; Back to top</a>

	<a onclick="clicky.log('#sharelink-clicked');" class="sot single" href="https://twitter.com/intent/tweet?original_referer=https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/&#038;source=tweetbutton&#038;text=Which%20Responsive%20Design%20Framework%20Is%20Best%3F%20Of%20Course%2C%20It%20Depends.&#038;url=https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/&#038;via=smashingmag">Tweet it</a><a onclick="clicky.log('#sharelink-clicked');" class="sot single" href="http://www.facebook.com/sharer/sharer.php?u=https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/">Share on Facebook</a></p>
	</p>

</article>
<div class="bio clearfix">
  <div class="grv">
    <img src="https://secure.gravatar.com/avatar/?s=78&amp;d=mm&amp;r=g" data-src="https://secure.gravatar.com/avatar/03e76f7e3c503908b6cf79ceb0ca4041?s=78&amp;d=mm&amp;r=g" data-src-retina="https://secure.gravatar.com/avatar/03e76f7e3c503908b6cf79ceb0ca4041?s=156&amp;d=mm&amp;r=g" class="avatar" height="78" width="78" >	</div>
	<div class="about">
		<a rel="author" class="poa" href="https://www.smashingmagazine.com/author/jen-kramer/?rel=author" title="Posts by Jen Kramer">Jen Kramer</a>		<p><p>For more than seventeen years, Jen Kramer has been educating clients, colleagues, friends and graduate students about the meaning of a "quality website." Since 2000, she has built websites that are supportive of business and marketing goals in a freelance capacity and as part of an agency.</p>
				
<p>Jen is a <a href="https://www.extension.harvard.edu/faculty-directory/jennifer-kramer">Lecturer at Harvard University Extension School</a> in the Master's of Liberal Arts in Digital Media Design, teaching five courses per year, advising students, and assisting in curriculum design.</p>


<p>Jen is also a prolific video author, creating 27 training courses for <a href="http://www.lynda.com/Jen-Kramer/203-1.html?utm_medium=affiliate&utm_source=ldc_affiliate&utm_content=vanityurl&utm_campaign=CD9&aid=CD9&bid=524">lynda.com</a>, <a href="http://www.oreilly.com/pub/au/6536">O'Reilly Media</a>, and <a href="http://gymnasium.aquent.com/courses/GYM/007/0/about">Aquent Gymnasium</a>.</p>
				
<p>She is also available for individual private tutoring, customized classroom training, and occasional freelance web design work.</p>

<p>Jen earned a BS in biology at University of North Carolina at Chapel Hill and an MS in Internet Strategy Management at the Marlboro College Graduate School.</p></p>
	</div>
</div>	<div class="ras clearfix">
		<h2>Related Articles</h2>
					<div class="ra clearfix">
				<a class="pp" href="https://www.smashingmagazine.com/2017/03/a-little-surprise-is-waiting-for-you-here/">
					<img data-src="https://www.smashingmagazine.com/wp-content/uploads/2017/03/redesign-front-page-desktop-500w-opt-178x118.png" width="178" height="178" alt="118" class="wp-post-image" />					<h3>A Little Surprise Is Waiting For You Here.</h3>
				</a>
			</div>
					<div class="ra clearfix">
				<a class="pp" href="https://www.smashingmagazine.com/2017/03/beauty-imperfection-interface-design/">
					<img data-src="https://www.smashingmagazine.com/wp-content/uploads/2017/03/google-calendar-layout-500w-opt-178x118.png" width="178" height="178" alt="118" class="wp-post-image" />					<h3>The Beauty Of Imperfection In Interface Design</h3>
				</a>
			</div>
					<div class="ra clearfix">
				<a class="pp" href="https://www.smashingmagazine.com/2017/03/world-wide-web-not-wealthy-western-web-part-2/">
					<img data-src="https://www.smashingmagazine.com/wp-content/uploads/2017/03/mobile-phones-world-graphy-opt-178x118.png" width="178" height="178" alt="118" class="wp-post-image" />					<h3>World Wide Web, Not Wealthy Western Web (Part 2)</h3>
				</a>
			</div>
			</div>
<div class="adv">
	<div class="oa_zone--ad commentspnsrtarget" id="commentspnsrtarget" data-ad-name="Comment Sponsor" data-ad-zone="26" data-ad-media="all"></div>
</div>

<ul id="comments" class="sub-tabs clearfix">
	<li><a href="#show-comments" class="active">4 Comments</a></li>
	</ul>
<div id="discussion" class="subtab-pages discussion">
	<div id="show-comments">
					<ol id="comments-overview" class="cl">
  <li class="comment even thread-even depth-1 clearfix">
	<span class="cn">1</span>

	<div class="c" id="comment-1295111">
		<div class="cau clearfix">
			<img src="https://secure.gravatar.com/avatar/?s=38&amp;d=mm&amp;r=g" data-src="https://secure.gravatar.com/avatar/605d92edd2739ffa60045ce5b0f59efb?s=38&amp;d=mm&amp;r=g" data-src-retina="https://secure.gravatar.com/avatar/605d92edd2739ffa60045ce5b0f59efb?s=76&amp;d=mm&amp;r=g" class="avatar" height="38" width="38" >			<div class="aum">
				<h3>Michał Sadowski</h3>
				<span class="dati"><a href="https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/#comment-1295111" title="Jump to Commentlink #1">March 20, 2017 11:57 am</a></span>
			</div>
		</div>
		<div class="ctx">
			<p>It&#8217;s 2017 and the question whether we should use responsive framework is more important than ever. Seriously.<br />
If you are a designer, now you have actual css grid (with some polyfilling needed), mixed with flexbox can give you a hand-crafted, actually flexible layout in no time. If you are a back-end developer who was forced to work with the front end? Well, go ahead and use bootstrap or whatever, it doesn&#8217;t matter. From my experience you won&#8217;t read the documentation anyway and you&#8217;ll get a layout breaking apart everywhere because you incorrectly set classes/structure/whatever.</p>
		</div>
		<div class="com">
			<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/?replytocom=1295111#respond' onclick='return addComment.moveForm( "comment-1295111", "1295111", "respond", "284535" )' aria-label='Reply to Michał Sadowski'>Reply</a></div>
			<div class="rating__container clearfix" aria-live="polite">
	<div id="rating__value--1295111" class="rating__value rating__value--positive">5</div>
			<div class="rating__stars" data-comment_id="1295111">
						<a class="rating__button rating__button--up"
				href="#"
				data-id="1"
				data-nonce="ce9861ec02"
				title="Vote up!"
			></a>
			<a class="rating__button rating__button--down"
				href="#"
				data-id="-1"
				data-nonce="ac868fb71c"
				title="Vote down!"
			></a>
		</div>
	</div>		</div>
	</div>
<ul class="children">
<li class="comment odd alt depth-2 clearfix">
	<span class="cn">2</span>

	<div class="c" id="comment-1295114">
		<div class="cau clearfix">
			<img src="https://secure.gravatar.com/avatar/?s=38&amp;d=mm&amp;r=g" data-src="https://secure.gravatar.com/avatar/97dab738ef777b18687538938120e9b1?s=38&amp;d=mm&amp;r=g" data-src-retina="https://secure.gravatar.com/avatar/97dab738ef777b18687538938120e9b1?s=76&amp;d=mm&amp;r=g" class="avatar" height="38" width="38" >			<div class="aum">
				<h3>CLP</h3>
				<span class="dati"><a href="https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/#comment-1295114" title="Jump to Commentlink #2">March 20, 2017 2:45 pm</a></span>
			</div>
		</div>
		<div class="ctx">
			<p>This was about to me my comment as well. These overly opinionated frameworks have far more going against them than for them.</p>
		</div>
		<div class="com">
			<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/?replytocom=1295114#respond' onclick='return addComment.moveForm( "comment-1295114", "1295114", "respond", "284535" )' aria-label='Reply to CLP'>Reply</a></div>
			<div class="rating__container clearfix" aria-live="polite">
	<div id="rating__value--1295114" class="rating__value">0</div>
			<div class="rating__stars" data-comment_id="1295114">
						<a class="rating__button rating__button--up"
				href="#"
				data-id="1"
				data-nonce="5b0d103b31"
				title="Vote up!"
			></a>
			<a class="rating__button rating__button--down"
				href="#"
				data-id="-1"
				data-nonce="574713a2f4"
				title="Vote down!"
			></a>
		</div>
	</div>		</div>
	</div>
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
<li class="comment even thread-odd thread-alt depth-1 clearfix">
	<span class="cn">3</span>

	<div class="c" id="comment-1295112">
		<div class="cau clearfix">
			<img src="https://secure.gravatar.com/avatar/?s=38&amp;d=mm&amp;r=g" data-src="https://secure.gravatar.com/avatar/6cc5a644d49a9bfe88bc0819ae7bdea6?s=38&amp;d=mm&amp;r=g" data-src-retina="https://secure.gravatar.com/avatar/6cc5a644d49a9bfe88bc0819ae7bdea6?s=76&amp;d=mm&amp;r=g" class="avatar" height="38" width="38" >			<div class="aum">
				<h3>Marcello</h3>
				<span class="dati"><a href="https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/#comment-1295112" title="Jump to Commentlink #3">March 20, 2017 12:01 pm</a></span>
			</div>
		</div>
		<div class="ctx">
			<p>Thank you for this article, it&#8217;s a nice comparison.<br />
However, I think it&#8217;s not fair to have included in the comparison  Bootstrap v4 that is still an alpha version, meaning that when the beta and the final version will be realised there will be breaking changes.<br />
Also, the v4 development seems to be not so active, the first alpha of v4 has been released almost 2 years ago (19 Aug 2015 ) and still no beta is available, and that is a huge timeframe considering the evolution change of front-end techs.<br />
There&#8217;s a lot of fuss about Bootstrap v4, but since it&#8217;s way far from a stable version it&#8217;s only good for experiments, not for serious development in production (what about the support of broken changes?).<br />
Probably you wanted to make a comparison between these frameworks based on their main features, anyway I think you shouldn&#8217;t have considered an unstable framework.</p>
<p>Just my 2 cents.</p>
		</div>
		<div class="com">
			<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/?replytocom=1295112#respond' onclick='return addComment.moveForm( "comment-1295112", "1295112", "respond", "284535" )' aria-label='Reply to Marcello'>Reply</a></div>
			<div class="rating__container clearfix" aria-live="polite">
	<div id="rating__value--1295112" class="rating__value">0</div>
			<div class="rating__stars" data-comment_id="1295112">
						<a class="rating__button rating__button--up"
				href="#"
				data-id="1"
				data-nonce="bcc011b03b"
				title="Vote up!"
			></a>
			<a class="rating__button rating__button--down"
				href="#"
				data-id="-1"
				data-nonce="b9e48f017f"
				title="Vote down!"
			></a>
		</div>
	</div>		</div>
	</div>
<ul class="children">
<li class="comment byuser comment-author-jen-kramer bypostauthor odd alt depth-2 clearfix">
	<span class="cn">4</span>

	<div class="c" id="comment-1295113">
		<div class="cau clearfix">
			<img src="https://secure.gravatar.com/avatar/?s=38&amp;d=mm&amp;r=g" data-src="https://secure.gravatar.com/avatar/03e76f7e3c503908b6cf79ceb0ca4041?s=38&amp;d=mm&amp;r=g" data-src-retina="https://secure.gravatar.com/avatar/03e76f7e3c503908b6cf79ceb0ca4041?s=76&amp;d=mm&amp;r=g" class="avatar" height="38" width="38" >			<div class="aum">
				<h3><a href='http://www.jenkramer.org' rel='external nofollow' class='url'>Jen Kramer</a></h3>
				<span class="dati"><a href="https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/#comment-1295113" title="Jump to Commentlink #4">March 20, 2017 12:17 pm</a></span>
			</div>
		</div>
		<div class="ctx">
			<p>Fair enough. However, I imagine if I compared Bootstrap 3, UIkit 2, and Foundation 6, I&#8217;d get a similar comment asking me why I&#8217;m not using the latest versions of everything.</p>
		</div>
		<div class="com">
			<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/?replytocom=1295113#respond' onclick='return addComment.moveForm( "comment-1295113", "1295113", "respond", "284535" )' aria-label='Reply to Jen Kramer'>Reply</a></div>
			<div class="rating__container clearfix" aria-live="polite">
	<div id="rating__value--1295113" class="rating__value rating__value--positive">3</div>
			<div class="rating__stars" data-comment_id="1295113">
						<a class="rating__button rating__button--up"
				href="#"
				data-id="1"
				data-nonce="f9524eaf71"
				title="Vote up!"
			></a>
			<a class="rating__button rating__button--down"
				href="#"
				data-id="-1"
				data-nonce="850ff356e8"
				title="Vote down!"
			></a>
		</div>
	</div>		</div>
	</div>
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ol>
			</div>
	</div>


					<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/03/which-responsive-design-framework-is-best/#respond" style="display:none;">Click here to cancel reply.</a></small></h3>				<form action="https://www.smashingmagazine.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
					<div class="ccr right"><small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/03/which-responsive-design-framework-is-best/#respond" style="display:none;">Click here to cancel reply.</a></small></div><label for="comment">Your message</label><p>You may use simple HTML to add links or lists to your comment. Also, use <code>&lt;pre>&lt;code class="language-*">...&lt;/code>&lt;/pre></code> to mark up code snippets. We support -js, -markup and -css for comments.</p><textarea name="1f4b0-comment" id="comment" rows="10" class="input textarea" required></textarea><textarea name="comment" style="display:none" rows="1" cols="1"></textarea><div class="clearfix"><p class="input-half"><label for="comment_author">Your name</label><input type="text" name="author" id="comment_author" value="" class="input" required /></p></div>
<div class="clearfix"><p class="input-half"><label for="email">Your email</label><input type="text" name="email" id="email" value="" class="input" required /></p></div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='284535' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>				</form>
					</div><!-- #respond -->
		
			</div>		</div>		<p><a href="#top" class="top" title="Jump to the top of the page">&uarr; Back to top</a></p>
	</div></div></main>
<aside id="wpsidebar" class="sb" role="complementary">
	<div class="col side">
		<section class="mise sf clearfix" role="search">
	<form id="search_2" method="get" action="https://www.smashingmagazine.com/search-results/" target="_top">
    <label class="sl" for="searching_2">Search on Smashing Magazine</label>
		<input id="searching_2" name="q" type="text" placeholder="e.g. JavaScript" />
		<button class="search_submit" type="submit">Search</button>
		<input type="hidden" name="cx" value="partner-pub-6779860845561969:5884617103">
		<input type="hidden" name="cof" value="FORID:10">
		<input type="hidden" name="ie" value="UTF-8">
	</form>
</section>

		<section class="bw faw">
  <p class="awithus">
      <a class="ed-us" href="mailto:s&#112;&#111;&#110;soring&#64;sma&#115;hi&#110;&#103;ma&#103;&#97;&#122;&#105;&#110;e&#46;c&#111;&#109;">
	      Become a sponsor!      </a>
  </p>
  <div id="spnsrlist-a" class="oa_zone--sponsor" data-sponsor-lines="1"></div>
</section>
		
<section class="sf wg">
  <h3>
    <a href="https://www.smashingmagazine.com/the-smashing-newsletter/">
      <img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smnl.png" alt="198,064 fine folks have signed up to our Newsletter already, when will you?" />
      Smashing Newsletter
    </a>
  </h3>
  <p>Subscribe to our email newsletter for useful tips and valuable resources, sent out every second Tuesday.</p>
  <div id="mc_embed_signup" class="mcf">
    <form action="//smashingmagazine.us1.list-manage.com/subscribe/post?u=16b832d9ad4b28edf261f34df&amp;id=a1666656e0" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate">
      <label for="mcer-EMAIL" class="sr">Please provide us with your email address:</label>
      <input id="mcer-EMAIL" name="email" autocomplete="email" type="text" placeholder="email address" />
      <button id="mc-embedded-subscribe" name="subscribe" class="submit" type="submit">Subscribe</button>
    </form>
    <a href="https://www.smashingmagazine.com/the-smashing-newsletter/"><img class="mcc" src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/mc-counter.svg" alt="Currently, we have 191728 subscribers to our newsletter" /></a>
  </div>
</section>

		<section class="bw">
  <div id="spnsrlist-b" class="oa_zone--sponsor" data-sponsor-lines="3"></div>
</section>

		<section class="so wg">
	<div class="fir">
		<a href="https://www.smashingmagazine.com/2015/03/31/real-life-responsive-web-design-smashing-book-5/?utm_source=magazine&utm_medium=sidebar-ad&utm_campaign=sb5" style="border:0;">
			<img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/sidebar-sb5.png" alt="The Smashing Book #5" width="94" height="135">
		</a>
		<p>
			Smashing Book 5: "Real-Life Responsive Web Design", our playbook to master all the tricky facets and hurdles of <strong>responsive web design</strong>. Gorgeous hardcover with 584 pages. The eBook is included. Free worldwide shipping. <a href="https://www.smashingmagazine.com/2015/03/31/real-life-responsive-web-design-smashing-book-5/?utm_source=magazine&utm_medium=sidebar-ad&utm_campaign=sb5">Get your book now!</a>
		</p>
	</div>
	<div class="sec">
		<a href="https://www.smashingmagazine.com/inclusive-design-patterns" style="border: 0;">
			<img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/inclusive-design-patterns.png" alt="Inclusive Design Patterns by Heydon Pickering" width="94" height="135">
		</a>
		<p>
			Today, too many websites are still inaccessible. In our new book <em>Inclusive Design Patterns</em>, we explore how to craft <strong>flexible front-end design patterns</strong> and make future-proof and accessible interfaces without extra effort. Hardcover, 312 pages. <a href="https://www.smashingmagazine.com/inclusive-design-patterns">Get the book →</a>
		</p>
	</div>
	<div class="thi">
		<a href="https://www.smashingmagazine.com/sketch-handbook" style="border:0;">
			<img src="https://www.smashingmagazine.com/wp-content/uploads/2016/11/sketch-handbook-sidebar-opt-v2.png" alt="The Sketch Handbook, with tips and tricks for designing with Sketch." width="94" height="142"></a>
		<p>Meet the new <em>Sketch Handbook</em>, our brand <strong>new Smashing book</strong> that will help you master all the tricky, advanced facets of Sketch. Filled with <strong>practical examples and tutorials in 12 chapters</strong>, the book will help you become more proficient in your work. <a href="https://www.smashingmagazine.com/sketch-handbook">Get the book</a>.</p>
	</div>

</section>


		<section class="bw">
  <div id="spnsrlist-c" class="oa_zone--sponsor" data-sponsor-lines="2"></div>
</section>

		<section class="mt wg">
  <a href="http://mediatemple.net">
    <img data-src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/mediatemple.svg" alt="Media Temple Logo" width="94" height="94" />
  </a>
  <p>We are proudly hosted on<br /><a href="http://mediatemple.net/webhosting/vps/dedicated-server/">Media Temple Dedicated Servers</a>. Performance matters.</p>
</section>

		<section>
	<div class="oa_zone--ad" id="sidebar_special-1" data-ad-name="Sidebar Special 1" data-ad-zone="72"></div>
</section>
<section>
	<div class="oa_zone--ad" id="sidebar_special-2" data-ad-name="Sidebar Special 2" data-ad-zone="72"></div>
</section>
<section>
	<div class="oa_zone--ad" id="sidebar_special-3" data-ad-name="Sidebar Special 3" data-ad-zone="72"></div>
</section>
<section>
	<div class="oa_zone--ad" id="sidebar_special-4" data-ad-name="Sidebar Special 4" data-ad-zone="72"></div>
</section>

		
<section class="wg">
	<div id="jobs">
		<h3>
			<a href="http://jobs.smashingmagazine.com/?pk_campaign=sm&amp;piwik_kwd=widget">
				<span>Smashing Job Board</span>
				<img data-src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/sm-jobs.png" alt="Smashing Jobs" width="36" height="34" />
			</a>
		</h3>
		<ul class="tl"><li class="clearfix"><a href="http://feedproxy.google.com/~r/smjobs/~3/AEWG2CGM4IA/2477272">Marketing Designer &amp; Frontend Developer - Customer.io - (Remote) - FullTime</a><p>Hey there! I'm Rachel from Customer.io! Over the next few weeks I'll be introducing you to our company, more specifically the Marketing Team.  We're really excited t...</p></li><li class="clearfix"><a href="http://feedproxy.google.com/~r/smjobs/~3/P3vMr2rhQvs/2477247">Freelance Designer Needed for Various Projects - Digital Elite - (Europe) - Freelance</a><p>We'll keep this short.&#013;
&#013;
Here's why people love being part of the Digital Elite team:&#013;
&#013;

Work from anywhere, any hours (we just care that your ...</p></li></ul>		<a class="cr" href="http://jobs.smashingmagazine.com?pk_campaign=sm&amp;piwik_kwd=widget">
			View more job openings&hellip;		</a>
	</div>
</section>

		<section class="clearfix">
	<div class="oa_zone--ad sidebar_sky" id="sidebar_sky-1" data-ad-name="Sidebar 1" data-ad-zone="40"></div>
</section>

<section class="clearfix">
	<div class="oa_zone--ad sidebar_sky" id="sidebar_sky-2" data-ad-name="Sidebar 2" data-ad-zone="40"></div>
</section>

		<section class="so wg conf">
	<div class="thi">
		<a href="https://smashingconf.com/" style="border: 0px none;"><img alt="SmashingConf San Francisco 2017" src="https://www.smashingmagazine.com/wp-content/uploads/2016/11/smashingconf-san-francisco-2017-2.png" width="90" height="90"></a>
		<p>Meet <strong>SmashingConf San Francisco 2017</strong>, featuring <strong>front-end</strong> ingredients, <strong>UX</strong> recipes and nothing but practical beats from the hidden corners of the web. Only <strong>practical, real-life techniques</strong> and recipes you can learn from. <a href="https://smashingconf.com/"><strong>Get your ticket now!</strong></a></p>
	</div>
</section>

		<section class="bw">
  <div id="spnsrlist-d" class="oa_zone--sponsor" data-sponsor-lines="2"></div>
</section>

		<section class="clearfix">
  <div class="oa_zone--ad sidebar_sky" id="sidebar_sky-3" data-ad-name="Sidebar 3" data-ad-zone="40"></div>
</section>

	</div>
</aside>
<footer class="f" id="footer" role="contentinfo">
		<p class="stmt">
		<em>With a commitment to quality content for the design community.</em>
		<br />Founded by Vitaly Friedman and Sven Lennartz. 2006-2017.		<br />Made in Germany.		<span class="flinks">
			&#9998;
			<a href="https://www.smashingmagazine.com/write-for-us/">Write for us</a> –
			<a href="https://www.smashingmagazine.com/contact/">Contact us</a> –
			<a href="https://www.smashingmagazine.com/privacy-policy-2/">Datenschutzerklärung</a> –
			<a href="https://www.smashingmagazine.com/about/">Impressum</a>.
		</span>
	</p>
</footer>
<script type='text/javascript'>
/* <![CDATA[ */
var iec_config = {"ajax_url":"https:\/\/www.smashingmagazine.com\/wp-json\/inpsyde-extended-comments\/rate\/","nonce":"0d678823fb"};
/* ]]> */
</script>
<script id="loadjs__inpsyde_extended_comments_rating">!function(a){"use strict";a.loadOnloadJS=function(b,c){a.addEventListener("load",function(){loadJS(b,c)},!1)},a.loadJS=function(b,c){var d=a.document.createElement("script");d.src=b,d.async=c||!1,a.document.body.appendChild(d)}}(window);
 loadOnloadJS( "https://www.smashingmagazine.com/wp-content/plugins/extended-comments/assets/js/build.min.js?ver=1.0", 1 );</script><script id="inlinejs__preload-polfill">!function(t){"use strict";var e=t.document,r={};r.isPreloadSupported=function(){try{return e.createElement("link").relList.supports("preload")}catch(t){return!1}},r.init=function(){for(var t=e.getElementsByTagName("link"),r=0;r<t.length;r++){var n=t[r];"preload"===n.rel&&"style"===n.getAttribute("as")&&(loadCSS(n.href,n),n.rel=null)}},window.loadCSS&&!r.isPreloadSupported()&&r.init()}(this);</script><script id="loadjs__comment-reply"> loadOnloadJS( "https://www.smashingmagazine.com/wp-includes/js/comment-reply.min.js", 1 );</script><script id="loadjs__smash-onload"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/onload.min.js?ver=6.4.7", 1 );</script><script id="loadjs__smash-fastclick"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/fastclick.min.js?ver=6.4.7", 1 );</script><script id="loadjs__smash-lazy-images"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/lazy-images.min.js?ver=6.4.7", 1 );</script><script id="loadjs__smash-blocked"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/blocked.min.js?ver=6.4.7", 1 );</script><script id="loadjs__codepen"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/codepen.js?ver=6.4.7", 1 );</script><script id="loadjs__prism"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/prism.js?ver=6.4.7", 1 );</script><script type='text/javascript' src='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/tablesaw.min.js?ver=6.4.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var AdsI18N = {"Advertisement":"Advertisement"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/ads.min.js?ver=6.4.7'></script>
<script id="inlinejs__wp-embed">!function(a,b){"use strict";function c(){if(!e){e=!0;var a,c,d,f,g=-1!==navigator.appVersion.indexOf("MSIE 10"),h=!!navigator.userAgent.match(/Trident.*rv:11\./),i=b.querySelectorAll("iframe.wp-embedded-content");for(c=0;c<i.length;c++)if(d=i[c],!d.getAttribute("data-secret")){if(f=Math.random().toString(36).substr(2,10),d.src+="#?secret="+f,d.setAttribute("data-secret",f),g||h)a=d.cloneNode(!0),a.removeAttribute("security"),d.parentNode.replaceChild(a,d)}else;}}var d=!1,e=!1;if(b.querySelector)if(a.addEventListener)d=!0;if(a.wp=a.wp||{},!a.wp.receiveEmbedMessage)if(a.wp.receiveEmbedMessage=function(c){var d=c.data;if(d.secret||d.message||d.value)if(!/[^a-zA-Z0-9]/.test(d.secret)){var e,f,g,h,i,j=b.querySelectorAll('iframe[data-secret="'+d.secret+'"]'),k=b.querySelectorAll('blockquote[data-secret="'+d.secret+'"]');for(e=0;e<k.length;e++)k[e].style.display="none";for(e=0;e<j.length;e++)if(f=j[e],c.source===f.contentWindow){if(f.removeAttribute("style"),"height"===d.message){if(g=parseInt(d.value,10),g>1e3)g=1e3;else if(200>~~g)g=200;f.height=g}if("link"===d.message)if(h=b.createElement("a"),i=b.createElement("a"),h.href=f.getAttribute("src"),i.href=d.value,i.host===h.host)if(b.activeElement===f)a.top.location.href=d.value}else;}},d)a.addEventListener("message",a.wp.receiveEmbedMessage,!1),b.addEventListener("DOMContentLoaded",c,!1),a.addEventListener("load",c,!1)}(window,document);</script>
		<script>try {
			SmashingAds.loadAds();
		} catch ( e ) {
		}</script>

		<script>try {
			SmashingAds.render( OA_output );
		} catch ( e ) {
		}</script>

	<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"86b694293f","applicationID":"11250242","transactionName":"NgMAbEZVV0cAWxZYXg9JI1tAXVZaTksLX1YNAw==","queueTime":0,"applicationTime":278,"atts":"GkQDGg5PREk=","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>
