<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
	<title>What You Need To Know About OAuth2 And Logging In With Facebook &ndash; Smashing Magazine</title>
	<meta charset="UTF-8" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[(new Date).getTime()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=NREUM;"undefined"==typeof window.newrelic&&(newrelic=f);var s=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],l="api-",p=l+"ixn-";a(s,function(e,t){f[t]=o(l+t,!0,"api")}),f.addPageAction=o(l+"addPageAction",!0),f.setCurrentRouteName=o(l+"routeName",!0),t.exports=newrelic,f.interaction=function(){return(new r).get()};var d=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(p+"tracer",[Date.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[Date.now(),r,o],n),o)try{return t.apply(this,arguments)}finally{c.emit("fn-end",[Date.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){d[t]=o(p+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,(new Date).getTime()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o){if(!p.aborted){e&&e(n,r,o);for(var i=t(o),a=v(n),u=a.length,c=0;c<u;c++)a[c].apply(i,r);var f=s[w[n]];return f&&f.push([y,n,r,i]),i}}function d(e,t){b[e]=v(e).concat(t)}function v(e){return b[e]||[]}function g(e){return l[e]=l[e]||o(n)}function m(e,t){f(e,function(e,n){t=t||"feature",w[n]=t,t in s||(s[t]=[])})}var b={},w={},y={on:d,emit:n,get:g,listeners:v,context:t,buffer:m,abort:a,aborted:!1};return y}function i(){return new r}function a(){(s.api||s.feature)&&(p.aborted=!0,s=p.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},l={},p=t.exports=o();p.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!h++){var e=y.info=NREUM.info,t=l.getElementsByTagName("script")[0];if(setTimeout(f.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return f.abort();c(b,function(t,n){e[t]||(e[t]=n)}),u("mark",["onload",a()],null,"api");var n=l.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===l.readyState&&i()}function i(){u("mark",["domContent",a()],null,"api")}function a(){return(new Date).getTime()}var u=e("handle"),c=e(2),f=e("ee"),s=window,l=s.document,p="addEventListener",d="attachEvent",v=s.XMLHttpRequest,g=v&&v.prototype;NREUM.o={ST:setTimeout,CT:clearTimeout,XHR:v,REQ:s.Request,EV:s.Event,PR:s.Promise,MO:s.MutationObserver},e(1);var m=""+location,b={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1016.min.js"},w=v&&g&&g[p]&&!/CriOS/.test(navigator.userAgent),y=t.exports={offset:a(),origin:m,features:{},xhrWrappable:w};l[p]?(l[p]("DOMContentLoaded",i,!1),s[p]("load",r,!1)):(l[d]("onreadystatechange",o),s[d]("onload",r)),u("mark",["firstbyte",a()],null,"api");var h=0},{}]},{},["loader"]);</script>
	<link rel="dns-prefetch" href="https://media-mediatemple.netdna-ssl.com/" />
	<link rel="dns-prefetch" href="https://auslieferung.commindo-media-resourcen.de/" />
	<link rel="preconnect" href="https://media-mediatemple.netdna-ssl.com" />
	<link rel="preconnect" href="https://auslieferung.commindo-media-resourcen.de/" />
	<style id="smash-above-the-fold-css">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</style><script>!function(e){"use strict";function t(e,t,n){e.addEventListener?e.addEventListener(t,n,!1):e.attachEvent&&e.attachEvent("on"+t,n)}function n(t,n){return e.localStorage&&localStorage[t+"_content"]&&localStorage[t+"_file"]===n}function o(t,o){if(e.localStorage&&e.XMLHttpRequest)n(t,o)?r(localStorage[t+"_content"]):a(t,o);else{var i=l.createElement("link");i.href=o,i.id=t,i.rel="stylesheet",i.type="text/css",l.getElementsByTagName("head")[0].appendChild(i),l.cookie=t}}function a(e,t){var n=new XMLHttpRequest;n.open("GET",t,!0),n.onreadystatechange=function(){4===n.readyState&&200===n.status&&(r(n.responseText),localStorage[e+"_content"]=n.responseText,localStorage[e+"_file"]=t)},n.send()}function r(e){var t=l.createElement("style");t.setAttribute("type","text/css"),l.getElementsByTagName("head")[0].appendChild(t),t.styleSheet?t.styleSheet.cssText=e:t.innerHTML=e}var l=e.document,i=function(e,t,n){function o(e){return l.body?e():void setTimeout(function(){o(e)})}function a(){i.addEventListener&&i.removeEventListener("load",a),i.media=n||"all"}var r,i=l.createElement("link");if(t)r=t;else{var s=(l.body||l.getElementsByTagName("head")[0]).childNodes;r=s[s.length-1]}var c=l.styleSheets;i.rel="stylesheet",i.href=e,i.media="only x",o(function(){r.parentNode.insertBefore(i,t?r:r.nextSibling)});var d=function(e){for(var t=i.href,n=c.length;n--;)if(c[n].href===t)return e();setTimeout(function(){d(e)})};return i.addEventListener&&i.addEventListener("load",a),i.onloadcssdefined=d,d(a),i};"undefined"!=typeof exports?exports.loadCSS=i:e.loadCSS=i,e.loadLocalStorageCSS=function(a,r){n(a,r)||l.cookie.indexOf(a)>-1?o(a,r):t(e,"load",function(){o(a,r)})}}(this);</script>
<link rel="preload" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/main.min.css?ver=6.4.12" as="style" onload="this.rel='stylesheet'" /><noscript><link rel='stylesheet' id='smash-main-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/main.min.css?ver=6.4.12' type='text/css' media='all' />
</noscript><link rel="preload" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/articles-only.min.css?ver=6.4.12" as="style" onload="this.rel='stylesheet'" /><noscript><link rel='stylesheet' id='smash-article-only-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/articles-only.min.css?ver=6.4.12' type='text/css' media='all' />
</noscript><script id="loadcss__smash-below-articles">loadCSS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/below-articles.min.css?ver=6.4.12", false, "all" );</script><noscript><link rel='stylesheet' id='smash-below-articles-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/below-articles.min.css?ver=6.4.12' type='text/css' media='all' />
</noscript><script id="loadcss__smash-comments">loadCSS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/comments.min.css?ver=6.4.12", false, "all" );</script><noscript><link rel='stylesheet' id='smash-comments-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/comments.min.css?ver=6.4.12' type='text/css' media='all' />
</noscript><link rel='stylesheet' id='smash-print-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/print.min.css?ver=6.4.12' type='text/css' media='print' />
<script id="loadcss__smash-webfonts">loadLocalStorageCSS( "smash-webfonts", "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/webfonts.min.css?ver=6.4.12" );</script><!--[if IE 8]>
<link rel='stylesheet' id='smash-ie8-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/ie8-nu.min.css?ver=6.4.12' type='text/css' media='all' />
<![endif]-->

<!-- This site is optimized with the Yoast SEO Premium plugin v4.6 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="OAuth2 is the protocol that enables anyone to log in with their Facebook account. This article explains how it works."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://www.smashingmagazine.com/2017/05/oauth2-logging-in-facebook/" />
<link rel="publisher" href="https://plus.google.com/+SmashingMagazine‎"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="What You Need To Know About OAuth2 And Logging In With Facebook &ndash; Smashing Magazine" />
<meta property="og:description" content="OAuth2 is the protocol that enables anyone to log in with their Facebook account. This article explains how it works." />
<meta property="og:url" content="https://www.smashingmagazine.com/2017/05/oauth2-logging-in-facebook/" />
<meta property="og:site_name" content="Smashing Magazine" />
<meta property="article:publisher" content="https://www.facebook.com/smashmag" />
<meta property="article:tag" content="Apps" />
<meta property="article:tag" content="Browsers" />
<meta property="article:tag" content="Forms" />
<meta property="article:section" content="Coding" />
<meta property="article:published_time" content="2017-05-02T13:19:55+02:00" />
<meta property="article:modified_time" content="2017-05-02T13:21:08+02:00" />
<meta property="og:updated_time" content="2017-05-02T13:21:08+02:00" />
<meta property="og:image" content="https://www.smashingmagazine.com/wp-content/uploads/2017/05/login2-500w-opt.png" />
<meta property="og:image:width" content="500" />
<meta property="og:image:height" content="306" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="OAuth2 is the protocol that enables anyone to log in with their Facebook account. This article explains how it works." />
<meta name="twitter:title" content="What You Need To Know About OAuth2 And Logging In With Facebook &ndash; Smashing Magazine" />
<meta name="twitter:site" content="@smashingmag" />
<meta name="twitter:image" content="https://www.smashingmagazine.com/wp-content/uploads/2017/05/login2-500w-opt.png" />
<meta name="twitter:creator" content="@ZackGrossbart" />
<meta property="DC.date.issued" content="2017-05-02T13:19:55+02:00" />
<!-- / Yoast SEO Premium plugin. -->

<link rel="alternate" type="application/rss+xml" title="Smashing Magazine &raquo; Feed" href="https://www.smashingmagazine.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Smashing Magazine &raquo; Comments Feed" href="https://www.smashingmagazine.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Smashing Magazine &raquo; What You Need To Know About OAuth2 And Logging In With Facebook Comments Feed" href="https://www.smashingmagazine.com/2017/05/oauth2-logging-in-facebook/feed/" />

<script type='text/javascript'>
/* <![CDATA[ */
var SmashingServiceWorkerData = {"url":"https:\/\/www.smashingmagazine.com\/serviceWorker.js"};
/* ]]> */
</script>
<script>
var SmashingServiceWorkerData=SmashingServiceWorkerData||{url:""};(function(a,b){if(b.url&&"serviceWorker" in a){a.serviceWorker.register(b.url);window.addEventListener("load",function(){if(a.serviceWorker.controller){a.serviceWorker.controller.postMessage({command:"trimCaches"})}})}})(navigator,SmashingServiceWorkerData);
</script>
<!--[if IE 8]>
<script type='text/javascript' src='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/html5shiv.min.js?ver=6.4.12'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://www.smashingmagazine.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.smashingmagazine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.smashingmagazine.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.smashingmagazine.com/?p=288419' />
<link rel="alternate" type="application/json+oembed" href="https://www.smashingmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.smashingmagazine.com%2F2017%2F05%2Foauth2-logging-in-facebook%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.smashingmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.smashingmagazine.com%2F2017%2F05%2Foauth2-logging-in-facebook%2F&#038;format=xml" />
<!-- Stream WordPress user activity plugin v3.0.7 -->
<link rel="manifest" href="/manifest.json">	<script>
	dataLayer = [
		{
			'site': {"ID":"1","name":"Smashing Magazine","home":"https:\/\/www.smashingmagazine.com"},
			'user': {"isLoggedIn":false,"ID":0,"role":"visitor"}		}
	];
</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
		new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
		j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
		'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-NWC9FPF');
</script>

	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="mask-icon" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/s.svg" color="#e53b2c" sizes="any" />
<!--[if IE]><link href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/favicon.ico" rel="icon" /><![endif]-->
<link rel="icon" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/favicon.png" />
<meta name="application-name" content="Smashing Magazine" />
<meta name="msapplication-TileColor" content="#fff" />
<meta name="msapplication-square70x70logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-70-70.png" />
<meta name="msapplication-square150x150logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-150-150.png" />
<meta name="msapplication-wide310x150logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-310-150.png" />
<meta name="msapplication-square310x310logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-310-310.png" />
<meta name="msapplication-notification" content="frequency=30;polling-uri1=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=1;polling-uri2=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=2;polling-uri3=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=3;polling-uri4=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=4;cycle=1" />
<link rel="apple-touch-icon-precomposed" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-57x57-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-72x72-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-114x114-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-144x144-precomposed.png" />
</head>
<body id="top" class="single single-post postid-288419 single-format-standard www-section">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NWC9FPF" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div class="mnb">
	<a href="#mn" class="ntb js-toggle-btn" title="Jump to the main navigation">
		Menu	</a>
	<a href="#ms" class="stb js-toggle-btn" title="Jump to the search">
		Search    </a>
</div><a class="sr" href="#content">Jump to the content</a>
<header class="h" role="banner">
	<h1 class="logo">
		<span class="sr">Smashing Magazine</span>
		<a href="https://www.smashingmagazine.com/"><img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/logo.png" alt="Smashing Magazine Logo" srcset="https://media-mediatemple.netdna-ssl.com/wp-content/themes/smashing-magazine/assets/images/logo.svg" /></a>
	</h1>
</header>
<nav class="mn" id="mn" role="navigation menu">
	<h2>Smashing Pages:</h2>
	 <ul id="menu-smashing-mobile-network" class="mnu"><li id="menu-item-218248" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218248 menu-item-books"><a href="https://www.smashingmagazine.com/books/">Books</a></li>
<li id="menu-item-218249" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218249 menu-item-tickets"><a href="https://www.smashingmagazine.com/workshops/">Tickets</a></li>
<li id="menu-item-219109" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219109 menu-item-shop"><a href="https://shop.smashingmagazine.com/">Shop</a></li>
<li id="menu-item-188959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188959 menu-item-email-newsletter"><a href="https://www.smashingmagazine.com/the-smashing-newsletter/">Email Newsletter</a></li>
<li id="menu-item-188961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-188961 menu-item-jobs"><a href="http://jobs.smashingmagazine.com">Jobs</a></li>
<li id="menu-item-188958" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188958 menu-item-about-us-impressum"><a href="https://www.smashingmagazine.com/about/">About us / Impressum</a></li>
</ul>	<h2>Categories:</h2>
	 <ul id="menu-mobile-categories" class="mnu"><li id="menu-item-181575" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-181575 menu-item-coding"><a href="https://www.smashingmagazine.com/category/coding/">Coding</a></li>
<li id="menu-item-181576" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181576 menu-item-design"><a href="https://www.smashingmagazine.com/category/design/">Design</a></li>
<li id="menu-item-181580" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-181580 menu-item-mobile"><a href="https://www.smashingmagazine.com/category/mobile/">Mobile</a></li>
<li id="menu-item-181579" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181579 menu-item-graphics"><a href="https://www.smashingmagazine.com/category/graphics/">Graphics</a></li>
<li id="menu-item-181577" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181577 menu-item-ux-design"><a href="https://www.smashingmagazine.com/category/uxdesign/">UX Design</a></li>
<li id="menu-item-181578" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181578 menu-item-wordpress"><a href="https://www.smashingmagazine.com/category/wordpress/"><span class="long"><span>Word</span><span>Press</span></span><span class="short">WP</span></a></li>
</ul></nav>
<a class="mnc js-toggle-btn" href="#top" data-toggle-target="mn" title="Close the navigation">X</a><div class="ms" id="ms" role="search">
  <form id="mobile-searching" class="sfm clearfix" method="get" action="https://www.smashingmagazine.com/search-results/" target="_top">
    <label for="mobile-search-input">Search on Smashing Magazine</label>
    <input name="q" id="mobile-search-input" type="text" placeholder="e.g. CSS" />
    <button class="submit" type="submit">Search</button>
    <input type="hidden" name="cx" value="partner-pub-6779860845561969:5884617103">
    <input type="hidden" name="cof" value="FORID:10">
    <input type="hidden" name="ie" value="UTF-8">
  </form>
</div>
<a role="button" class="msc js-toggle-btn" href="#top" data-toggle-target="ms" title="Close the search">X</a>
<nav class="tn clearfix" role="navigation">
	 <ul id="menu-network-menu" class="nw clearfix"><li class="current"><a href="https://www.smashingmagazine.com"><img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/logo.png" alt="Smashing Magazine" srcset="https://media-mediatemple.netdna-ssl.com/wp-content/themes/smashing-magazine/assets/images/logo.svg"  /></a></li><li id="menu-item-218245" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218245 menu-item-books"><a href="https://www.smashingmagazine.com/books/">Books</a></li>
<li id="menu-item-231721" class="cody menu-item menu-item-type-custom menu-item-object-custom menu-item-231721 menu-item-ebooks"><a href="https://shop.smashingmagazine.com/products/the-smashing-library">eBooks</a></li>
<li id="menu-item-218696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218696 menu-item-tickets"><a href="https://www.smashingmagazine.com/smashing-workshops/">Tickets</a></li>
<li id="menu-item-231722" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-231722 menu-item-shop"><a href="https://shop.smashingmagazine.com/">Shop</a></li>
<li id="menu-item-2" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2 menu-item-jobs"><a href="http://jobs.smashingmagazine.com/">Jobs</a></li>
</ul><nav id="social-media-nav" role="menu">
  <ul class="ch">
  	<li class="rss">
	    <a href="https://www.smashingmagazine.com/feed/" title="Subscribe to our RSS-feed (120K)">RSS</a>
    </li>
  	<li class="fb">
	    <a href="//www.facebook.com/smashmag" title="Join our Facebook page! (267k)">Facebook</a>
    </li>
  	<li class="tw">
	    <a href="//twitter.com/smashingmag" title="Follow us on Twitter! (956k)">Twitter</a>
    </li>
  	<li class="nl">
	    <a href="https://www.smashingmagazine.com/the-smashing-newsletter/" title="Subscribe to our Email Newsletter (180k)">Newsletter</a>
    </li>
  </ul>
</nav>
</nav>
<main>
	<div class="cc">
		<div class="fluid clearfix">
			<div class="grid clearfix">
				<section class="mise sf clearfix" role="search">
	<form id="search_1" method="get" action="https://www.smashingmagazine.com/search-results/" target="_top">
    <label class="sl" for="searching_1">Search on Smashing Magazine</label>
		<input id="searching_1" name="q" type="text" placeholder="e.g. JavaScript" />
		<button class="search_submit" type="submit">Search</button>
		<input type="hidden" name="cx" value="partner-pub-6779860845561969:5884617103">
		<input type="hidden" name="cof" value="FORID:10">
		<input type="hidden" name="ie" value="UTF-8">
	</form>
</section>
				<div class="col sn">
					<div class="sct"><ul id="menu-category-menu" class="clearfix"><li id="menu-item-116" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-116 menu-item-coding"><a href="https://www.smashingmagazine.com/category/coding/">Coding</a>
<ul class="sub-menu">
	<li id="menu-item-2014" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2014 menu-item-css"><a href="https://www.smashingmagazine.com/tag/css/">CSS</a></li>
	<li id="menu-item-134810" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-134810 menu-item-html"><a href="https://www.smashingmagazine.com/tag/html/">HTML</a></li>
	<li id="menu-item-2015" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2015 menu-item-javascript"><a href="https://www.smashingmagazine.com/tag/javascript/">JavaScript</a></li>
	<li id="menu-item-2016" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2016 menu-item-techniques"><a href="https://www.smashingmagazine.com/tag/techniques/">Techniques</a></li>
</ul>
</li>
<li id="menu-item-117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-117 menu-item-design"><a href="https://www.smashingmagazine.com/category/design/">Design</a>
<ul class="sub-menu">
	<li id="menu-item-2017" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2017 menu-item-web-design"><a href="https://www.smashingmagazine.com/tag/web-design/">Web Design</a></li>
	<li id="menu-item-231166" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-231166 menu-item-responsive"><a title="Responsive Web Design" href="https://www.smashingmagazine.com/tag/responsive-web-design/">Responsive</a></li>
	<li id="menu-item-2032" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2032 menu-item-typography"><a href="https://www.smashingmagazine.com/tag/typography/">Typography</a></li>
	<li id="menu-item-2063" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2063 menu-item-inspiration"><a href="https://www.smashingmagazine.com/tag/inspiration/">Inspiration</a></li>
</ul>
</li>
<li id="menu-item-119" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-119 menu-item-mobile"><a href="https://www.smashingmagazine.com/category/mobile/">Mobile</a>
<ul class="sub-menu">
	<li id="menu-item-142132" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-142132 menu-item-iphone-ipad"><a href="https://www.smashingmagazine.com/tag/ios/">iPhone &#038; iPad</a></li>
	<li id="menu-item-143596" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143596 menu-item-android"><a href="https://www.smashingmagazine.com/tag/android/">Android</a></li>
	<li id="menu-item-143608" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143608 menu-item-design-patterns"><a href="https://www.smashingmagazine.com/tag/design-patterns/">Design Patterns</a></li>
</ul>
</li>
<li id="menu-item-118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-118 menu-item-graphics"><a href="https://www.smashingmagazine.com/category/graphics/">Graphics</a>
<ul class="sub-menu">
	<li id="menu-item-2264" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2264 menu-item-photoshop"><a href="https://www.smashingmagazine.com/tag/photoshop/">Photoshop</a></li>
	<li id="menu-item-160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-160 menu-item-fireworks"><a href="https://www.smashingmagazine.com/category/fireworks/">Fireworks</a></li>
	<li id="menu-item-2283" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2283 menu-item-wallpapers"><a href="https://www.smashingmagazine.com/tag/wallpapers/">Wallpapers</a></li>
	<li id="menu-item-2305" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2305 menu-item-freebies"><a href="https://www.smashingmagazine.com/tag/freebies/">Freebies</a></li>
</ul>
</li>
<li id="menu-item-120" class="menu-item-uxdesign menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-120 menu-item-ux-design"><a href="https://www.smashingmagazine.com/category/uxdesign/">UX Design</a>
<ul class="sub-menu">
	<li id="menu-item-143609" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143609 menu-item-usability"><a href="https://www.smashingmagazine.com/tag/usability/">Usability</a></li>
	<li id="menu-item-143610" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143610 menu-item-user-experience"><a href="https://www.smashingmagazine.com/tag/user-experience/">User Experience</a></li>
	<li id="menu-item-143611" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143611 menu-item-ui-design"><a href="https://www.smashingmagazine.com/tag/ui/">UI Design</a></li>
	<li id="menu-item-143612" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143612 menu-item-e-commerce"><a href="https://www.smashingmagazine.com/tag/e-commerce/">E-Commerce</a></li>
</ul>
</li>
<li id="menu-item-121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-121 menu-item-wordpress"><a href="https://www.smashingmagazine.com/category/wordpress/"><span class="long"><span>Word</span><span>Press</span></span><span class="short">WP</span></a>
<ul class="sub-menu">
	<li id="menu-item-143677" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143677 menu-item-essentials"><a href="https://www.smashingmagazine.com/tag/essentials/">Essentials</a></li>
	<li id="menu-item-143678" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143678 menu-item-techniques"><a href="https://www.smashingmagazine.com/tag/techniques-wp/">Techniques</a></li>
	<li id="menu-item-143679" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143679 menu-item-plugins"><a href="https://www.smashingmagazine.com/tag/plugins/">Plugins</a></li>
	<li id="menu-item-143680" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143680 menu-item-themes"><a href="https://www.smashingmagazine.com/tag/themes/">Themes</a></li>
</ul>
</li>
</ul></div>				</div>
				<div id="content" class="col main">
					<div id="blocked" class="blocked clearfix">
	<figure style="max-width: 24%;min-width: 90px;">
		<a href="https://smashingconf.com">
			<img
				src="https://www.smashingmagazine.com/wp-content/uploads/2017/04/ny-cat-round.svg"
				alt="Smashing Conf New York">
		</a>
	</figure>
	<p style="font-size: calc(1em + ((0.4vw + 0.25vh) / 2));">
		<strong>You know, we use ad-blockers as well.</strong>
		We gotta keep those servers running though. Did you know that we publish
		<a href="https://www.smashingmagazine.com/books/">useful books</a> and run
		<a href="https://www.smashingmagazine.com/smashing-workshops/">friendly conferences</a> — crafted for pros like yourself?
		E.g. our upcoming <a href="https://smashingconf.com">SmashingConf New York</a>, dedicated to smart front-end
		techniques and design patterns.
	</p>
</div>
<article class="post-288419 post type-post status-publish format-standard has-post-thumbnail hentry category-coding category-mobile tag-apps tag-browsers tag-forms" vocab="http://schema.org/" typeof="TechArticle">

		<h2>
		<a property="url" href="https://www.smashingmagazine.com/2017/05/oauth2-logging-in-facebook/" rel="bookmark" title="Read 'What You Need To Know About OAuth2 And Logging In With Facebook'"><span property="name">What You Need To Know About OAuth2 And Logging In With Facebook</span></a>
	</h2>

			
<ul class="pmd clearfix">
	<li class="a" property="author" typeof="person" resource="#authorname">By <a href="https://www.smashingmagazine.com/author/zack-grossbart/" title="Posts by Zack Grossbart" rel="author">Zack Grossbart</a></li>
				<li class="rd" property="datePublished" content="May 2nd, 2017">May 2nd, 2017</li>
				<li class="tags" property="keywords"><a href="https://www.smashingmagazine.com/tag/apps/">Apps</a><a href="https://www.smashingmagazine.com/tag/browsers/">Browsers</a><a href="https://www.smashingmagazine.com/tag/forms/">Forms</a></li>
		<li class="comments" property="discussionUrl"><a href="#comments" title="Comment on What You Need To Know About OAuth2 And Logging In With Facebook">1 Comment</a> </li>
		</ul>
	
	<div class="ad ed">
	<div class="oa_zone--ad cad" id="cad" data-ad-name="Medium Rectangle" data-ad-zone="22" data-ad-media="all"></div>
</div>

	<p>In case you&#8217;re wondering what OAuth2 is, it&#8217;s the protocol that enables anyone to log in with their Facebook account. It powers the “Log in with Facebook” button in apps and on websites everywhere.</p>
<p>This article shows you how “Log in with Facebook” works and explains the protocol behind it all. You’ll learn why you’d want to log in with Facebook, Google, Microsoft or one of the many other companies that support OAuth2.</p>
<p>We’ll look at two examples: why Spotify uses Facebook to let you log into the Spotify mobile app, and why Quora uses Google and Facebook to let you log into its website.</p>
<h4  id="further-reading-on-smashingmag"><span class="rh">Further Reading</span> on SmashingMag: <a href="#further-reading-on-smashingmag" aria-label="Link to section 'Further Reading on SmashingMag:'" class="sr hsl">Link</a></h4>
<ul>
<li><a title="Read 'Four Ways To Build A Mobile Application,'" href="https://www.smashingmagazine.com/2013/11/four-ways-to-build-a-mobile-app-part1-native-ios/" rel="bookmark">Four Ways To Build A Mobile Application</a><sup class="po" id="note-1"><a href="#1">1</a></sup></li>
<li><a title="Read 'How To Build Honest UIs And Help Users Make Better Decisions'" href="https://www.smashingmagazine.com/2016/10/how-to-build-honest-uis-and-help-users-make-better-decisions/" rel="bookmark">How To Build Honest UIs And Help Users Make Better Decisions</a><sup class="po" id="note-2"><a href="#2">2</a></sup></li>
<li><a title="Read 'Keeping Your Android App Popular After Launch'" href="https://www.smashingmagazine.com/2015/10/keep-your-android-app-popular-after-launch/" rel="bookmark">Keeping Your Android App Popular After Launch</a><sup class="po" id="note-3"><a href="#3">3</a></sup></li>
<li><a title="Read 'Spotify Playlists To Fuel Your Coding And Design Sessions'" href="https://www.smashingmagazine.com/2016/11/playlists-fuel-coding-design-sessions/" rel="bookmark">Spotify Playlists To Fuel Your Coding And Design Sessions</a><sup class="po" id="note-4"><a href="#4">4</a></sup></li>
</ul>
<h3  id="before-oauth2">Before OAuth2 <a href="#before-oauth2" aria-label="Link to section 'Before OAuth2'" class="sr hsl">Link</a></h3>
<p>OAuth2 won a standards battle a few years ago. It’s the only authentication protocol supported by the major vendors. Google recommends OAuth2 for all of its APIs, and Facebook’s Graph API only supports OAuth2.</p>
<p>The best way to understand OAuth2 is to look at what came before it and why we needed something different. It all started with Basic Auth.</p>
<h4  id="basic-auth">Basic Auth <a href="#basic-auth" aria-label="Link to section 'Basic Auth'" class="sr hsl">Link</a></h4>
<p>Authentication schemes focus on two key questions: Who are you? And can you prove it?</p>
<p>The most common way to ask these two questions is with a username and password. The username says who you are, and the password proves it.</p>
<p>Basic Auth was the first web authentication scheme. It sounds funny but “Basic authentication” was its actual name in the specification first published in 1999.</p>
<p>Basic Auth allows web servers to ask for these credentials in a way that browsers understand. The server returns an HTTP response code of <code>401</code> (which means that authentication is required) and adds a special header to the response, named <code>WWW-Authenticate</code>, with a special value of <code>Basic</code>.</p>
<p>When the browser sees this response code and this header, it shows a popup log-in dialog:</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2017/03/1-basic_auth-preview-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/03/1-basic_auth-preview-opt.png" alt="The Basic Auth log-in dialog" width="453" height="" /></a><sup class="po" id="note-5"><a href="#5">5</a></sup></p>
<figcaption>The Basic Auth log-in dialog</figcaption>
</figure>
<p>The great part about Basic Auth is its simplicity. You don’t have to write a log-in screen. The browser handles all of that and just sends the username and password to the server. It also gives the browser a chance to specially handle the password, whether by remembering it for the user, getting it from a third-party plugin or taking the user’s credentials from their operating system.</p>
<p>The downside is that you don’t get any control over the look and feel of the log-in screen. That means you can’t style it or add new functionality, such as a “Forgot password?” link or an option to create a new account. If you want more customization, you’d have to write a custom log-in form.</p>
<h4  id="custom-log-in-forms">Custom Log-In Forms <a href="#custom-log-in-forms" aria-label="Link to section 'Custom Log-In Forms'" class="sr hsl">Link</a></h4>
<p>Custom log-in forms give you all the control you could want. You write an HTML form and prompt for the credentials. You then submit the form and handle the log-in any way you want. You get total control: You can style it, ask for more details or add more links.</p>
<p>Some websites, such as WordPress, use a simple form for the log-in screen:</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2017/03/7-wordpress_login-preview-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/03/7-wordpress_login-preview-opt.png" alt="WordPress log-in screen" width="385" height="" /></a><sup class="po" id="note-6"><a href="#6">6</a></sup></p>
<figcaption>WordPress log-in screen</figcaption>
</figure>
<p>LinkedIn lets users log in or create an account on the same page, without having to go to another part of the website:</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2017/03/2-linkedin_login-large-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/03/2-linkedin_login-780w-opt.png" alt="LinkedIn log-in screen" width="780" height="508" /></a><sup class="po" id="note-7"><a href="#7">7</a></sup></p>
<figcaption>LinkedIn log-in screen (<a href="https://www.smashingmagazine.com/wp-content/uploads/2017/03/2-linkedin_login-large-opt.png">View large version</a><sup class="po" id="note-8"><a href="#8">8</a></sup>)</figcaption>
</figure>
<p>Form-based log-in is very popular, but it has a major fundamental problem: Users have to tell the website their password.</p>
<h4  id="keeping-secrets-secret">Keeping Secrets Secret <a href="#keeping-secrets-secret" aria-label="Link to section 'Keeping Secrets Secret'" class="sr hsl">Link</a></h4>
<p>In security circles, we call a password a secret. It’s a piece of information that only you have and proves that you’re you. The secret can also be more than just a password; we’ll talk more about that a little later.</p>
<p>A website can take all the security measures in the world, but if the user shares their password, then that security is gone. Hackers breached the Gawker website in 2010, exposing many users’ passwords. While this was a problem for Gawker, the problem didn’t stop there. Most people reuse passwords, so hackers took the leaked data from Gawker and tried to log into more critical websites, such as Gmail, Facebook and eBay. Anyone who used a Gawker password for more important things lost a lot more than the latest gossip about Hulk Hogan’s sex tape.</p>
<p>Making sure your users don’t reuse a password for multiple accounts is the first half of the problem — and it’s impossible. As long as people have to create different accounts all over the Internet, they will reuse their passwords.</p>
<p>The second half of the problem is storing the passwords securely.</p>
<p>When someone logs into your app, you need to verify their password, and that means you need a copy to verify it against. You could store all usernames and passwords in a database somewhere, but now you risk losing those passwords or getting hacked. The best practice is to use a <a href="https://en.wikipedia.org/wiki/Cryptographic_hash_function">hash function</a><sup class="po" id="note-9"><a href="#9">9</a></sup>, such as one of the <a href="https://en.wikipedia.org/wiki/SHA-2">SHA-2</a><sup class="po" id="note-10"><a href="#10">10</a></sup> functions. This function encrypts data in a way that you can never get it back, but you can replicate the encryption: “my password” will hash to something like <code>bb14292d91c6d0920a5536bb41f3a50f66351b7b9d94c804dfce8a96ca1051f2</code> every time.</p>
<p>And now we’re off in the tall grass: I’m telling you how to implement cryptographic protocols. Next, I’ll have to explain how to add a <a href="https://en.wikipedia.org/wiki/Salt_(cryptography)">salt</a><sup class="po" id="note-11"><a href="#11">11</a></sup> to your data and which textbooks to read on man-in-the-middle attacks. All you wanted to do is write an app, and now you have to become a security expert. We need to step back.</p>
<h3  id="oauth2">OAuth2 <a href="#oauth2" aria-label="Link to section 'OAuth2'" class="sr hsl">Link</a></h3>
<p>You probably aren’t a security expert. Even if you are, I still wouldn’t trust you with my password. OAuth2 gives you a better way.</p>
<p>As an example, I use Spotify on my iPad. I pay the company $10 a month to listen to music. Spotify gives me access on only three devices, so I need a password to make sure that nobody else uses my account. My Spotify account isn’t a big security concern. Getting hacked wouldn’t be the end of the world, but the company does have my credit card, so I want to make sure that I’m secure.</p>
<p>I hardly ever log into Spotify, so I don’t want to create another account and have to remember another password. Spotify gives me a better option:</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2017/03/3-login1-large-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/03/3-login1-780w-opt.png" alt="Spotify log-in screen with _Log in with Facebook_ option" width="780" height="1040" /></a><sup class="po" id="note-12"><a href="#12">12</a></sup></p>
<figcaption>Spotify log-in screen with “Log in with Facebook” option (<a href="https://www.smashingmagazine.com/wp-content/uploads/2017/03/3-login1-large-opt.png">View large version</a><sup class="po" id="note-13"><a href="#13">13</a></sup>)</figcaption>
</figure>
<p>I can use my Facebook account to log in. When I tap that button, Spotify sends me over to facebook.com, and I log in there. This might seem like a small detail, but it’s the most important step of the whole process.</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2017/03/4-login2-large-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/03/4-login2-780w-opt.png" alt="Facebook log-in screen for Spotify" width="780" height="1040" /></a><sup class="po" id="note-14"><a href="#14">14</a></sup></p>
<figcaption>Facebook log-in screen for Spotify (<a href="https://www.smashingmagazine.com/wp-content/uploads/2017/03/4-login2-large-opt.png">View large version</a><sup class="po" id="note-15"><a href="#15">15</a></sup>)</figcaption>
</figure>
<p>Spotify’s programmers could have written a log-in form themselves and then sent my username and password to Facebook with a back-end API, but there are two big reasons why I don’t want them to do that:</p>
<ul>
<li><strong>I don’t trust Spotify with my Facebook password.</strong><br />
I use Facebook to connect with friends and I don’t want to get hacked. I don’t trust that Spotify will handle the password correctly. I also don’t trust that it’ll avoid the temptation to do something funny with it. Maybe it would try to store it so that it can use it later. Maybe it has a bug that writes it to a file somewhere before sending it off to Facebook, so a hacker could grab it. I’m sorry, Spotify; I’m just not the trusting sort.</li>
<li><strong>I don’t want to let Spotify do everything.</strong><br />
I want Spotify to play music. I don’t want it to post to my friends’ walls when I listen to the Spice Girls. I also don’t want to let it download my list of friends and bug them to join Spotify. If I gave Spotify my Facebook password, then it could log in as me on Facebook; it could do anything I could do.</li>
</ul>
<p>There are also two big reasons why Spotify doesn’t want to do that:</p>
<ul>
<li><strong>Facebook has multiple options for me to log in.</strong><br />
I can either log in with my username and password or I can log in with the Facebook app. I can also retrieve my password from Facebook or get help that Spotify can’t give me. If I just gave Spotify my password, I wouldn’t get any of those options.</li>
<li><strong>My secret might not be a password.</strong><br />
A password is enough security for my $10-per-month Spotify account, but it might not be enough for my bank or something even more important. There are a lot of other secrets I could provide: I might have a smart card, or I might be living in a Mission Impossible movie and use a retinal scanner.</li>
</ul>
<p>I’m not in a Mission Impossible movie, but in the real world, many companies use two-factor authentication, such as a password plus something else. The most common method is to use your phone. When you want to log in, the company sends you a text with a special code that lasts for a few minutes; you then type in the code or use an app to input it.</p>
<p>Now the company is sure that nobody can log into your account without your phone. If someone steals your password, they still can’t log in. As long as you don’t lose your phone, everything is secure.</p>
<p>Facebook isn’t the only OAuth2 provider. When I log into Quora with my Google account, Google tells me what Quora would like to do and asks if that’s OK:</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2017/03/6-quora_auth-preview-opt.png"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/03/6-quora_auth-preview-opt.png" alt="The step-2 dialog for the Google Quora OAuth2 process" width="438" height="" /></a><sup class="po" id="note-16"><a href="#16">16</a></sup></p>
<figcaption>The step-2 dialog for the Google and Quora OAuth2 process</figcaption>
</figure>
<p>I might be fine with allowing Quora to view my email address and my basic profile data, but I don’t want it to manage my contacts. OAuth2 shows me all of the access that Quora wants, allowing me to pick and choose what I grant access to.</p>
<p>So, those are the advantages of OAuth2. Let’s see how it works.</p>
<h3  id="how-oauth2-works">How OAuth2 Works <a href="#how-oauth2-works" aria-label="Link to section 'How OAuth2 Works'" class="sr hsl">Link</a></h3>
<p>Facebook, Google and most of the other OAuth2 providers treat native clients differently from web clients. Native clients are considered more secure, and they get tokens and refresh tokens that can last for months. Web clients get much shorter tokens, which typically time out when the user closes the browser or hasn’t clicked on the website for a while.</p>
<p>In both cases, the log-in process is the same. The difference is in how often the user needs to go through it.</p>
<p>OAuth2 log-in follows these general steps:</p>
<ol>
<li><strong>The user tries to do something that requires authentication.</strong><br />
This could be as simple as opening an app or clicking a “Log in” button.</li>
<li><strong>The app or website determines that the user hasn’t logged in yet and starts the log-in process.</strong><br />
It does this by opening a web page and sending it to a special URL at Facebook, Google or whatever other website is providing your OAuth2.</li>
</ol>
<p>Opening a new browser window for the OAuth2 provider is a crucial step. That’s what allows providers to show their own log-in forms and to ask each user for whatever log-in information they need. Most apps do this with an embedded web view.</p>
<p>Along with the provider’s log-in URL, you need to send some URL parameters that tell the provider who you are and what you want to do:</p>
<ul>
<li><code>client_id</code><br />
This tells the OAuth2 provider what your app is. You’ll need to register your app ahead of time to get a client ID.</li>
<li><code>redirect_uri</code><br />
This tells the provider where you want to go when you’re done. For a website, this could be back to the main page; a native app could go to a page that closes the web view.</li>
<li><code>response_type</code><br />
This tells the provider what you want back. Normally, this value is either <code>token</code>, to indicate that you want an access token, or <code>code</code>, to indicate that you want an access code. Providers may also extend this value to provide other types of data.</li>
<li><code>scope</code><br />
This tells the provider what your app wants to access. This is how Google knows that Quora is asking for access to manage your contacts. Each provider has a different set of scopes.</li>
</ul>
<p>There are additional fields that can add more security or help with caching. Certain providers also get to add more fields, but these four are the important ones.</p>
<p>Once your app opens the web view, the provider takes over. They might just ask for a simple username and password, or they might present multiple screens requesting anything from the name of your favorite teacher to your mother’s maiden name. That’s all up to them. The important part is that, when the provider is done, they will redirect back to you and give you a token.</p>
<h4  id="its-all-about-the-tokens">It’s All About The Tokens <a href="#its-all-about-the-tokens" aria-label="Link to section 'It’s All About The Tokens'" class="sr hsl">Link</a></h4>
<p>When the process completes, the provider will give you a token and a token type. There are two types of tokens: access tokens and refresh tokens. The type of client you have will determine which types of tokens you’re allowed to ask for.</p>
<p>When I log into my Spotify app, I can stay logged in for months, because the assumption is that my phone is used only by me. Facebook trusts the Spotify app to manage the tokens, and I trust the Spotify app not to lose the tokens.</p>
<p>When the access token times out (typically, in one to two hours), Spotify can use the refresh token to get a new one.</p>
<p>The refresh token lasts for months. That way, I only have to log in on my phone a few times a year. The downside is that if I lose that refresh token, someone else could use my account for months. The refresh token is so important that iOS provides a keychain for tokens, where it makes sure to encrypt and store them safely.</p>
<p>Using OAuth2 in a web application works the same way. Instead of using a web view, you can open up the OAuth2 log-in request in a frame, an iframe or a separate window. You can also open it on the current page, but this would cause you to lose all JavaScript application state whenever someone needs to log in.</p>
<p>When I log into Quora with my web browser, I don’t get a refresh token. They want the token to time out and prompt me to log in again when I quit my browser or even just go away for lunch. Untrusted clients can’t refresh the token because they can’t be trusted to hold on to the important refresh token. It’s more secure but less convenient, because they will prompt you to log in again much more frequently.</p>
<h3  id="using-oauth2-in-your-app">Using OAuth2 In Your App <a href="#using-oauth2-in-your-app" aria-label="Link to section 'Using OAuth2 In Your App'" class="sr hsl">Link</a></h3>
<p>Now you know how OAuth2 works, but you probably don’t want to implement your own OAuth2 client. You could go read the whole 75-page <a href="https://tools.ietf.org/html/rfc6749">OAuth 2.0 specification</a><sup class="po" id="note-17"><a href="#17">17</a></sup> if you’re having trouble sleeping, but you don’t need to. Some great libraries are out there for you to use.</p>
<p>iOS has built-in support for OAuth2. Corrina Krych has a very helpful tutorial on <a href="https://www.raywenderlich.com/99431/oauth-2-with-swift-tutorial">using OAuth 2.0 with Swift</a><sup class="po" id="note-18"><a href="#18">18</a></sup>. It walks you through how to get a token, how to integrate the views in your app and where to store your tokens.</p>
<p>Android also has built-in support for OAuth2. I must admit that I’m not as familiar with it because I focus on iOS, but there are some good <a href="https://developer.android.com/training/id-auth/authenticate.html">sections in the documentation</a><sup class="po" id="note-19"><a href="#19">19</a></sup> to show you examples and some open-source libraries to make it even easier.</p>
<p>JavaScript doesn’t have built-in support for OAuth2, but there are clients for all of the major JavaScript libraries. React fully supports OAuth2. AngularJS has third-party support for OAuth2.0 for many projects. I even wrote <a href="https://github.com/gromit-soft">one of them</a><sup class="po" id="note-20"><a href="#20">20</a></sup>.</p>
<p>Once you have an OAuth2 client, you’ll need to choose a provider.</p>
<h3  id="who-do-you-trust">Who Do You Trust? <a href="#who-do-you-trust" aria-label="Link to section 'Who Do You Trust?'" class="sr hsl">Link</a></h3>
<p>The big assumption here is that I trust Facebook more than Spotify. I have no good reason for that. Facebook doesn’t make its internal security public, and there’s no good way for me to audit it. Neither does Spotify. There’s no Consumer Reports for OAuth2 security. I’m basically trusting Facebook because it’s bigger. I trust Facebook because other people do.</p>
<p>I’m also trusting Facebook more every time I click the “Log in with Facebook” button. If Facebook loses my password, then hackers will get access not just to my Facebook account, but also to my Spotify account and to any other service I’ve logged into with my Facebook account. The upside is that there is only one place I have to reset my password in order to fix the problem.</p>
<p>I don’t have to trust Facebook, but I have to trust someone. Somebody has to authenticate me. I need to choose the provider I trust.</p>
<h4  id="choosing-an-oauth2-provider">Choosing an OAuth2 Provider <a href="#choosing-an-oauth2-provider" aria-label="Link to section 'Choosing an OAuth2 Provider'" class="sr hsl">Link</a></h4>
<p>Wikipedia maintains a <a href="https://en.wikipedia.org/wiki/List_of_OAuth_providers">list of OAuth providers</a><sup class="po" id="note-21"><a href="#21">21</a></sup>, but you wouldn’t care about most of them. The big ones are Facebook and Google. You might also want to look at Amazon or Microsoft.</p>
<p>All four of them are big and easy to integrate with. Facebook provides <a href="https://developers.facebook.com/docs/apps/register">instructions for registering an app</a><sup class="po" id="note-22"><a href="#22">22</a></sup>. Google has <a href="https://developers.google.com/identity/protocols/OAuth2">similar steps</a><sup class="po" id="note-23"><a href="#23">23</a></sup>. The basic idea is that you create a developer account and then create an app ID. The provider then gives you a client ID that you can use to make requests.</p>
<p>You can also choose multiple providers. Quora allows you to log in with Facebook or Google; because they both use OAuth2, you may use the same code for both.</p>
<h3  id="whats-missing-from-oauth2">What’s Missing From OAuth2 <a href="#whats-missing-from-oauth2" aria-label="Link to section 'What’s Missing From OAuth2'" class="sr hsl">Link</a></h3>
<p>OAuth2 does a very good job of solving a complex problem, but it is missing a couple of things:</p>
<ul>
<li><strong>The standard isn’t completely standard.</strong><br />
I’ve never been able to write a single OAuth2 client that can log into both Facebook and Google without a few <code>if</code> statements. Each interprets the specification differently, and there are little dissimilar details for each one. They also always have different ideas on what scopes to provide. Using a library to integrate with OAuth2 helps a lot with this problem, but it will never be 100% transparent in your app’s code.</li>
<li><strong>Logging out is tricky.</strong><br />
Every app or website that uses OAuth2 has a log-out button, but most will just forget the tokens without invalidating them. The app will forget about all of your current tokens and allow someone else to log in, but your tokens are still valid. If a hacker stole your token, they could still use it and log in as you.</li>
</ul>
<p>There is a separate specification for <a href="https://tools.ietf.org/html/rfc7009">invalidating OAuth2 tokens</a><sup class="po" id="note-24"><a href="#24">24</a></sup>, but it wasn’t picked up by many of the major providers. OAuth2 doesn’t provide a way to recover if a hacker gets your refresh token; even though you can delete your local copy of the token, the hacker will still have it. Many providers give you a way to suspend your account, but there’s no standard way to do it.</p>
<p>In defence of OAuth2, this is a difficult problem, because many providers use <a href="https://www.smashingmagazine.com/2012/05/backpack-algorithms-and-public-key-cryptography-made-easy/">public-key cryptography</a><sup class="po" id="note-25"><a href="#25">25</a></sup> to create stateless tokens. This means that the server doesn’t remember the tokens it has created, so it can’t forget them later.</p>
<p>The other major problem with OAuth2 is that you are dependent on your provider. When Facebook goes down, so does the “Log in with Facebook” button in your app. If Google decides to start charging you to support OAuth2 or demands that you share your profit with it, there’s nothing you can do. This is the double-edged sword of trusting a provider: They are doing a lot for you, but they have control over your users.</p>
<h3  id="oauth2-runs-the-world">OAuth2 Runs The World <a href="#oauth2-runs-the-world" aria-label="Link to section 'OAuth2 Runs The World'" class="sr hsl">Link</a></h3>
<p>Even with a couple of missing features and a big dependency, OAuth2 is still an excellent choice. It makes it easy for users to log into your app, to not have to remember a password for every website, and to trust your security. OAuth2 is a very popular choice. It dominates the industry. No other security protocol comes close to the adoption of OAuth2.</p>
<p>Now you know where OAuth2 comes from and how it works. Go make smart choices about who to trust, stop reading articles about safely storing encrypted passwords, and spend more of your time writing your amazing app.</p>
<p><em property="editor">(da, il, al)</em></p>
<h4  class="po" id="footnotes">Footnotes <a href="#footnotes" aria-label="Link to section 'Footnotes'" class="sr hsl">Link</a></h4><ol class="po"><li id="#1"><a href="#note-1">1 https://www.smashingmagazine.com/2013/11/four-ways-to-build-a-mobile-app-part1-native-ios/</a></li><li id="#2"><a href="#note-2">2 https://www.smashingmagazine.com/2016/10/how-to-build-honest-uis-and-help-users-make-better-decisions/</a></li><li id="#3"><a href="#note-3">3 https://www.smashingmagazine.com/2015/10/keep-your-android-app-popular-after-launch/</a></li><li id="#4"><a href="#note-4">4 https://www.smashingmagazine.com/2016/11/playlists-fuel-coding-design-sessions/</a></li><li id="#5"><a href="#note-5">5 https://www.smashingmagazine.com/wp-content/uploads/2017/03/1-basic_auth-preview-opt.png</a></li><li id="#6"><a href="#note-6">6 https://www.smashingmagazine.com/wp-content/uploads/2017/03/7-wordpress_login-preview-opt.png</a></li><li id="#7"><a href="#note-7">7 https://www.smashingmagazine.com/wp-content/uploads/2017/03/2-linkedin_login-large-opt.png</a></li><li id="#8"><a href="#note-8">8 https://www.smashingmagazine.com/wp-content/uploads/2017/03/2-linkedin_login-large-opt.png</a></li><li id="#9"><a href="#note-9">9 https://en.wikipedia.org/wiki/Cryptographic_hash_function</a></li><li id="#10"><a href="#note-10">10 https://en.wikipedia.org/wiki/SHA-2</a></li><li id="#11"><a href="#note-11">11 https://en.wikipedia.org/wiki/Salt_(cryptography)</a></li><li id="#12"><a href="#note-12">12 https://www.smashingmagazine.com/wp-content/uploads/2017/03/3-login1-large-opt.png</a></li><li id="#13"><a href="#note-13">13 https://www.smashingmagazine.com/wp-content/uploads/2017/03/3-login1-large-opt.png</a></li><li id="#14"><a href="#note-14">14 https://www.smashingmagazine.com/wp-content/uploads/2017/03/4-login2-large-opt.png</a></li><li id="#15"><a href="#note-15">15 https://www.smashingmagazine.com/wp-content/uploads/2017/03/4-login2-large-opt.png</a></li><li id="#16"><a href="#note-16">16 https://www.smashingmagazine.com/wp-content/uploads/2017/03/6-quora_auth-preview-opt.png</a></li><li id="#17"><a href="#note-17">17 https://tools.ietf.org/html/rfc6749</a></li><li id="#18"><a href="#note-18">18 https://www.raywenderlich.com/99431/oauth-2-with-swift-tutorial</a></li><li id="#19"><a href="#note-19">19 https://developer.android.com/training/id-auth/authenticate.html</a></li><li id="#20"><a href="#note-20">20 https://github.com/gromit-soft</a></li><li id="#21"><a href="#note-21">21 https://en.wikipedia.org/wiki/List_of_OAuth_providers</a></li><li id="#22"><a href="#note-22">22 https://developers.facebook.com/docs/apps/register</a></li><li id="#23"><a href="#note-23">23 https://developers.google.com/identity/protocols/OAuth2</a></li><li id="#24"><a href="#note-24">24 https://tools.ietf.org/html/rfc7009</a></li><li id="#25"><a href="#note-25">25 https://www.smashingmagazine.com/2012/05/backpack-algorithms-and-public-key-cryptography-made-easy/</a></li></ol>
	
	
	<div class="lt"><a href="https://www.smashingmagazine.com/tag/apps/">Apps</a><a href="https://www.smashingmagazine.com/tag/browsers/">Browsers</a><a href="https://www.smashingmagazine.com/tag/forms/">Forms</a></div>
<p>
	<a href="#top" class="top">&uarr; Back to top</a>

	<a onclick="clicky.log('#sharelink-clicked');" class="sot single" href="https://twitter.com/intent/tweet?original_referer=https://www.smashingmagazine.com/2017/05/oauth2-logging-in-facebook/&#038;source=tweetbutton&#038;text=What%20You%20Need%20To%20Know%20About%20OAuth2%20And%20Logging%20In%20With%20Facebook&#038;url=https://www.smashingmagazine.com/2017/05/oauth2-logging-in-facebook/&#038;via=smashingmag">Tweet it</a><a onclick="clicky.log('#sharelink-clicked');" class="sot single" href="http://www.facebook.com/sharer/sharer.php?u=https://www.smashingmagazine.com/2017/05/oauth2-logging-in-facebook/">Share on Facebook</a></p>
	</p>

</article>
<div class="bio clearfix">
  <div class="grv">
    <img src="https://secure.gravatar.com/avatar/?s=78&amp;d=mm&amp;r=g" data-src="https://secure.gravatar.com/avatar/f5723210ca0f0701be05a6b54b231c9c?s=78&amp;d=mm&amp;r=g" data-src-retina="https://secure.gravatar.com/avatar/f5723210ca0f0701be05a6b54b231c9c?s=156&amp;d=mm&amp;r=g" class="avatar" height="78" width="78" >	</div>
	<div class="about">
		<a rel="author" class="poa" href="https://www.smashingmagazine.com/author/zack-grossbart/?rel=author" title="Posts by Zack Grossbart">Zack Grossbart</a>		<p><a href="http://www.zackgrossbart.com/">Zack Grossbart</a> is an engineer, designer, and author.  He's an Architecting Engineer and Human Factors Specialist at <a href="https://www.microfocus.com/">Micro Focus</a> where he focuses on enterprise identity and security.  Zack began loading DOS from a floppy disk when he was five years old. He's been getting paid to code since he was 15 and started his first software company when he was 16. Zack lives in Cambridge, Massachusetts with his wife and daughter.</p>
	</div>
</div><div class="adv">
	<div class="oa_zone--ad commentspnsrtarget" id="commentspnsrtarget" data-ad-name="Comment Sponsor" data-ad-zone="26" data-ad-media="all"></div>
</div>

<ul id="comments" class="sub-tabs clearfix">
	<li><a href="#show-comments" class="active">1 Comment</a></li>
	</ul>
<div id="discussion" class="subtab-pages discussion">
	<div id="show-comments">
					<ol id="comments-overview" class="cl">
  <li class="comment even thread-even depth-1 clearfix">
	<span class="cn">1</span>

	<div class="c" id="comment-1296128">
		<div class="cau clearfix">
			<img src="https://secure.gravatar.com/avatar/?s=38&amp;d=mm&amp;r=g" data-src="https://secure.gravatar.com/avatar/feb6b33f97536942cc18f66bcc2c7b57?s=38&amp;d=mm&amp;r=g" data-src-retina="https://secure.gravatar.com/avatar/feb6b33f97536942cc18f66bcc2c7b57?s=76&amp;d=mm&amp;r=g" class="avatar" height="38" width="38" >			<div class="aum">
				<h3>krissanawat</h3>
				<span class="dati"><a href="https://www.smashingmagazine.com/2017/05/oauth2-logging-in-facebook/#comment-1296128" title="Jump to Commentlink #1">May 2, 2017 1:40 pm</a></span>
			</div>
		</div>
		<div class="ctx">
			<p>Great article, Zack!</p>
		</div>
		<div class="com">
			<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-1296128' onclick='return addComment.moveForm( "comment-1296128", "1296128", "respond", "288419" )' aria-label='Reply to krissanawat'>Reply</a></div>
			<div class="rating__container clearfix" aria-live="polite">
	<div id="rating__value--1296128" class="rating__value">0</div>
			<div class="rating__stars" data-comment_id="1296128">
						<a class="rating__button rating__button--up"
				href="#"
				data-id="1"
				data-nonce="934bd9c58b"
				title="Vote up!"
			></a>
			<a class="rating__button rating__button--down"
				href="#"
				data-id="-1"
				data-nonce="3594647e26"
				title="Vote down!"
			></a>
		</div>
	</div>		</div>
	</div>
</li><!-- #comment-## -->
</ol>
			</div>
	</div>


					<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/05/oauth2-logging-in-facebook/#respond" style="display:none;">Click here to cancel reply.</a></small></h3>				<form action="https://www.smashingmagazine.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
					<div class="ccr right"><small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/05/oauth2-logging-in-facebook/#respond" style="display:none;">Click here to cancel reply.</a></small></div><label for="comment">Your message</label><p>You may use simple HTML to add links or lists to your comment. Also, use <code>&lt;pre>&lt;code class="language-*">...&lt;/code>&lt;/pre></code> to mark up code snippets. We support -js, -markup and -css for comments.</p><textarea name="1f4b0-comment" id="comment" rows="10" class="input textarea" required></textarea><textarea name="comment" style="display:none" rows="1" cols="1"></textarea><div class="clearfix"><p class="input-half"><label for="comment_author">Your name</label><input type="text" name="author" id="comment_author" value="" class="input" required /></p></div>
<div class="clearfix"><p class="input-half"><label for="email">Your email</label><input type="text" name="email" id="email" value="" class="input" required /></p></div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='288419' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>				</form>
					</div><!-- #respond -->
		
			</div>		</div>		<p><a href="#top" class="top" title="Jump to the top of the page">&uarr; Back to top</a></p>
	</div></div></main>
<aside id="wpsidebar" class="sb" role="complementary">
	<div class="col side">
		<section class="mise sf clearfix" role="search">
	<form id="search_2" method="get" action="https://www.smashingmagazine.com/search-results/" target="_top">
    <label class="sl" for="searching_2">Search on Smashing Magazine</label>
		<input id="searching_2" name="q" type="text" placeholder="e.g. JavaScript" />
		<button class="search_submit" type="submit">Search</button>
		<input type="hidden" name="cx" value="partner-pub-6779860845561969:5884617103">
		<input type="hidden" name="cof" value="FORID:10">
		<input type="hidden" name="ie" value="UTF-8">
	</form>
</section>

		<section class="bw faw">
  <p class="awithus">
      <a class="ed-us" href="mailto:sp&#111;n&#115;o&#114;&#105;&#110;&#103;&#64;&#115;&#109;&#97;&#115;&#104;&#105;&#110;&#103;maga&#122;i&#110;e&#46;&#99;om">
	      Become a sponsor!      </a>
  </p>
  <div id="spnsrlist-a" class="oa_zone--sponsor" data-sponsor-lines="1"></div>
</section>
		
<section class="sf wg">
  <h3>
    <a href="https://www.smashingmagazine.com/the-smashing-newsletter/">
      <img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smnl.png" alt="198,064 fine folks have signed up to our Newsletter already, when will you?" />
      Smashing Newsletter
    </a>
  </h3>
  <p>Subscribe to our email newsletter for useful tips and valuable resources, sent out every second Tuesday.</p>
  <div id="mc_embed_signup" class="mcf">
    <form action="//smashingmagazine.us1.list-manage.com/subscribe/post?u=16b832d9ad4b28edf261f34df&amp;id=a1666656e0" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate">
      <label for="mcer-EMAIL" class="sr">Please provide us with your email address:</label>
      <input id="mcer-EMAIL" name="email" autocomplete="email" type="text" placeholder="email address" />
      <button id="mc-embedded-subscribe" name="subscribe" class="submit" type="submit">Subscribe</button>
    </form>
    <a href="https://www.smashingmagazine.com/the-smashing-newsletter/"><img class="mcc" src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/mc-counter.svg" alt="Currently, we have 191728 subscribers to our newsletter" /></a>
  </div>
</section>

		<section class="bw">
  <div id="spnsrlist-b" class="oa_zone--sponsor" data-sponsor-lines="3"></div>
</section>

		<section class="so wg">
	<div class="fir">
		<a href="https://www.smashingmagazine.com/2015/03/31/real-life-responsive-web-design-smashing-book-5/?utm_source=magazine&utm_medium=sidebar-ad&utm_campaign=sb5" style="border:0;">
			<img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/sidebar-sb5.png" alt="The Smashing Book #5" width="94" height="135">
		</a>
		<p>
			Smashing Book 5: "Real-Life Responsive Web Design", our playbook to master all the tricky facets and hurdles of <strong>responsive web design</strong>. Gorgeous hardcover with 584 pages. The eBook is included. Free worldwide shipping. <a href="https://www.smashingmagazine.com/2015/03/31/real-life-responsive-web-design-smashing-book-5/?utm_source=magazine&utm_medium=sidebar-ad&utm_campaign=sb5">Get your book now!</a>
		</p>
	</div>
	<div class="sec">
		<a href="https://www.smashingmagazine.com/inclusive-design-patterns" style="border: 0;">
			<img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/inclusive-design-patterns.png" alt="Inclusive Design Patterns by Heydon Pickering" width="94" height="135">
		</a>
		<p>
			Today, too many websites are still inaccessible. In our new book <em>Inclusive Design Patterns</em>, we explore how to craft <strong>flexible front-end design patterns</strong> and make future-proof and accessible interfaces without extra effort. Hardcover, 312 pages. <a href="https://www.smashingmagazine.com/inclusive-design-patterns">Get the book →</a>
		</p>
	</div>
	<div class="thi">
		<a href="https://www.smashingmagazine.com/sketch-handbook" style="border:0;">
			<img src="https://www.smashingmagazine.com/wp-content/uploads/2016/11/sketch-handbook-sidebar-opt-v2.png" alt="The Sketch Handbook, with tips and tricks for designing with Sketch." width="94" height="142"></a>
		<p>Meet the new <em>Sketch Handbook</em>, our brand <strong>new Smashing book</strong> that will help you master all the tricky, advanced facets of Sketch. Filled with <strong>practical examples and tutorials in 12 chapters</strong>, the book will help you become more proficient in your work. <a href="https://www.smashingmagazine.com/sketch-handbook">Get the book</a>.</p>
	</div>

</section>


		<section class="bw">
  <div id="spnsrlist-c" class="oa_zone--sponsor" data-sponsor-lines="2"></div>
</section>

		<section class="mt wg">
  <a href="http://mediatemple.net">
    <img data-src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/mediatemple.svg" alt="Media Temple Logo" width="94" height="94" />
  </a>
  <p>We are proudly hosted on<br /><a href="http://mediatemple.net/webhosting/vps/dedicated-server/">Media Temple Dedicated Servers</a>. Performance matters.</p>
</section>

		<section>
	<div class="oa_zone--ad" id="sidebar_special-1" data-ad-name="Sidebar Special 1" data-ad-zone="72"></div>
</section>
<section>
	<div class="oa_zone--ad" id="sidebar_special-2" data-ad-name="Sidebar Special 2" data-ad-zone="72"></div>
</section>
<section>
	<div class="oa_zone--ad" id="sidebar_special-3" data-ad-name="Sidebar Special 3" data-ad-zone="72"></div>
</section>
<section>
	<div class="oa_zone--ad" id="sidebar_special-4" data-ad-name="Sidebar Special 4" data-ad-zone="72"></div>
</section>

		
<section class="wg">
	<div id="jobs">
		<h3>
			<a href="http://jobs.smashingmagazine.com/?pk_campaign=sm&amp;piwik_kwd=widget">
				<span>Smashing Job Board</span>
				<img data-src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/sm-jobs.png" alt="Smashing Jobs" width="36" height="34" />
			</a>
		</h3>
		<ul class="tl"><li class="clearfix"><a href="http://feedproxy.google.com/~r/smjobs/~3/ISsQr5RnSHY/2488732">Video Instructor, User Experience Design (Freelance) - CareerFoundry GmbH - (Remote) - Freelance</a><p>CareerFoundry is a young, well-funded, and quickly growing Online Education Startup based in Berlin, Germany. We offer eager learners from all over the world the cha...</p></li><li class="clearfix"><a href="http://feedproxy.google.com/~r/smjobs/~3/j3w_obYE5JE/2487977">Senior Front End Developer - Red Ventures - (Charlotte, NC) - FullTime</a><p>At Red Ventures our product is our expertise in how to market and sell in the digital world. We combine digital acumen – think design, creative, content, etc. – ...</p></li></ul>		<a class="cr" href="http://jobs.smashingmagazine.com?pk_campaign=sm&amp;piwik_kwd=widget">
			View more job openings&hellip;		</a>
	</div>
</section>

		<section class="clearfix">
	<div class="oa_zone--ad sidebar_sky" id="sidebar_sky-1" data-ad-name="Sidebar 1" data-ad-zone="40"></div>
</section>

<section class="clearfix">
	<div class="oa_zone--ad sidebar_sky" id="sidebar_sky-2" data-ad-name="Sidebar 2" data-ad-zone="40"></div>
</section>

		<section class="so wg conf">
	<div class="thi">
		<a href="https://smashingconf.com/" style="border: 0px none;">
			<img
				alt="SmashingConf New York 2017"
				src="https://www.smashingmagazine.com/wp-content/uploads/2017/04/ny-cat-round.svg"
				width="90"
				height="90">
		</a>
		<p>
			Meet us in <a href="https://smashingconf.com/"><strong>SmashingConf New York</strong></a>
			and learn about Atomic Design, DevTools, Persuasive Design, performance, and more.
			Taking place on <strong>June 13-14</strong>.
			With Brad Frost, Sara Soueidan, Umar Hansa, Yuko Shimizu, and others.
			<a href="https://smashingconf.com/"><strong>Get your ticket now!</strong></a>
		</p>
	</div>
</section>
		<section class="bw">
  <div id="spnsrlist-d" class="oa_zone--sponsor" data-sponsor-lines="2"></div>
</section>

		<section class="clearfix">
  <div class="oa_zone--ad sidebar_sky" id="sidebar_sky-3" data-ad-name="Sidebar 3" data-ad-zone="40"></div>
</section>

	</div>
</aside>
<footer class="f" id="footer" role="contentinfo">
		<p class="stmt">
		<em>With a commitment to quality content for the design community.</em>
		<br />Founded by Vitaly Friedman and Sven Lennartz. 2006-2017.		<br />Made in Germany.		<span class="flinks">
			&#9998;
			<a href="https://www.smashingmagazine.com/write-for-us/">Write for us</a> –
			<a href="https://www.smashingmagazine.com/contact/">Contact us</a> –
			<a href="https://www.smashingmagazine.com/privacy-policy-2/">Datenschutzerklärung</a> –
			<a href="https://www.smashingmagazine.com/about/">Impressum</a>.
		</span>
	</p>
</footer>
<script type='text/javascript'>
/* <![CDATA[ */
var iec_config = {"ajax_url":"https:\/\/www.smashingmagazine.com\/wp-json\/inpsyde-extended-comments\/rate\/","nonce":"015bb89305"};
/* ]]> */
</script>
<script id="loadjs__inpsyde_extended_comments_rating">!function(a){"use strict";a.loadOnloadJS=function(b,c){a.addEventListener("load",function(){loadJS(b,c)},!1)},a.loadJS=function(b,c){var d=a.document.createElement("script");d.src=b,d.async=c||!1,a.document.body.appendChild(d)}}(window);
 loadOnloadJS( "https://www.smashingmagazine.com/wp-content/plugins/extended-comments/assets/js/build.min.js?ver=1.0", 1 );</script><script id="inlinejs__preload-polfill">!function(t){"use strict";var e=t.document,r={};r.isPreloadSupported=function(){try{return e.createElement("link").relList.supports("preload")}catch(t){return!1}},r.init=function(){for(var t=e.getElementsByTagName("link"),r=0;r<t.length;r++){var n=t[r];"preload"===n.rel&&"style"===n.getAttribute("as")&&(loadCSS(n.href,n),n.rel=null)}},window.loadCSS&&!r.isPreloadSupported()&&r.init()}(this);</script><script id="loadjs__comment-reply"> loadOnloadJS( "https://www.smashingmagazine.com/wp-includes/js/comment-reply.min.js", 1 );</script><script id="loadjs__smash-onload"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/onload.min.js?ver=6.4.12", 1 );</script><script id="loadjs__smash-fastclick"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/fastclick.min.js?ver=6.4.12", 1 );</script><script id="loadjs__smash-lazy-images"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/lazy-images.min.js?ver=6.4.12", 1 );</script><script id="loadjs__smash-blocked"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/blocked.min.js?ver=6.4.12", 1 );</script><script id="loadjs__codepen"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/codepen.js?ver=6.4.12", 1 );</script><script id="loadjs__prism"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/prism.js?ver=6.4.12", 1 );</script><script type='text/javascript'>
/* <![CDATA[ */
var AdsI18N = {"Advertisement":"Advertisement"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/ads.min.js?ver=6.4.12'></script>
<script id="inlinejs__wp-embed">!function(a,b){"use strict";function c(){if(!e){e=!0;var a,c,d,f,g=-1!==navigator.appVersion.indexOf("MSIE 10"),h=!!navigator.userAgent.match(/Trident.*rv:11\./),i=b.querySelectorAll("iframe.wp-embedded-content");for(c=0;c<i.length;c++)if(d=i[c],!d.getAttribute("data-secret")){if(f=Math.random().toString(36).substr(2,10),d.src+="#?secret="+f,d.setAttribute("data-secret",f),g||h)a=d.cloneNode(!0),a.removeAttribute("security"),d.parentNode.replaceChild(a,d)}else;}}var d=!1,e=!1;if(b.querySelector)if(a.addEventListener)d=!0;if(a.wp=a.wp||{},!a.wp.receiveEmbedMessage)if(a.wp.receiveEmbedMessage=function(c){var d=c.data;if(d.secret||d.message||d.value)if(!/[^a-zA-Z0-9]/.test(d.secret)){var e,f,g,h,i,j=b.querySelectorAll('iframe[data-secret="'+d.secret+'"]'),k=b.querySelectorAll('blockquote[data-secret="'+d.secret+'"]');for(e=0;e<k.length;e++)k[e].style.display="none";for(e=0;e<j.length;e++)if(f=j[e],c.source===f.contentWindow){if(f.removeAttribute("style"),"height"===d.message){if(g=parseInt(d.value,10),g>1e3)g=1e3;else if(200>~~g)g=200;f.height=g}if("link"===d.message)if(h=b.createElement("a"),i=b.createElement("a"),h.href=f.getAttribute("src"),i.href=d.value,i.host===h.host)if(b.activeElement===f)a.top.location.href=d.value}else;}},d)a.addEventListener("message",a.wp.receiveEmbedMessage,!1),b.addEventListener("DOMContentLoaded",c,!1),a.addEventListener("load",c,!1)}(window,document);</script>
		<script>try {
			SmashingAds.loadAds();
		} catch ( e ) {
		}</script>

		<script>try {
			SmashingAds.render( OA_output );
		} catch ( e ) {
		}</script>

	<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"86b694293f","applicationID":"11250242","transactionName":"NgMAbEZVV0cAWxZYXg9JI1tAXVZaTksLX1YNAw==","queueTime":0,"applicationTime":245,"atts":"GkQDGg5PREk=","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>
