<!DOCTYPE html>
<html lang="en-US">
<head>
	<title>The Missing Advice I Needed When Starting My Career &ndash; Smashing Magazine</title>
	<meta charset="UTF-8" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,n,t){function r(t){if(!n[t]){var o=n[t]={exports:{}};e[t][0].call(o.exports,function(n){var o=e[t][1][n];return r(o||n)},o,o.exports)}return n[t].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<t.length;o++)r(t[o]);return r}({1:[function(e,n,t){function r(){}function o(e,n,t){return function(){return i(e,[c.now()].concat(u(arguments)),n?null:this,t),n?void 0:this}}var i=e("handle"),a=e(2),u=e(3),f=e("ee").get("tracer"),c=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,n){s[n]=o(d+n,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),n.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,n){var t={},r=this,o="function"==typeof n;return i(l+"tracer",[c.now(),e,t],r),function(){if(f.emit((o?"":"no-")+"fn-start",[c.now(),r,o],t),o)try{return n.apply(this,arguments)}finally{f.emit("fn-end",[c.now()],t)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,n){m[n]=o(l+n)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,c.now()])}},{}],2:[function(e,n,t){function r(e,n){var t=[],r="",i=0;for(r in e)o.call(e,r)&&(t[i]=n(r,e[r]),i+=1);return t}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],3:[function(e,n,t){function r(e,n,t){n||(n=0),"undefined"==typeof t&&(t=e?e.length:0);for(var r=-1,o=t-n||0,i=Array(o<0?0:o);++r<o;)i[r]=e[n+r];return i}n.exports=r},{}],4:[function(e,n,t){n.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,n,t){function r(){}function o(e){function n(e){return e&&e instanceof r?e:e?f(e,u,i):i()}function t(t,r,o,i){if(!d.aborted||i){e&&e(t,r,o);for(var a=n(o),u=m(t),f=u.length,c=0;c<f;c++)u[c].apply(a,r);var p=s[y[t]];return p&&p.push([b,t,r,a]),a}}function l(e,n){v[e]=m(e).concat(n)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(t)}function g(e,n){c(e,function(e,t){n=n||"feature",y[t]=n,n in s||(s[n]=[])})}var v={},y={},b={on:l,emit:t,get:w,listeners:m,context:n,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",f=e("gos"),c=e(2),s={},p={},d=n.exports=o();d.backlog=s},{}],gos:[function(e,n,t){function r(e,n,t){if(o.call(e,n))return e[n];var r=t();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,n,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[n]=r,r}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],handle:[function(e,n,t){function r(e,n,t,r){o.buffer([e],r),o.emit(e,n,t)}var o=e("ee").get("handle");n.exports=r,r.ee=o},{}],id:[function(e,n,t){function r(e){var n=typeof e;return!e||"object"!==n&&"function"!==n?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");n.exports=r},{}],loader:[function(e,n,t){function r(){if(!x++){var e=h.info=NREUM.info,n=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&n))return s.abort();c(y,function(n,t){e[n]||(e[n]=t)}),f("mark",["onload",a()+h.offset],null,"api");var t=d.createElement("script");t.src="https://"+e.agent,n.parentNode.insertBefore(t,n)}}function o(){"complete"===d.readyState&&i()}function i(){f("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),f=e("handle"),c=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1039.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=n.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),f("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>
	<link rel="dns-prefetch" href="https://media-mediatemple.netdna-ssl.com/" />
	<link rel="dns-prefetch" href="https://auslieferung.commindo-media-resourcen.de/" />
	<link rel="preconnect" href="https://media-mediatemple.netdna-ssl.com" />
	<link rel="preconnect" href="https://auslieferung.commindo-media-resourcen.de/" />
	<style id="smash-above-the-fold-css">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</style><script>!function(e){"use strict";function t(e,t,n){e.addEventListener?e.addEventListener(t,n,!1):e.attachEvent&&e.attachEvent("on"+t,n)}function n(t,n){return e.localStorage&&localStorage[t+"_content"]&&localStorage[t+"_file"]===n}function o(t,o){if(e.localStorage&&e.XMLHttpRequest)n(t,o)?r(localStorage[t+"_content"]):a(t,o);else{var i=l.createElement("link");i.href=o,i.id=t,i.rel="stylesheet",i.type="text/css",l.getElementsByTagName("head")[0].appendChild(i),l.cookie=t}}function a(e,t){var n=new XMLHttpRequest;n.open("GET",t,!0),n.onreadystatechange=function(){4===n.readyState&&200===n.status&&(r(n.responseText),localStorage[e+"_content"]=n.responseText,localStorage[e+"_file"]=t)},n.send()}function r(e){var t=l.createElement("style");t.setAttribute("type","text/css"),l.getElementsByTagName("head")[0].appendChild(t),t.styleSheet?t.styleSheet.cssText=e:t.innerHTML=e}var l=e.document,i=function(e,t,n){function o(e){return l.body?e():void setTimeout(function(){o(e)})}function a(){i.addEventListener&&i.removeEventListener("load",a),i.media=n||"all"}var r,i=l.createElement("link");if(t)r=t;else{var s=(l.body||l.getElementsByTagName("head")[0]).childNodes;r=s[s.length-1]}var c=l.styleSheets;i.rel="stylesheet",i.href=e,i.media="only x",o(function(){r.parentNode.insertBefore(i,t?r:r.nextSibling)});var d=function(e){for(var t=i.href,n=c.length;n--;)if(c[n].href===t)return e();setTimeout(function(){d(e)})};return i.addEventListener&&i.addEventListener("load",a),i.onloadcssdefined=d,d(a),i};"undefined"!=typeof exports?exports.loadCSS=i:e.loadCSS=i,e.loadLocalStorageCSS=function(a,r){n(a,r)||l.cookie.indexOf(a)>-1?o(a,r):t(e,"load",function(){o(a,r)})}}(this);</script>
<link rel="preload" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/main.min.css?ver=6.4.13" as="style" onload="this.rel='stylesheet'" /><noscript><link rel='stylesheet' id='smash-main-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/main.min.css?ver=6.4.13' type='text/css' media='all' />
</noscript><link rel="preload" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/articles-only.min.css?ver=6.4.13" as="style" onload="this.rel='stylesheet'" /><noscript><link rel='stylesheet' id='smash-article-only-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/articles-only.min.css?ver=6.4.13' type='text/css' media='all' />
</noscript><script id="loadcss__smash-below-articles">loadCSS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/below-articles.min.css?ver=6.4.13", false, "all" );</script><noscript><link rel='stylesheet' id='smash-below-articles-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/below-articles.min.css?ver=6.4.13' type='text/css' media='all' />
</noscript><script id="loadcss__smash-comments">loadCSS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/comments.min.css?ver=6.4.13", false, "all" );</script><noscript><link rel='stylesheet' id='smash-comments-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/comments.min.css?ver=6.4.13' type='text/css' media='all' />
</noscript><link rel='stylesheet' id='smash-print-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/print.min.css?ver=6.4.13' type='text/css' media='print' />
<script id="loadcss__smash-webfonts">loadLocalStorageCSS( "smash-webfonts", "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/webfonts.min.css?ver=6.4.13" );</script><!--[if IE 8]>
<link rel='stylesheet' id='smash-ie8-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/ie8-nu.min.css?ver=6.4.13' type='text/css' media='all' />
<![endif]-->

<!-- This site is optimized with the Yoast SEO Premium plugin v4.6 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Paul Boag shares lessons learned from working in the web industry for over 20 years. The missing advice you might need when starting out."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://www.smashingmagazine.com/2017/07/missing-advice-when-starting-career/" />
<link rel="publisher" href="https://plus.google.com/+SmashingMagazine‎"/>
<meta property="DC.date.issued" content="2017-07-25T07:00:17+02:00" />
<!-- / Yoast SEO Premium plugin. -->

<link rel="alternate" type="application/rss+xml" title="Smashing Magazine &raquo; Feed" href="https://www.smashingmagazine.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Smashing Magazine &raquo; Comments Feed" href="https://www.smashingmagazine.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Smashing Magazine &raquo; The Missing Advice I Needed When Starting My Career Comments Feed" href="https://www.smashingmagazine.com/2017/07/missing-advice-when-starting-career/feed/" />

<script type='text/javascript'>
/* <![CDATA[ */
var SmashingServiceWorkerData = {"url":"https:\/\/www.smashingmagazine.com\/serviceWorker.js"};
/* ]]> */
</script>
<script>
var SmashingServiceWorkerData=SmashingServiceWorkerData||{url:""};(function(a,b){if(b.url&&"serviceWorker" in a){a.serviceWorker.register(b.url);window.addEventListener("load",function(){if(a.serviceWorker.controller){a.serviceWorker.controller.postMessage({command:"trimCaches"})}})}})(navigator,SmashingServiceWorkerData);
</script>
<!--[if IE 8]>
<script type='text/javascript' src='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/html5shiv.min.js?ver=6.4.13'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://www.smashingmagazine.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.smashingmagazine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.smashingmagazine.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.smashingmagazine.com/?p=295176' />
<link rel="alternate" type="application/json+oembed" href="https://www.smashingmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.smashingmagazine.com%2F2017%2F07%2Fmissing-advice-when-starting-career%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.smashingmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.smashingmagazine.com%2F2017%2F07%2Fmissing-advice-when-starting-career%2F&#038;format=xml" />
<!-- Stream WordPress user activity plugin v3.0.7 -->
<link rel="manifest" href="/manifest.json">	<script>
	dataLayer = [
		{
			'site': {"ID":"1","name":"Smashing Magazine","home":"https:\/\/www.smashingmagazine.com"},
			'user': {"isLoggedIn":false,"ID":0,"role":"visitor"}		}
	];
</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
		new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
		j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
		'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-NWC9FPF');
</script>

	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="mask-icon" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/s.svg" color="#e53b2c" sizes="any" />
<!--[if IE]><link href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/favicon.ico" rel="icon" /><![endif]-->
<link rel="icon" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/favicon.png" />
<meta name="application-name" content="Smashing Magazine" />
<meta name="msapplication-TileColor" content="#fff" />
<meta name="msapplication-square70x70logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-70-70.png" />
<meta name="msapplication-square150x150logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-150-150.png" />
<meta name="msapplication-wide310x150logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-310-150.png" />
<meta name="msapplication-square310x310logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-310-310.png" />
<meta name="msapplication-notification" content="frequency=30;polling-uri1=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=1;polling-uri2=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=2;polling-uri3=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=3;polling-uri4=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=4;cycle=1" />
<link rel="apple-touch-icon-precomposed" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-57x57-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-72x72-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-114x114-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-144x144-precomposed.png" />
</head>
<body id="top" class="single single-post postid-295176 single-format-standard www-section">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NWC9FPF" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div class="mnb">
	<a href="#mn" class="ntb js-toggle-btn" title="Jump to the main navigation">
		Menu	</a>
	<a href="#ms" class="stb js-toggle-btn" title="Jump to the search">
		Search    </a>
</div><a class="sr" href="#content">Jump to the content</a>
<header class="h" role="banner">
	<h1 class="logo">
		<span class="sr">Smashing Magazine</span>
		<a href="https://www.smashingmagazine.com/"><img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/logo.png" alt="Smashing Magazine Logo" srcset="https://media-mediatemple.netdna-ssl.com/wp-content/themes/smashing-magazine/assets/images/logo.svg" /></a>
	</h1>
</header>
<nav class="mn" id="mn" role="navigation menu">
	<h2>Smashing Pages:</h2>
	 <ul id="menu-smashing-mobile-network" class="mnu"><li id="menu-item-218248" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218248 menu-item-books"><a href="https://www.smashingmagazine.com/books/">Books</a></li>
<li id="menu-item-218249" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218249 menu-item-tickets"><a href="https://www.smashingmagazine.com/workshops/">Tickets</a></li>
<li id="menu-item-219109" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219109 menu-item-shop"><a href="https://shop.smashingmagazine.com/">Shop</a></li>
<li id="menu-item-188959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188959 menu-item-email-newsletter"><a href="https://www.smashingmagazine.com/the-smashing-newsletter/">Email Newsletter</a></li>
<li id="menu-item-188961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-188961 menu-item-jobs"><a href="http://jobs.smashingmagazine.com">Jobs</a></li>
<li id="menu-item-188958" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188958 menu-item-about-us-impressum"><a href="https://www.smashingmagazine.com/about/">About us / Impressum</a></li>
</ul>	<h2>Categories:</h2>
	 <ul id="menu-mobile-categories" class="mnu"><li id="menu-item-181575" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181575 menu-item-coding"><a href="https://www.smashingmagazine.com/category/coding/">Coding</a></li>
<li id="menu-item-181576" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181576 menu-item-design"><a href="https://www.smashingmagazine.com/category/design/">Design</a></li>
<li id="menu-item-181580" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181580 menu-item-mobile"><a href="https://www.smashingmagazine.com/category/mobile/">Mobile</a></li>
<li id="menu-item-181579" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181579 menu-item-graphics"><a href="https://www.smashingmagazine.com/category/graphics/">Graphics</a></li>
<li id="menu-item-181577" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-181577 menu-item-ux-design"><a href="https://www.smashingmagazine.com/category/uxdesign/">UX Design</a></li>
<li id="menu-item-181578" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181578 menu-item-wordpress"><a href="https://www.smashingmagazine.com/category/wordpress/"><span class="long"><span>Word</span><span>Press</span></span><span class="short">WP</span></a></li>
</ul></nav>
<a class="mnc js-toggle-btn" href="#top" data-toggle-target="mn" title="Close the navigation">X</a><div class="ms" id="ms" role="search">
  <form id="mobile-searching" class="sfm clearfix" method="get" action="https://www.smashingmagazine.com/search-results/" target="_top">
    <label for="mobile-search-input">Search on Smashing Magazine</label>
    <input name="q" id="mobile-search-input" type="text" placeholder="e.g. CSS" />
    <button class="submit" type="submit">Search</button>
    <input type="hidden" name="cx" value="partner-pub-6779860845561969:5884617103">
    <input type="hidden" name="cof" value="FORID:10">
    <input type="hidden" name="ie" value="UTF-8">
  </form>
</div>
<a role="button" class="msc js-toggle-btn" href="#top" data-toggle-target="ms" title="Close the search">X</a>
<nav class="tn clearfix" role="navigation">
	 <ul id="menu-network-menu" class="nw clearfix"><li class="current"><a href="https://www.smashingmagazine.com"><img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/logo.png" alt="Smashing Magazine" srcset="https://media-mediatemple.netdna-ssl.com/wp-content/themes/smashing-magazine/assets/images/logo.svg"  /></a></li><li id="menu-item-218245" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218245 menu-item-books"><a href="https://www.smashingmagazine.com/books/">Books</a></li>
<li id="menu-item-231721" class="cody menu-item menu-item-type-custom menu-item-object-custom menu-item-231721 menu-item-ebooks"><a href="https://shop.smashingmagazine.com/products/the-smashing-library">eBooks</a></li>
<li id="menu-item-218696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218696 menu-item-tickets"><a href="https://www.smashingmagazine.com/smashing-workshops/">Tickets</a></li>
<li id="menu-item-231722" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-231722 menu-item-shop"><a href="https://shop.smashingmagazine.com/">Shop</a></li>
<li id="menu-item-2" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2 menu-item-jobs"><a href="http://jobs.smashingmagazine.com/">Jobs</a></li>
</ul><nav id="social-media-nav" role="menu">
  <ul class="ch">
  	<li class="rss">
	    <a href="https://www.smashingmagazine.com/feed/" title="Subscribe to our RSS-feed (120K)">RSS</a>
    </li>
  	<li class="fb">
	    <a href="//www.facebook.com/smashmag" title="Join our Facebook page! (267k)">Facebook</a>
    </li>
  	<li class="tw">
	    <a href="//twitter.com/smashingmag" title="Follow us on Twitter! (956k)">Twitter</a>
    </li>
  	<li class="nl">
	    <a href="https://www.smashingmagazine.com/the-smashing-newsletter/" title="Subscribe to our Email Newsletter (180k)">Newsletter</a>
    </li>
  </ul>
</nav>
</nav>
<main>
	<div class="cc">
		<div class="fluid clearfix">
			<div class="grid clearfix">
				<section class="mise sf clearfix" role="search">
	<form id="search_1" method="get" action="https://www.smashingmagazine.com/search-results/" target="_top">
    <label class="sl" for="searching_1">Search on Smashing Magazine</label>
		<input id="searching_1" name="q" type="text" placeholder="e.g. JavaScript" />
		<button class="search_submit" type="submit">Search</button>
		<input type="hidden" name="cx" value="partner-pub-6779860845561969:5884617103">
		<input type="hidden" name="cof" value="FORID:10">
		<input type="hidden" name="ie" value="UTF-8">
	</form>
</section>
				<div class="col sn">
					<div class="sct"><ul id="menu-category-menu" class="clearfix"><li id="menu-item-116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-116 menu-item-coding"><a href="https://www.smashingmagazine.com/category/coding/">Coding</a>
<ul class="sub-menu">
	<li id="menu-item-2014" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2014 menu-item-css"><a href="https://www.smashingmagazine.com/tag/css/">CSS</a></li>
	<li id="menu-item-134810" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-134810 menu-item-html"><a href="https://www.smashingmagazine.com/tag/html/">HTML</a></li>
	<li id="menu-item-2015" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2015 menu-item-javascript"><a href="https://www.smashingmagazine.com/tag/javascript/">JavaScript</a></li>
	<li id="menu-item-2016" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2016 menu-item-techniques"><a href="https://www.smashingmagazine.com/tag/techniques/">Techniques</a></li>
</ul>
</li>
<li id="menu-item-117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-117 menu-item-design"><a href="https://www.smashingmagazine.com/category/design/">Design</a>
<ul class="sub-menu">
	<li id="menu-item-2017" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2017 menu-item-web-design"><a href="https://www.smashingmagazine.com/tag/web-design/">Web Design</a></li>
	<li id="menu-item-231166" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-231166 menu-item-responsive"><a title="Responsive Web Design" href="https://www.smashingmagazine.com/tag/responsive-web-design/">Responsive</a></li>
	<li id="menu-item-2032" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2032 menu-item-typography"><a href="https://www.smashingmagazine.com/tag/typography/">Typography</a></li>
	<li id="menu-item-2063" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2063 menu-item-inspiration"><a href="https://www.smashingmagazine.com/tag/inspiration/">Inspiration</a></li>
</ul>
</li>
<li id="menu-item-119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-119 menu-item-mobile"><a href="https://www.smashingmagazine.com/category/mobile/">Mobile</a>
<ul class="sub-menu">
	<li id="menu-item-142132" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-142132 menu-item-iphone-ipad"><a href="https://www.smashingmagazine.com/tag/ios/">iPhone &#038; iPad</a></li>
	<li id="menu-item-143596" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143596 menu-item-android"><a href="https://www.smashingmagazine.com/tag/android/">Android</a></li>
	<li id="menu-item-143608" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143608 menu-item-design-patterns"><a href="https://www.smashingmagazine.com/tag/design-patterns/">Design Patterns</a></li>
</ul>
</li>
<li id="menu-item-118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-118 menu-item-graphics"><a href="https://www.smashingmagazine.com/category/graphics/">Graphics</a>
<ul class="sub-menu">
	<li id="menu-item-2264" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2264 menu-item-photoshop"><a href="https://www.smashingmagazine.com/tag/photoshop/">Photoshop</a></li>
	<li id="menu-item-160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-160 menu-item-fireworks"><a href="https://www.smashingmagazine.com/category/fireworks/">Fireworks</a></li>
	<li id="menu-item-2283" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2283 menu-item-wallpapers"><a href="https://www.smashingmagazine.com/tag/wallpapers/">Wallpapers</a></li>
	<li id="menu-item-2305" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2305 menu-item-freebies"><a href="https://www.smashingmagazine.com/tag/freebies/">Freebies</a></li>
</ul>
</li>
<li id="menu-item-120" class="menu-item-uxdesign menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-120 menu-item-ux-design"><a href="https://www.smashingmagazine.com/category/uxdesign/">UX Design</a>
<ul class="sub-menu">
	<li id="menu-item-143609" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143609 menu-item-usability"><a href="https://www.smashingmagazine.com/tag/usability/">Usability</a></li>
	<li id="menu-item-143610" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143610 menu-item-user-experience"><a href="https://www.smashingmagazine.com/tag/user-experience/">User Experience</a></li>
	<li id="menu-item-143611" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143611 menu-item-ui-design"><a href="https://www.smashingmagazine.com/tag/ui/">UI Design</a></li>
	<li id="menu-item-143612" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143612 menu-item-e-commerce"><a href="https://www.smashingmagazine.com/tag/e-commerce/">E-Commerce</a></li>
</ul>
</li>
<li id="menu-item-121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-121 menu-item-wordpress"><a href="https://www.smashingmagazine.com/category/wordpress/"><span class="long"><span>Word</span><span>Press</span></span><span class="short">WP</span></a>
<ul class="sub-menu">
	<li id="menu-item-143677" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143677 menu-item-essentials"><a href="https://www.smashingmagazine.com/tag/essentials/">Essentials</a></li>
	<li id="menu-item-143678" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143678 menu-item-techniques"><a href="https://www.smashingmagazine.com/tag/techniques-wp/">Techniques</a></li>
	<li id="menu-item-143679" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143679 menu-item-plugins"><a href="https://www.smashingmagazine.com/tag/plugins/">Plugins</a></li>
	<li id="menu-item-143680" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143680 menu-item-themes"><a href="https://www.smashingmagazine.com/tag/themes/">Themes</a></li>
</ul>
</li>
</ul></div>				</div>
				<div id="content" class="col main">
					<div id="blocked" class="blocked clearfix">
	<figure style="max-width: 24%;min-width: 90px;">
		<a href="https://smashingconf.com/barcelona-2017">
			<img
				src="https://www.smashingmagazine.com/wp-content/uploads/2017/06/smashingconf-barcelona-round-v2.png"
				alt="Smashing Conf Barcelona">
		</a>
	</figure>
	<p style="font-size: calc(1em + ((0.4vw + 0.25vh) / 2));">
		<strong>You know, we use ad-blockers as well.</strong> We gotta keep those servers running though.
		Did you know that we publish <a href="https://www.smashingmagazine.com/books/">useful books</a> and run
		<a href="https://www.smashingmagazine.com/smashing-workshops/">friendly conferences</a> — crafted for pros like
		yourself? E.g. our upcoming <a href="https://smashingconf.com/barcelona-2017">SmashingConf Barcelona</a>,
		dedicated to smart front-end techniques and design patterns.
	</p>
</div><article class="post-295176 post type-post status-publish format-standard has-post-thumbnail hentry category-uxdesign tag-career tag-tools" vocab="http://schema.org/" typeof="TechArticle">

		<h2>
		<a property="url" href="https://www.smashingmagazine.com/2017/07/missing-advice-when-starting-career/" rel="bookmark" title="Read 'The Missing Advice I Needed When Starting My Career'"><span property="name">The Missing Advice I Needed When Starting My Career</span></a>
	</h2>

			
<ul class="pmd clearfix">
	<li class="a" property="author" typeof="person" resource="#authorname">By <a href="https://www.smashingmagazine.com/author/paul-boag/" title="Posts by Paul Boag" rel="author">Paul Boag</a></li>
				<li class="rd" property="datePublished" content="July 25th, 2017">July 25th, 2017</li>
				<li class="tags" property="keywords"><a href="https://www.smashingmagazine.com/tag/career/">Career</a><a href="https://www.smashingmagazine.com/tag/tools/">Tools</a></li>
		<li class="comments" property="discussionUrl"><a href="#comments" title="Comment on The Missing Advice I Needed When Starting My Career">1 Comment</a> </li>
		</ul>
	
	<div class="ad ed">
	<div class="oa_zone--ad cad" id="cad" data-ad-name="Medium Rectangle" data-ad-zone="22" data-ad-media="all"></div>
</div>

	<p>Do you ever wish you had a time machine? I certainly do, but not for the usual reasons. I want a time machine so I can go back and have a frank conversation with my younger self. I&#8217;ll let you in on a bit of a secret: <strong>My younger self was an idiot!</strong></p>
<p>I have been working on the web for over 22 years now, and I feel like I wasted so many of those years. If only I could go back and share a few hard truths with myself at the start of my career. Unfortunately, I cannot, but I can share that advice with you.</p>
<p>Admittedly, you are almost certainly not as idiotic as I was. But hopefully, there will be something in this advice that inspires you.</p>
<p>Speaking of inspiration, that leads me nicely into my first piece of wisdom!</p>
<h3  id="look-beyond-the-web-for-inspiration">Look Beyond The Web For Inspiration <a href="#look-beyond-the-web-for-inspiration" aria-label="Link to section 'Look Beyond The Web For Inspiration'" class="sr hsl">Link</a></h3>
<p>I used to be a dedicated follower of fashion who wasted so much time looking at other “cool” websites and browsing galleries of inspirational websites. My design style would morph to embrace the latest trends, from Web 2.0 to hero banners.</p>
<p>The result of this was bland “me too” design. But worst of all, it never put the user first. It was all about making something look good in my portfolio.</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2017/06/01-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/06/01-The-Missing-Advice-I-Needed-When-Starting-My-Career-800w-opt.jpg" width="800" height="630" alt="Look for inspiration beyond the web. Look to art, architecture and print design." /></a><sup class="po" id="note-1"><a href="#1">1</a></sup><br />
<figcaption>Look for inspiration beyond the web. Look to art, architecture and print design. (<a href="https://www.smashingmagazine.com/wp-content/uploads/2017/06/01-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg">View large version</a><sup class="po" id="note-2"><a href="#2">2</a></sup>)<br />
</figcaption>
</figure>
<p>It was such a <strong>waste</strong> because so much inspiration is all around us: great books on classic print design, architectural trends, even airport signage (a personal obsession of mine).</p>
<p>Don’t make my mistakes. You don’t even have the luxury of my excuses. With <a href="https://www.smashingmagazine.com/2016/11/css-grids-flexbox-and-box-alignment-our-new-system-for-web-layout/">CSS grid</a><sup class="po" id="note-3"><a href="#3">3</a></sup>, the possibilities are endless, and we should all embrace them.</p>
<p>On the subject of latest trends, that brings me to my next transgression: obsessing over tools.</p>
<h3  id="stop-obsessing-over-tools">Stop Obsessing Over Tools <a href="#stop-obsessing-over-tools" aria-label="Link to section 'Stop Obsessing Over Tools'" class="sr hsl">Link</a></h3>
<p>We’ve wasted hours arguing over what tool is best. Should we code in PHP or classic ASP? (Yes, I am that old.) Can I be a “proper” web designer and code in Dreamweaver? Which content management systems should we use? The list went on.</p>
<p>Some tool or other would become trendy for whatever reason, and we would all jump on the bandwagon, until the next one emerged, and we jumped to that after an even more furious debate.</p>
<p>I see the same today: arguments over <a href="https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/">frameworks</a><sup class="po" id="note-4"><a href="#4">4</a></sup> and whether we should embrace Angular or React. <strong>I don’t follow these discussions anymore</strong> because somewhere along the line I realized something: There is no single answer.</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2017/06/02-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/06/02-The-Missing-Advice-I-Needed-When-Starting-My-Career-800w-opt.jpg" width="800" height="630" alt="Do not become overly attached to a single tool. Tools come and go, and no one will be appropriate for every project." /></a><sup class="po" id="note-5"><a href="#5">5</a></sup><br />
<figcaption>Do not become overly attached to a single tool. Tools come and go, and no one will be appropriate for every project. (<a href="https://www.smashingmagazine.com/wp-content/uploads/2017/06/02-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg">View large version</a><sup class="po" id="note-6"><a href="#6">6</a></sup>)<br />
</figcaption>
</figure>
<p>A lot of these choices come down to personal preference or the requirements of the individual client. <strong>Remain flexible and open to change</strong>. If you don’t, you’ll go the way of ColdFusion and Flash developers. Annoyingly, I’ll bet that many of you reading this are too young even to remember ColdFusion! I am so old.</p>
<p>All of that time I wasted arguing about tools would have been so much better spent elsewhere, like on improving my soft skills.</p>
<h3  id="get-better-at-working-with-others">Get Better At Working With Others <a href="#get-better-at-working-with-others" aria-label="Link to section 'Get Better At Working With Others'" class="sr hsl">Link</a></h3>
<p>I was an insufferable <em>know-it-all</em> when I was young. I always had the answers and always knew a better way to do something. I am sure you are not like that, although, let’s be honest, how would you know if you were? I certainly had no idea how irritating I was, despite the warning signs.</p>
<p>For a start, I found myself <strong>constantly arguing with everybody</strong>. Everything seemed like a battle because nobody around me “got it.” In hindsight, that was because I was too busy irritating everybody to take the time to explain things properly. But at the time, it just felt like everybody else was stupid.</p>
<p>I wish I had realized how weak I was in this area. Perhaps then I would have invested time and energy in improving how I worked alongside other people. Maybe I would have listened more and put the same effort into understanding my colleagues as I did my users.</p>
<p>I am not suggesting I should have done this necessarily to be a good man (trust me, I am not now). Instead, I should have done this because it would have made my life so much easier. <strong>I wasted endless time arguing and alienating people</strong>, people I needed on my side to do my job. It was incredibly frustrating.</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2017/06/03-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/06/03-The-Missing-Advice-I-Needed-When-Starting-My-Career-800w-opt.jpg" width="800" height="630" alt="We spend a lot of time debating whether designers should learn to code, when perhaps we should be worrying about other skills." /></a><sup class="po" id="note-7"><a href="#7">7</a></sup><br />
<figcaption>We spend a lot of time debating whether designers should learn to code, when perhaps we should be worrying about other skills. (<a href="https://www.smashingmagazine.com/wp-content/uploads/2017/06/03-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg">View large version</a><sup class="po" id="note-8"><a href="#8">8</a></sup>)<br />
</figcaption>
</figure>
<p>If I had developed that skill of working with people earlier, it would have also allowed me to push beyond the confines of my role.</p>
<h3  id="always-push-beyond-your-job-description">Always Push Beyond Your Job Description <a href="#always-push-beyond-your-job-description" aria-label="Link to section 'Always Push Beyond Your Job Description'" class="sr hsl">Link</a></h3>
<p>I confess that, for many years, I was a bit of a job’s worth. I was a designer, and I spent much of my working life complaining because other people weren’t doing their jobs properly. Clients failed to deliver copy, developers didn’t implement my designs correctly, and project managers were always putting unrealistic constraints on me.</p>
<p>To be fair to my younger self, these were all real problems. But I did nothing but moan about them. I made no effort to help my colleagues fix these issues. I never questioned why the client was failing to deliver content or why the project manager seemed so unreasonable? I didn’t bother to understand the constraints they faced.</p>
<p>When I did eventually wake up and start paying attention, I discovered a bigger world. I found out just how interconnected digital and the user experience are, and how many things beyond the screen influence the experience.</p>
<p>I learned so much over that time, and you can, too. Take the time to <strong>understand the roles of those around you</strong>. Understand their challenges and constraints. Understand their perspectives and motivations. This will not only improve your working relationship, but make you better at your job, too. </p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2017/06/Empathy-map-large-opt.jpg"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/06/Empathy-map-800w-opt-1.jpg" width="800" height="450" alt="Seek to understand colleagues just as you would a user. You could even consider creating empathy maps for them!" /></a><sup class="po" id="note-9"><a href="#9">9</a></sup><br />
<figcaption>Seek to understand colleagues just as you would a user. You could even consider creating empathy maps for them! (<a href="https://www.smashingmagazine.com/wp-content/uploads/2017/06/Empathy-map-large-opt.jpg">View large version</a><sup class="po" id="note-10"><a href="#10">10</a></sup>)<br />
</figcaption>
</figure>
<p>If you are a designer, this will enhance your designs, making them more useful in the “real world.” If you are a developer, you will understand the challenges users face and the impact you have on the user experience. And so it goes on.</p>
<p>Ultimately, this will make you better at your job and hopefully progress your career. But a successful career is about more than being good at your job.</p>
<h3  id="commit-to-putting-yourself-out-there">Commit To Putting Yourself Out There <a href="#commit-to-putting-yourself-out-there" aria-label="Link to section 'Commit To Putting Yourself Out There'" class="sr hsl">Link</a></h3>
<p>You could be the best designer or developer in the world, but if nobody has heard of you, you will have little success. That probably isn’t right or fair, but that is the reality.</p>
<p>I’ll be honest with you: Many people are far better at their jobs than me. But I speak all around the world, write books and have built a significant following, not because I am good at what I do, but because I put myself out there.</p>
<p>But it took me so long to realize that. I wasted years moaning about how it was unfair that other people got to write and speak and how my ideas were just as good as theirs.</p>
<p>Eventually, it twigged that I didn’t need anybody’s permission to start sharing my thoughts. I could write on a blog without a publisher and speak on a podcast without a conference.</p>
<p>You can, too. Not only that, you should! If you are not sharing what you have learned, you are invisible, and that will <a href="https://www.invisionapp.com/blog/designers-should-write/">hamper your career</a><sup class="po" id="note-11"><a href="#11">11</a></sup>.</p>
<figure><a href="https://www.smashingmagazine.com/wp-content/uploads/2017/06/04-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/06/04-The-Missing-Advice-I-Needed-When-Starting-My-Career-800w-opt.jpg" width="800" height="805" alt="You don&#039;t need to be invited to speak at a conference to start sharing your ideas." /></a><sup class="po" id="note-12"><a href="#12">12</a></sup><br />
<figcaption>You don&#8217;t need to be invited to speak at a conference to start sharing your ideas.<br />
 (<a href="https://www.smashingmagazine.com/wp-content/uploads/2017/06/04-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg">View large version</a><sup class="po" id="note-13"><a href="#13">13</a></sup>)<br />
</figcaption>
</figure>
<p>You might feel you have nothing new to say. Don’t worry, just share what you have learned. There will always be people who haven’t learned those lessons yet.</p>
<p>You might feel nobody is listening. Again, don’t worry. If you persevere, eventually people will start paying attention. I’ll let you in on a secret: Quality is not the number one reason for success. Consistency is. Even second-rate content will draw attention if you <strong>release it regularly enough</strong>.</p>
<p>Put yourself out there, in whatever way you choose. It will enable you to build contacts in the industry. That will help you avoid the last mistake my younger self-made: wasting too many years working for appalling bosses.</p>
<h3  id="dont-put-up-with-a-terrible-boss">Don’t Put Up With A Terrible Boss <a href="#dont-put-up-with-a-terrible-boss" aria-label="Link to section 'Don’t Put Up With A Terrible Boss'" class="sr hsl">Link</a></h3>
<p>I worked for some truly nasty people, ranging from the incompetent to the criminal. Two ended up in prison, and the only good guy I ever worked for died of a heart attack due to stress!</p>
<p>I wasted years working for these people, years of them undervaluing my work and failing to invest in enabling me to do it better. Admittedly, I could be a bit of an idiot, as we have already established. But even with hindsight, these people were terrible. Unfortunately, <strong>apathy and fear prevented me from moving on</strong>.</p>
<p>Don’t make my mistake. There is no need. <strong>We are much in demand</strong>. Getting good digital staff is incredibly challenging, and you owe no loyalty to a boss who doesn’t value your expertise.</p>
<p>Instead, find a company that is going to nurture you and help you grow in your career. I’ll be honest: I never achieved that. I never had a mentor or somebody to teach me. I stumbled my way through my career, and I think I am the poorer for it. So, don’t settle. You deserve better, and loads of great jobs are out there.</p>
<p><em>(al)</em></p>
<h4  class="po" id="footnotes">Footnotes <a href="#footnotes" aria-label="Link to section 'Footnotes'" class="sr hsl">Link</a></h4><ol class="po"><li id="#1"><a href="#note-1">1 https://www.smashingmagazine.com/wp-content/uploads/2017/06/01-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg</a></li><li id="#2"><a href="#note-2">2 https://www.smashingmagazine.com/wp-content/uploads/2017/06/01-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg</a></li><li id="#3"><a href="#note-3">3 https://www.smashingmagazine.com/2016/11/css-grids-flexbox-and-box-alignment-our-new-system-for-web-layout/</a></li><li id="#4"><a href="#note-4">4 https://www.smashingmagazine.com/2017/03/which-responsive-design-framework-is-best/</a></li><li id="#5"><a href="#note-5">5 https://www.smashingmagazine.com/wp-content/uploads/2017/06/02-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg</a></li><li id="#6"><a href="#note-6">6 https://www.smashingmagazine.com/wp-content/uploads/2017/06/02-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg</a></li><li id="#7"><a href="#note-7">7 https://www.smashingmagazine.com/wp-content/uploads/2017/06/03-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg</a></li><li id="#8"><a href="#note-8">8 https://www.smashingmagazine.com/wp-content/uploads/2017/06/03-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg</a></li><li id="#9"><a href="#note-9">9 https://www.smashingmagazine.com/wp-content/uploads/2017/06/Empathy-map-large-opt.jpg</a></li><li id="#10"><a href="#note-10">10 https://www.smashingmagazine.com/wp-content/uploads/2017/06/Empathy-map-large-opt.jpg</a></li><li id="#11"><a href="#note-11">11 https://www.invisionapp.com/blog/designers-should-write/</a></li><li id="#12"><a href="#note-12">12 https://www.smashingmagazine.com/wp-content/uploads/2017/06/04-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg</a></li><li id="#13"><a href="#note-13">13 https://www.smashingmagazine.com/wp-content/uploads/2017/06/04-The-Missing-Advice-I-Needed-When-Starting-My-Career-large-opt.jpg</a></li></ol>
	
	
	<div class="lt"><a href="https://www.smashingmagazine.com/tag/career/">Career</a><a href="https://www.smashingmagazine.com/tag/tools/">Tools</a></div>
<p>
	<a href="#top" class="top">&uarr; Back to top</a>

	<a onclick="clicky.log('#sharelink-clicked');" class="sot single" href="https://twitter.com/intent/tweet?original_referer=https://www.smashingmagazine.com/2017/07/missing-advice-when-starting-career/&#038;source=tweetbutton&#038;text=The%20Missing%20Advice%20I%20Needed%20When%20Starting%20My%20Career&#038;url=https://www.smashingmagazine.com/2017/07/missing-advice-when-starting-career/&#038;via=smashingmag">Tweet it</a><a onclick="clicky.log('#sharelink-clicked');" class="sot single" href="http://www.facebook.com/sharer/sharer.php?u=https://www.smashingmagazine.com/2017/07/missing-advice-when-starting-career/">Share on Facebook</a></p>
	</p>

</article>
<div class="bio clearfix">
  <div class="grv">
    <img src="https://secure.gravatar.com/avatar/?s=78&amp;d=mm&amp;r=g" data-src="https://secure.gravatar.com/avatar/62bca2f41acf187b40d1fd8a0675f738?s=78&amp;d=mm&amp;r=g" data-src-retina="https://secure.gravatar.com/avatar/62bca2f41acf187b40d1fd8a0675f738?s=156&amp;d=mm&amp;r=g" class="avatar" height="78" width="78" >	</div>
	<div class="about">
		<a rel="author" class="poa" href="https://www.smashingmagazine.com/author/paul-boag/?rel=author" title="Posts by Paul Boag">Paul Boag</a>		<p>Paul Boag is the author of <a href="https://www.smashingmagazine.com/user-experience-revolution/">The User Experience Revolution</a> and a leader in digital strategy with over 20 years experience. Through <a href="https://boagworld.com/boagworks/consultancy/">consultancy</a>, <a href="https://boagworld.com/boagworks/speaking/">speaking</a>, <a href="https://boagworld.com/boagworks/writing/">writing</a>, <a href="https://boagworld.com/boagworks/training/">training</a> and <a href="https://boagworld.com/boagworks/mentorship/">mentoring</a> he passionately promotes digital best practice.</p>
	</div>
</div><div class="adv">
	<div class="oa_zone--ad commentspnsrtarget" id="commentspnsrtarget" data-ad-name="Comment Sponsor" data-ad-zone="26" data-ad-media="all"></div>
</div>

<ul id="comments" class="sub-tabs clearfix">
	<li><a href="#show-comments" class="active">1 Comment</a></li>
	</ul>
<div id="discussion" class="subtab-pages discussion">
	<div id="show-comments">
					<ol id="comments-overview" class="cl">
  <li class="comment even thread-even depth-1 clearfix">
	<span class="cn">1</span>

	<div class="c" id="comment-1300028">
		<div class="cau clearfix">
			<img src="https://secure.gravatar.com/avatar/?s=38&amp;d=mm&amp;r=g" data-src="https://secure.gravatar.com/avatar/bdd54ca79baf43f17c95ccdcafe4d2cd?s=38&amp;d=mm&amp;r=g" data-src-retina="https://secure.gravatar.com/avatar/bdd54ca79baf43f17c95ccdcafe4d2cd?s=76&amp;d=mm&amp;r=g" class="avatar" height="38" width="38" >			<div class="aum">
				<h3>Nils Solanki</h3>
				<span class="dati"><a href="https://www.smashingmagazine.com/2017/07/missing-advice-when-starting-career/#comment-1300028" title="Jump to Commentlink #1">July 25, 2017 1:36 pm</a></span>
			</div>
		</div>
		<div class="ctx">
			<p>Thank you for the great advice, Paul. It&#8217;s reassuring that even well-known designers like yourself have struggled with these issues. I&#8217;ve still got a long way ahead of myself it seems :) I was wondering though:<br />
Do you have some specific advice for someone who wants to go solo after a few years in an agency?</p>
		</div>
		<div class="com">
			<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-1300028' onclick='return addComment.moveForm( "comment-1300028", "1300028", "respond", "295176" )' aria-label='Reply to Nils Solanki'>Reply</a></div>
			<div class="rating__container clearfix" aria-live="polite">
	<div id="rating__value--1300028" class="rating__value">0</div>
			<div class="rating__stars" data-comment_id="1300028">
						<a class="rating__button rating__button--up"
				href="#"
				data-id="1"
				data-nonce="f93c970f5d"
				title="Vote up!"
			></a>
			<a class="rating__button rating__button--down"
				href="#"
				data-id="-1"
				data-nonce="99f62f4a0f"
				title="Vote down!"
			></a>
		</div>
	</div>		</div>
	</div>
</li><!-- #comment-## -->
</ol>
			</div>
	</div>


					<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/07/missing-advice-when-starting-career/#respond" style="display:none;">Click here to cancel reply.</a></small></h3>				<form action="https://www.smashingmagazine.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
					<div class="ccr right"><small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/07/missing-advice-when-starting-career/#respond" style="display:none;">Click here to cancel reply.</a></small></div><label for="comment">Your message</label><p>You may use simple HTML to add links or lists to your comment. Also, use <code>&lt;pre>&lt;code class="language-*">...&lt;/code>&lt;/pre></code> to mark up code snippets. We support -js, -markup and -css for comments.</p><textarea name="1f4b0-comment" id="comment" rows="10" class="input textarea" required></textarea><textarea name="comment" style="display:none" rows="1" cols="1"></textarea><div class="clearfix"><p class="input-half"><label for="comment_author">Your name</label><input type="text" name="author" id="comment_author" value="" class="input" required /></p></div>
<div class="clearfix"><p class="input-half"><label for="email">Your email</label><input type="text" name="email" id="email" value="" class="input" required /></p></div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='295176' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>				</form>
					</div><!-- #respond -->
		
			</div>		</div>		<p><a href="#top" class="top" title="Jump to the top of the page">&uarr; Back to top</a></p>
	</div></div></main>
<aside id="wpsidebar" class="sb" role="complementary">
	<div class="col side">
		<section class="mise sf clearfix" role="search">
	<form id="search_2" method="get" action="https://www.smashingmagazine.com/search-results/" target="_top">
    <label class="sl" for="searching_2">Search on Smashing Magazine</label>
		<input id="searching_2" name="q" type="text" placeholder="e.g. JavaScript" />
		<button class="search_submit" type="submit">Search</button>
		<input type="hidden" name="cx" value="partner-pub-6779860845561969:5884617103">
		<input type="hidden" name="cof" value="FORID:10">
		<input type="hidden" name="ie" value="UTF-8">
	</form>
</section>

		<section class="bw faw">
  <p class="awithus">
      <a class="ed-us" href="mailto:sp&#111;&#110;&#115;or&#105;ng&#64;&#115;&#109;&#97;&#115;&#104;&#105;&#110;&#103;&#109;aga&#122;&#105;ne&#46;&#99;&#111;&#109;">
	      Become a sponsor!      </a>
  </p>
  <div id="spnsrlist-a" class="oa_zone--sponsor" data-sponsor-lines="1"></div>
</section>
		
<section class="sf wg">
  <h3>
    <a href="https://www.smashingmagazine.com/the-smashing-newsletter/">
      <img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smnl.png" alt="198,064 fine folks have signed up to our Newsletter already, when will you?" />
      Smashing Newsletter
    </a>
  </h3>
  <p>Subscribe to our email newsletter for useful tips and valuable resources, sent out every second Tuesday.</p>
  <div id="mc_embed_signup" class="mcf">
    <form action="//smashingmagazine.us1.list-manage.com/subscribe/post?u=16b832d9ad4b28edf261f34df&amp;id=a1666656e0" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate">
      <label for="mcer-EMAIL" class="sr">Please provide us with your email address:</label>
      <input id="mcer-EMAIL" name="email" autocomplete="email" type="text" placeholder="email address" />
      <button id="mc-embedded-subscribe" name="subscribe" class="submit" type="submit">Subscribe</button>
    </form>
    <a href="https://www.smashingmagazine.com/the-smashing-newsletter/"><img class="mcc" src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/mc-counter.svg" alt="Currently, we have 191728 subscribers to our newsletter" /></a>
  </div>
</section>

		<section class="bw">
  <div id="spnsrlist-b" class="oa_zone--sponsor" data-sponsor-lines="3"></div>
</section>

		<section class="so wg">
	<div class="fir">
		<a href="https://www.smashingmagazine.com/design-systems-book" style="border:0;">
			<img
				src="https://www.smashingmagazine.com/wp-content/uploads/2017/06/cover-design-systems-2-sidebar.png"
				alt="Design Systems Book"
				width="94"
				height="131">
		</a>
		<p>
			As designing static pages has become untenable, many have started to approach design in a modular way.
			In this book, we’ll identify what makes an <strong>effective design system</strong> that empowers teams to
			create great digital products.
			<a href="https://www.smashingmagazine.com/design-systems-book/">Pre-order the book now →</a>
		</p>
	</div>
	<div class="sec">
		<a href="https://www.smashingmagazine.com/inclusive-design-patterns" style="border: 0;">
			<img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/inclusive-design-patterns.png" alt="Inclusive Design Patterns by Heydon Pickering" width="94" height="135">
		</a>
		<p>
			Today, too many websites are still inaccessible. In our new book
			<em>Inclusive Design Patterns</em>, we explore how to craft
			<strong>flexible front-end design patterns</strong> and make future-proof and accessible interfaces without extra effort. Hardcover, 312 pages.
			<a href="https://www.smashingmagazine.com/inclusive-design-patterns">Get the book →</a>
		</p>
	</div>
	<div class="thi">
		<a href="https://www.smashingmagazine.com/sketch-handbook" style="border:0;">
			<img src="https://www.smashingmagazine.com/wp-content/uploads/2016/11/sketch-handbook-sidebar-opt-v2.png" alt="The Sketch Handbook, with tips and tricks for designing with Sketch." width="94" height="142"></a>
		<p>Meet the new <em>Sketch Handbook</em>, our brand
			<strong>new Smashing book</strong> that will help you master all the tricky, advanced facets of Sketch. Filled with
			<strong>practical examples and tutorials in 12 chapters</strong>, the book will help you become more proficient in your work.
			<a href="https://www.smashingmagazine.com/sketch-handbook">Get the book</a>.</p>
	</div>

</section>


		<section class="bw">
  <div id="spnsrlist-c" class="oa_zone--sponsor" data-sponsor-lines="2"></div>
</section>

		<section class="mt wg">
  <a href="http://mediatemple.net">
    <img data-src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/mediatemple.svg" alt="Media Temple Logo" width="94" height="94" />
  </a>
  <p>We are proudly hosted on<br /><a href="http://mediatemple.net/webhosting/vps/dedicated-server/">Media Temple Dedicated Servers</a>. Performance matters.</p>
</section>

		<section>
	<div class="oa_zone--ad" id="sidebar_special-1" data-ad-name="Sidebar Special 1" data-ad-zone="72"></div>
</section>
<section>
	<div class="oa_zone--ad" id="sidebar_special-2" data-ad-name="Sidebar Special 2" data-ad-zone="72"></div>
</section>
<section>
	<div class="oa_zone--ad" id="sidebar_special-3" data-ad-name="Sidebar Special 3" data-ad-zone="72"></div>
</section>
<section>
	<div class="oa_zone--ad" id="sidebar_special-4" data-ad-name="Sidebar Special 4" data-ad-zone="72"></div>
</section>

		
<section class="wg">
	<div id="jobs">
		<h3>
			<a href="http://jobs.smashingmagazine.com/?pk_campaign=sm&amp;piwik_kwd=widget">
				<span>Smashing Job Board</span>
				<img data-src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/sm-jobs.png" alt="Smashing Jobs" width="36" height="34" />
			</a>
		</h3>
		<ul class="tl"><li class="clearfix"><a href="http://feedproxy.google.com/~r/smjobs/~3/F4eb9St9Woc/2503372">Expert User Experience Interactie ontwerper - Belastingdienst - (Utrecht) - FullTime</a><p>Expert User Experience Interactie ontwerper
&#013;
&#013;
Belastingdienst

&#013;
&#013;
Functie­omschrijving&#013;
Burgers en bedrijven in Nederland maken steeds m...</p></li><li class="clearfix"><a href="http://feedproxy.google.com/~r/smjobs/~3/adX0PvsyJzY/2502954">User Experience Designer - Elevated Third - (Denver) - FullTime</a><p>Elevated Third is a growing digital agency located in the heart of downtown Denver. We don’t have any design gurus or divas here, just outcome-focused people who d...</p></li></ul>		<a class="cr" href="http://jobs.smashingmagazine.com?pk_campaign=sm&amp;piwik_kwd=widget">
			View more job openings&hellip;		</a>
	</div>
</section>

		<section class="clearfix">
	<div class="oa_zone--ad sidebar_sky" id="sidebar_sky-1" data-ad-name="Sidebar 1" data-ad-zone="40"></div>
</section>

<section class="clearfix">
	<div class="oa_zone--ad sidebar_sky" id="sidebar_sky-2" data-ad-name="Sidebar 2" data-ad-zone="40"></div>
</section>

		<section class="so wg conf">
	<div class="fir">
		<a href="https://smashingconf.com/barcelona-2017">
			<img
				data-src="https://www.smashingmagazine.com/wp-content/uploads/2017/06/smashingconf-barcelona-sidebar.png"
				alt="SmashingConf Barcelona 2017"
				height="100"
				width="100">
		</a>
		<p>
			Trends don’t matter, but techniques do.
			With <a href="https://smashingconf.com/barcelona-2017/">SmashingConf Barcelona</a>, we’ll explore problems,
			smart solutions and lessons learned from actual projects.
			Taking place on October 17–18 at the Palau de la Música Catalana.
			<a href="https://smashingconf.com/barcelona-2017/registration">To the tickets →</a>
		</p>
	</div>
	<div class="thi">
		<a href="https://smashingconf.com">
			<img
				data-src="https://www.smashingmagazine.com/wp-content/uploads/2017/06/sidebar-freiburg-avatar.png"
				alt="SmashingConf Freiburg 2017"
				width="100"
				height="100">
		</a>
		<p>
			Home sweet home! On September 11–12th, we're gathering for our <strong>6th</strong>
			<a href="https://smashingconf.com">SmashingConf Freiburg</a> right next to the legendary Black Forest.
			With Umar Hansa, Rachel Andrew, Alla Kholmatova, Chris Wright, and others.
			<a href="https://smashingconf.com">To the tickets →</a>
		</p>
	</div>
</section>
		<section class="bw">
  <div id="spnsrlist-d" class="oa_zone--sponsor" data-sponsor-lines="2"></div>
</section>

		<section class="clearfix">
  <div class="oa_zone--ad sidebar_sky" id="sidebar_sky-3" data-ad-name="Sidebar 3" data-ad-zone="40"></div>
</section>

	</div>
</aside>
<footer class="f" id="footer" role="contentinfo">
		<p class="stmt">
		<em>With a commitment to quality content for the design community.</em>
		<br />Founded by Vitaly Friedman and Sven Lennartz. 2006-2017.		<br />Made in Germany.		<span class="flinks">
			&#9998;
			<a href="https://www.smashingmagazine.com/write-for-us/">Write for us</a> –
			<a href="https://www.smashingmagazine.com/contact/">Contact us</a> –
			<a href="https://www.smashingmagazine.com/privacy-policy-2/">Datenschutzerklärung</a> –
			<a href="https://www.smashingmagazine.com/about/">Impressum</a>.
		</span>
	</p>
</footer>
<script type='text/javascript'>
/* <![CDATA[ */
var iec_config = {"ajax_url":"https:\/\/www.smashingmagazine.com\/wp-json\/inpsyde-extended-comments\/rate\/","nonce":"36f8bd2411"};
/* ]]> */
</script>
<script id="loadjs__inpsyde_extended_comments_rating">!function(a){"use strict";a.loadOnloadJS=function(b,c){a.addEventListener("load",function(){loadJS(b,c)},!1)},a.loadJS=function(b,c){var d=a.document.createElement("script");d.src=b,d.async=c||!1,a.document.body.appendChild(d)}}(window);
 loadOnloadJS( "https://www.smashingmagazine.com/wp-content/plugins/extended-comments/assets/js/build.min.js?ver=1.0", 1 );</script><script id="inlinejs__preload-polfill">!function(t){"use strict";var e=t.document,r={};r.isPreloadSupported=function(){try{return e.createElement("link").relList.supports("preload")}catch(t){return!1}},r.init=function(){for(var t=e.getElementsByTagName("link"),r=0;r<t.length;r++){var n=t[r];"preload"===n.rel&&"style"===n.getAttribute("as")&&(loadCSS(n.href,n),n.rel=null)}},window.loadCSS&&!r.isPreloadSupported()&&r.init()}(this);</script><script id="loadjs__comment-reply"> loadOnloadJS( "https://www.smashingmagazine.com/wp-includes/js/comment-reply.min.js", 1 );</script><script id="loadjs__smash-onload"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/onload.min.js?ver=6.4.13", 1 );</script><script id="loadjs__smash-fastclick"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/fastclick.min.js?ver=6.4.13", 1 );</script><script id="loadjs__smash-lazy-images"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/lazy-images.min.js?ver=6.4.13", 1 );</script><script id="loadjs__smash-blocked"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/blocked.min.js?ver=6.4.13", 1 );</script><script id="loadjs__codepen"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/codepen.js?ver=6.4.13", 1 );</script><script id="loadjs__prism"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/prism.js?ver=6.4.13", 1 );</script><script type='text/javascript'>
/* <![CDATA[ */
var AdsI18N = {"Advertisement":"Advertisement"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/ads.min.js?ver=6.4.13'></script>
<script id="inlinejs__wp-embed">!function(a,b){"use strict";function c(){if(!e){e=!0;var a,c,d,f,g=-1!==navigator.appVersion.indexOf("MSIE 10"),h=!!navigator.userAgent.match(/Trident.*rv:11\./),i=b.querySelectorAll("iframe.wp-embedded-content");for(c=0;c<i.length;c++)if(d=i[c],!d.getAttribute("data-secret")){if(f=Math.random().toString(36).substr(2,10),d.src+="#?secret="+f,d.setAttribute("data-secret",f),g||h)a=d.cloneNode(!0),a.removeAttribute("security"),d.parentNode.replaceChild(a,d)}else;}}var d=!1,e=!1;if(b.querySelector)if(a.addEventListener)d=!0;if(a.wp=a.wp||{},!a.wp.receiveEmbedMessage)if(a.wp.receiveEmbedMessage=function(c){var d=c.data;if(d.secret||d.message||d.value)if(!/[^a-zA-Z0-9]/.test(d.secret)){var e,f,g,h,i,j=b.querySelectorAll('iframe[data-secret="'+d.secret+'"]'),k=b.querySelectorAll('blockquote[data-secret="'+d.secret+'"]');for(e=0;e<k.length;e++)k[e].style.display="none";for(e=0;e<j.length;e++)if(f=j[e],c.source===f.contentWindow){if(f.removeAttribute("style"),"height"===d.message){if(g=parseInt(d.value,10),g>1e3)g=1e3;else if(200>~~g)g=200;f.height=g}if("link"===d.message)if(h=b.createElement("a"),i=b.createElement("a"),h.href=f.getAttribute("src"),i.href=d.value,i.host===h.host)if(b.activeElement===f)a.top.location.href=d.value}else;}},d)a.addEventListener("message",a.wp.receiveEmbedMessage,!1),b.addEventListener("DOMContentLoaded",c,!1),a.addEventListener("load",c,!1)}(window,document);</script>
		<script>try {
			SmashingAds.loadAds();
		} catch ( e ) {
		}</script>

		<script>try {
			SmashingAds.render( OA_output );
		} catch ( e ) {
		}</script>

	<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"86b694293f","applicationID":"11250242","transactionName":"NgMAbEZVV0cAWxZYXg9JI1tAXVZaTksLX1YNAw==","queueTime":0,"applicationTime":233,"atts":"GkQDGg5PREk=","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>
