<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
	<title>Web Development Reading List #171: Leaks, SHA-1 Collision, And Brotli &ndash; Smashing Magazine</title>
	<meta charset="UTF-8" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[(new Date).getTime()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=NREUM;"undefined"==typeof window.newrelic&&(newrelic=f);var s=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],l="api-",p=l+"ixn-";a(s,function(e,t){f[t]=o(l+t,!0,"api")}),f.addPageAction=o(l+"addPageAction",!0),f.setCurrentRouteName=o(l+"routeName",!0),t.exports=newrelic,f.interaction=function(){return(new r).get()};var d=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(p+"tracer",[Date.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[Date.now(),r,o],n),o)try{return t.apply(this,arguments)}finally{c.emit("fn-end",[Date.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){d[t]=o(p+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,(new Date).getTime()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o){if(!p.aborted){e&&e(n,r,o);for(var i=t(o),a=v(n),u=a.length,c=0;c<u;c++)a[c].apply(i,r);var f=s[w[n]];return f&&f.push([y,n,r,i]),i}}function d(e,t){b[e]=v(e).concat(t)}function v(e){return b[e]||[]}function g(e){return l[e]=l[e]||o(n)}function m(e,t){f(e,function(e,n){t=t||"feature",w[n]=t,t in s||(s[t]=[])})}var b={},w={},y={on:d,emit:n,get:g,listeners:v,context:t,buffer:m,abort:a,aborted:!1};return y}function i(){return new r}function a(){(s.api||s.feature)&&(p.aborted=!0,s=p.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},l={},p=t.exports=o();p.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!h++){var e=y.info=NREUM.info,t=l.getElementsByTagName("script")[0];if(setTimeout(f.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return f.abort();c(b,function(t,n){e[t]||(e[t]=n)}),u("mark",["onload",a()],null,"api");var n=l.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===l.readyState&&i()}function i(){u("mark",["domContent",a()],null,"api")}function a(){return(new Date).getTime()}var u=e("handle"),c=e(2),f=e("ee"),s=window,l=s.document,p="addEventListener",d="attachEvent",v=s.XMLHttpRequest,g=v&&v.prototype;NREUM.o={ST:setTimeout,CT:clearTimeout,XHR:v,REQ:s.Request,EV:s.Event,PR:s.Promise,MO:s.MutationObserver},e(1);var m=""+location,b={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1016.min.js"},w=v&&g&&g[p]&&!/CriOS/.test(navigator.userAgent),y=t.exports={offset:a(),origin:m,features:{},xhrWrappable:w};l[p]?(l[p]("DOMContentLoaded",i,!1),s[p]("load",r,!1)):(l[d]("onreadystatechange",o),s[d]("onload",r)),u("mark",["firstbyte",a()],null,"api");var h=0},{}]},{},["loader"]);</script>
	<link rel="dns-prefetch" href="https://media-mediatemple.netdna-ssl.com/" />
	<link rel="dns-prefetch" href="https//auslieferung.commindo-media-resourcen.de/" />
	<link rel="preconnect" href="https://media-mediatemple.netdna-ssl.com" />
	<link rel="preconnect" href="https://auslieferung.commindo-media-resourcen.de/" />
	<style id="smash-above-the-fold-css">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</style><script>!function(e){"use strict";function t(e,t,n){e.addEventListener?e.addEventListener(t,n,!1):e.attachEvent&&e.attachEvent("on"+t,n)}function n(t,n){return e.localStorage&&localStorage[t+"_content"]&&localStorage[t+"_file"]===n}function o(t,o){if(e.localStorage&&e.XMLHttpRequest)n(t,o)?r(localStorage[t+"_content"]):a(t,o);else{var i=l.createElement("link");i.href=o,i.id=t,i.rel="stylesheet",i.type="text/css",l.getElementsByTagName("head")[0].appendChild(i),l.cookie=t}}function a(e,t){var n=new XMLHttpRequest;n.open("GET",t,!0),n.onreadystatechange=function(){4===n.readyState&&200===n.status&&(r(n.responseText),localStorage[e+"_content"]=n.responseText,localStorage[e+"_file"]=t)},n.send()}function r(e){var t=l.createElement("style");t.setAttribute("type","text/css"),l.getElementsByTagName("head")[0].appendChild(t),t.styleSheet?t.styleSheet.cssText=e:t.innerHTML=e}var l=e.document,i=function(e,t,n){function o(e){return l.body?e():void setTimeout(function(){o(e)})}function a(){i.addEventListener&&i.removeEventListener("load",a),i.media=n||"all"}var r,i=l.createElement("link");if(t)r=t;else{var s=(l.body||l.getElementsByTagName("head")[0]).childNodes;r=s[s.length-1]}var c=l.styleSheets;i.rel="stylesheet",i.href=e,i.media="only x",o(function(){r.parentNode.insertBefore(i,t?r:r.nextSibling)});var d=function(e){for(var t=i.href,n=c.length;n--;)if(c[n].href===t)return e();setTimeout(function(){d(e)})};return i.addEventListener&&i.addEventListener("load",a),i.onloadcssdefined=d,d(a),i};"undefined"!=typeof exports?exports.loadCSS=i:e.loadCSS=i,e.loadLocalStorageCSS=function(a,r){n(a,r)||l.cookie.indexOf(a)>-1?o(a,r):t(e,"load",function(){o(a,r)})}}(this);</script>
<link rel="preload" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/main.min.css?ver=6.4.7" as="style" onload="this.rel='stylesheet'" /><noscript><link rel='stylesheet' id='smash-main-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/main.min.css?ver=6.4.7' type='text/css' media='all' />
</noscript><link rel="preload" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/articles-only.min.css?ver=6.4.7" as="style" onload="this.rel='stylesheet'" /><noscript><link rel='stylesheet' id='smash-article-only-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/articles-only.min.css?ver=6.4.7' type='text/css' media='all' />
</noscript><script id="loadcss__smash-below-articles">loadCSS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/below-articles.min.css?ver=6.4.7", false, "all" );</script><noscript><link rel='stylesheet' id='smash-below-articles-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/below-articles.min.css?ver=6.4.7' type='text/css' media='all' />
</noscript><script id="loadcss__smash-comments">loadCSS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/comments.min.css?ver=6.4.7", false, "all" );</script><noscript><link rel='stylesheet' id='smash-comments-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/comments.min.css?ver=6.4.7' type='text/css' media='all' />
</noscript><link rel='stylesheet' id='smash-print-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/print.min.css?ver=6.4.7' type='text/css' media='print' />
<script id="loadcss__smash-webfonts">loadLocalStorageCSS( "smash-webfonts", "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/webfonts.min.css?ver=6.4.7" );</script><!--[if IE 8]>
<link rel='stylesheet' id='smash-ie8-css'  href='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/css/ie8-nu.min.css?ver=6.4.7' type='text/css' media='all' />
<![endif]-->

<!-- This site is optimized with the Yoast SEO Premium plugin v3.5.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Phew, what a week! Due to an HTML-parsing bug, Cloudflare experienced a major data leak, and the first practical collision for SHA-1 was revealed as well.    We should take these events as an occasion to reconsider if a centralized front-end load balancer that modifies your traffic is a good idea after all. And it’s definitely time to upgrade your TLS-certificate if you still serve SHA-1, too. Here’s what else happened this week."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://www.smashingmagazine.com/2017/02/web-development-reading-list-171/" />
<link rel="publisher" href="https://plus.google.com/+SmashingMagazine‎"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Web Development Reading List #171: Leaks, SHA-1 Collision, And Brotli &ndash; Smashing Magazine" />
<meta property="og:description" content="Phew, what a week! Due to an HTML-parsing bug, Cloudflare experienced a major data leak, and the first practical collision for SHA-1 was revealed as well.    We should take these events as an occasion to reconsider if a centralized front-end load balancer that modifies your traffic is a good idea after all. And it’s definitely time to upgrade your TLS-certificate if you still serve SHA-1, too. Here’s what else happened this week." />
<meta property="og:url" content="https://www.smashingmagazine.com/2017/02/web-development-reading-list-171/" />
<meta property="og:site_name" content="Smashing Magazine" />
<meta property="article:publisher" content="https://www.facebook.com/smashmag" />
<meta property="article:tag" content="Web Development Reading List" />
<meta property="article:section" content="General" />
<meta property="article:published_time" content="2017-02-24T13:51:12+01:00" />
<meta property="og:image" content="https://www.smashingmagazine.com/wp-content/uploads/2017/02/git-guide-opt.png" />
<meta property="og:image" content="https://www.smashingmagazine.com/wp-content/uploads/2017/02/brotli-support-opt.png" />
<meta property="og:image" content="https://www.smashingmagazine.com/wp-content/uploads/2017/02/airink-opt.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Phew, what a week! Due to an HTML-parsing bug, Cloudflare experienced a major data leak, and the first practical collision for SHA-1 was revealed as well.    We should take these events as an occasion to reconsider if a centralized front-end load balancer that modifies your traffic is a good idea after all. And it’s definitely time to upgrade your TLS-certificate if you still serve SHA-1, too. Here’s what else happened this week." />
<meta name="twitter:title" content="Web Development Reading List #171: Leaks, SHA-1 Collision, And Brotli &ndash; Smashing Magazine" />
<meta name="twitter:site" content="@smashingmag" />
<meta name="twitter:image" content="https://www.smashingmagazine.com/wp-content/uploads/2017/02/wdrl-171-opt.png" />
<meta name="twitter:creator" content="@helloanselm" />
<meta property="DC.date.issued" content="2017-02-24T13:51:12+01:00" />
<!-- / Yoast SEO Premium plugin. -->

<link rel="alternate" type="application/rss+xml" title="Smashing Magazine &raquo; Feed" href="https://www.smashingmagazine.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Smashing Magazine &raquo; Comments Feed" href="https://www.smashingmagazine.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Smashing Magazine &raquo; Web Development Reading List #171: Leaks, SHA-1 Collision, And Brotli Comments Feed" href="https://www.smashingmagazine.com/2017/02/web-development-reading-list-171/feed/" />

<script type='text/javascript'>
/* <![CDATA[ */
var SmashingServiceWorkerData = {"url":"https:\/\/www.smashingmagazine.com\/serviceWorker.js"};
/* ]]> */
</script>
<script>
var SmashingServiceWorkerData=SmashingServiceWorkerData||{url:""};(function(a,b){if(b.url&&"serviceWorker" in a){a.serviceWorker.register(b.url);window.addEventListener("load",function(){if(a.serviceWorker.controller){a.serviceWorker.controller.postMessage({command:"trimCaches"})}})}})(navigator,SmashingServiceWorkerData);
</script>
<!--[if IE 8]>
<script type='text/javascript' src='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/html5shiv.min.js?ver=6.4.7'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://www.smashingmagazine.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.smashingmagazine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.smashingmagazine.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.smashingmagazine.com/?p=285293' />
<link rel="alternate" type="application/json+oembed" href="https://www.smashingmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.smashingmagazine.com%2F2017%2F02%2Fweb-development-reading-list-171%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.smashingmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.smashingmagazine.com%2F2017%2F02%2Fweb-development-reading-list-171%2F&#038;format=xml" />
<!-- Stream WordPress user activity plugin v3.0.7 -->
	<script>
	dataLayer = [
		{
			'site': {"ID":"1","name":"Smashing Magazine","home":"https:\/\/www.smashingmagazine.com"},
			'user': {"isLoggedIn":false,"ID":0,"role":"visitor"}		}
	];
</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
		new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
		j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
		'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-NWC9FPF');
</script>

	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="mask-icon" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/s.svg" color="#e53b2c" sizes="any" />
<!--[if IE]><link href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/favicon.ico" rel="icon" /><![endif]-->
<link rel="icon" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/favicon.png" />
<meta name="application-name" content="Smashing Magazine" />
<meta name="msapplication-TileColor" content="#fff" />
<meta name="msapplication-square70x70logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-70-70.png" />
<meta name="msapplication-square150x150logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-150-150.png" />
<meta name="msapplication-wide310x150logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-310-150.png" />
<meta name="msapplication-square310x310logo" content="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smashing-windows-icon-310-310.png" />
<meta name="msapplication-notification" content="frequency=30;polling-uri1=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=1;polling-uri2=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=2;polling-uri3=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=3;polling-uri4=http://notifications.buildmypinnedsite.com/?feed=https://www.smashingmagazine.com/feed/&amp;id=4;cycle=1" />
<link rel="apple-touch-icon-precomposed" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-57x57-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-72x72-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-114x114-precomposed.png" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/apple-touch-icon-144x144-precomposed.png" />
</head>
<body id="top" class="single single-post postid-285293 single-format-standard www-section">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NWC9FPF" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div class="mnb">
	<a href="#mn" class="ntb js-toggle-btn" title="Jump to the main navigation">
		Menu	</a>
	<a href="#ms" class="stb js-toggle-btn" title="Jump to the search">
		Search    </a>
</div><a class="sr" href="#content">Jump to the content</a>
<header class="h" role="banner">
	<h1 class="logo">
		<span class="sr">Smashing Magazine</span>
		<a href="https://www.smashingmagazine.com/"><img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/logo.png" alt="Smashing Magazine Logo" srcset="https://media-mediatemple.netdna-ssl.com/wp-content/themes/smashing-magazine/assets/images/logo.svg" /></a>
	</h1>
</header>
<nav class="mn" id="mn" role="navigation menu">
	<h2>Smashing Pages:</h2>
	 <ul id="menu-smashing-mobile-network" class="mnu"><li id="menu-item-218248" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218248 menu-item-books"><a href="https://www.smashingmagazine.com/books/">Books</a></li>
<li id="menu-item-218247" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218247 menu-item-ebooks"><a href="https://www.smashingmagazine.com/ebooks__trashed/">eBooks</a></li>
<li id="menu-item-218249" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218249 menu-item-tickets"><a href="https://www.smashingmagazine.com/workshops/">Tickets</a></li>
<li id="menu-item-219109" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219109 menu-item-shop"><a href="https://shop.smashingmagazine.com/">Shop</a></li>
<li id="menu-item-188959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188959 menu-item-email-newsletter"><a href="https://www.smashingmagazine.com/the-smashing-newsletter/">Email Newsletter</a></li>
<li id="menu-item-188961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-188961 menu-item-jobs"><a href="http://jobs.smashingmagazine.com">Jobs</a></li>
<li id="menu-item-188958" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-188958 menu-item-about-us-impressum"><a href="https://www.smashingmagazine.com/about/">About us / Impressum</a></li>
</ul>	<h2>Categories:</h2>
	 <ul id="menu-mobile-categories" class="mnu"><li id="menu-item-181575" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181575 menu-item-coding"><a href="https://www.smashingmagazine.com/category/coding/">Coding</a></li>
<li id="menu-item-181576" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181576 menu-item-design"><a href="https://www.smashingmagazine.com/category/design/">Design</a></li>
<li id="menu-item-181580" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181580 menu-item-mobile"><a href="https://www.smashingmagazine.com/category/mobile/">Mobile</a></li>
<li id="menu-item-181579" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181579 menu-item-graphics"><a href="https://www.smashingmagazine.com/category/graphics/">Graphics</a></li>
<li id="menu-item-181577" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181577 menu-item-ux-design"><a href="https://www.smashingmagazine.com/category/uxdesign/">UX Design</a></li>
<li id="menu-item-181578" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181578 menu-item-wordpress"><a href="https://www.smashingmagazine.com/category/wordpress/"><span class="long"><span>Word</span><span>Press</span></span><span class="short">WP</span></a></li>
</ul></nav>
<a class="mnc js-toggle-btn" href="#top" data-toggle-target="mn" title="Close the navigation">X</a><div class="ms" id="ms" role="search">
  <form id="mobile-searching" class="sfm clearfix" method="get" action="https://www.smashingmagazine.com/search-results/" target="_top">
    <label for="mobile-search-input">Search on Smashing Magazine</label>
    <input name="q" id="mobile-search-input" type="text" placeholder="e.g. CSS" />
    <button class="submit" type="submit">Search</button>
    <input type="hidden" name="cx" value="partner-pub-6779860845561969:5884617103">
    <input type="hidden" name="cof" value="FORID:10">
    <input type="hidden" name="ie" value="UTF-8">
  </form>
</div>
<a role="button" class="msc js-toggle-btn" href="#top" data-toggle-target="ms" title="Close the search">X</a>
<nav class="tn clearfix" role="navigation">
	 <ul id="menu-network-menu" class="nw clearfix"><li class="current"><a href="https://www.smashingmagazine.com"><img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/logo.png" alt="Smashing Magazine" srcset="https://media-mediatemple.netdna-ssl.com/wp-content/themes/smashing-magazine/assets/images/logo.svg"  /></a></li><li id="menu-item-218245" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218245 menu-item-books"><a href="https://www.smashingmagazine.com/books/">Books</a></li>
<li id="menu-item-231721" class="cody menu-item menu-item-type-custom menu-item-object-custom menu-item-231721 menu-item-ebooks"><a href="https://shop.smashingmagazine.com/products/the-smashing-library">eBooks</a></li>
<li id="menu-item-218696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218696 menu-item-tickets"><a href="https://www.smashingmagazine.com/smashing-workshops/">Tickets</a></li>
<li id="menu-item-231722" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-231722 menu-item-shop"><a href="https://shop.smashingmagazine.com/">Shop</a></li>
<li id="menu-item-2" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2 menu-item-jobs"><a href="http://jobs.smashingmagazine.com/">Jobs</a></li>
</ul><nav id="social-media-nav" role="menu">
  <ul class="ch">
  	<li class="rss">
	    <a href="https://www.smashingmagazine.com/feed/" title="Subscribe to our RSS-feed (120K)">RSS</a>
    </li>
  	<li class="fb">
	    <a href="//www.facebook.com/smashmag" title="Join our Facebook page! (267k)">Facebook</a>
    </li>
  	<li class="tw">
	    <a href="//twitter.com/smashingmag" title="Follow us on Twitter! (956k)">Twitter</a>
    </li>
  	<li class="nl">
	    <a href="https://www.smashingmagazine.com/the-smashing-newsletter/" title="Subscribe to our Email Newsletter (180k)">Newsletter</a>
    </li>
  </ul>
</nav>
</nav>
<main>
	<div class="cc">
		<div class="fluid clearfix">
			<div class="grid clearfix">
				<section class="mise sf clearfix" role="search">
	<form id="search_1" method="get" action="https://www.smashingmagazine.com/search-results/" target="_top">
    <label class="sl" for="searching_1">Search on Smashing Magazine</label>
		<input id="searching_1" name="q" type="text" placeholder="e.g. JavaScript" />
		<button class="search_submit" type="submit">Search</button>
		<input type="hidden" name="cx" value="partner-pub-6779860845561969:5884617103">
		<input type="hidden" name="cof" value="FORID:10">
		<input type="hidden" name="ie" value="UTF-8">
	</form>
</section>
				<div class="col sn">
					<div class="sct"><ul id="menu-category-menu" class="clearfix"><li id="menu-item-116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-116 menu-item-coding"><a href="https://www.smashingmagazine.com/category/coding/">Coding</a>
<ul class="sub-menu">
	<li id="menu-item-2014" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2014 menu-item-css"><a href="https://www.smashingmagazine.com/tag/css/">CSS</a></li>
	<li id="menu-item-134810" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-134810 menu-item-html"><a href="https://www.smashingmagazine.com/tag/html/">HTML</a></li>
	<li id="menu-item-2015" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2015 menu-item-javascript"><a href="https://www.smashingmagazine.com/tag/javascript/">JavaScript</a></li>
	<li id="menu-item-2016" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2016 menu-item-techniques"><a href="https://www.smashingmagazine.com/tag/techniques/">Techniques</a></li>
</ul>
</li>
<li id="menu-item-117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-117 menu-item-design"><a href="https://www.smashingmagazine.com/category/design/">Design</a>
<ul class="sub-menu">
	<li id="menu-item-2017" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2017 menu-item-web-design"><a href="https://www.smashingmagazine.com/tag/web-design/">Web Design</a></li>
	<li id="menu-item-231166" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-231166 menu-item-responsive"><a title="Responsive Web Design" href="https://www.smashingmagazine.com/tag/responsive-web-design/">Responsive</a></li>
	<li id="menu-item-2032" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2032 menu-item-typography"><a href="https://www.smashingmagazine.com/tag/typography/">Typography</a></li>
	<li id="menu-item-2063" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2063 menu-item-inspiration"><a href="https://www.smashingmagazine.com/tag/inspiration/">Inspiration</a></li>
</ul>
</li>
<li id="menu-item-119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-119 menu-item-mobile"><a href="https://www.smashingmagazine.com/category/mobile/">Mobile</a>
<ul class="sub-menu">
	<li id="menu-item-142132" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-142132 menu-item-iphone-ipad"><a href="https://www.smashingmagazine.com/tag/ios/">iPhone &#038; iPad</a></li>
	<li id="menu-item-143596" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143596 menu-item-android"><a href="https://www.smashingmagazine.com/tag/android/">Android</a></li>
	<li id="menu-item-143608" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143608 menu-item-design-patterns"><a href="https://www.smashingmagazine.com/tag/design-patterns/">Design Patterns</a></li>
</ul>
</li>
<li id="menu-item-118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-118 menu-item-graphics"><a href="https://www.smashingmagazine.com/category/graphics/">Graphics</a>
<ul class="sub-menu">
	<li id="menu-item-2264" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2264 menu-item-photoshop"><a href="https://www.smashingmagazine.com/tag/photoshop/">Photoshop</a></li>
	<li id="menu-item-160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-160 menu-item-fireworks"><a href="https://www.smashingmagazine.com/category/fireworks/">Fireworks</a></li>
	<li id="menu-item-2283" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2283 menu-item-wallpapers"><a href="https://www.smashingmagazine.com/tag/wallpapers/">Wallpapers</a></li>
	<li id="menu-item-2305" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-2305 menu-item-freebies"><a href="https://www.smashingmagazine.com/tag/freebies/">Freebies</a></li>
</ul>
</li>
<li id="menu-item-120" class="menu-item-uxdesign menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-120 menu-item-ux-design"><a href="https://www.smashingmagazine.com/category/uxdesign/">UX Design</a>
<ul class="sub-menu">
	<li id="menu-item-143609" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143609 menu-item-usability"><a href="https://www.smashingmagazine.com/tag/usability/">Usability</a></li>
	<li id="menu-item-143610" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143610 menu-item-user-experience"><a href="https://www.smashingmagazine.com/tag/user-experience/">User Experience</a></li>
	<li id="menu-item-143611" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143611 menu-item-ui-design"><a href="https://www.smashingmagazine.com/tag/ui/">UI Design</a></li>
	<li id="menu-item-143612" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143612 menu-item-e-commerce"><a href="https://www.smashingmagazine.com/tag/e-commerce/">E-Commerce</a></li>
</ul>
</li>
<li id="menu-item-121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-121 menu-item-wordpress"><a href="https://www.smashingmagazine.com/category/wordpress/"><span class="long"><span>Word</span><span>Press</span></span><span class="short">WP</span></a>
<ul class="sub-menu">
	<li id="menu-item-143677" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143677 menu-item-essentials"><a href="https://www.smashingmagazine.com/tag/essentials/">Essentials</a></li>
	<li id="menu-item-143678" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143678 menu-item-techniques"><a href="https://www.smashingmagazine.com/tag/techniques-wp/">Techniques</a></li>
	<li id="menu-item-143679" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143679 menu-item-plugins"><a href="https://www.smashingmagazine.com/tag/plugins/">Plugins</a></li>
	<li id="menu-item-143680" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-143680 menu-item-themes"><a href="https://www.smashingmagazine.com/tag/themes/">Themes</a></li>
</ul>
</li>
</ul></div>				</div>
				<div id="content" class="col main">
					<div id="blocked" class="blocked clearfix">

	<figure style="max-width: 24%;min-width: 90px;">
		<a href="https://smashingconf.com">
			<img src="https://www.smashingmagazine.com/wp-content/uploads/2016/11/smashingconf-san-francisco-2017-1.png" alt="Smashing Conf San Francisco">
		</a>
	</figure>

	<p style="font-size: calc(1em + ((0.4vw + 0.25vh) / 2));">
		<strong>We use ad-blockers as well, you know.</strong> We gotta keep those servers running though.
		Did you know that we publish <a href="https://www.smashingmagazine.com/books/">useful books</a> and run
		<a href="https://www.smashingmagazine.com/smashing-workshops/">friendly conferences</a>
		— crafted for pros like yourself? E.g. upcoming <a href="https://smashingconf.com">SmashingConf San Francisco</a>,
		dedicated to smart front-end techniques and design patterns.
	</p>
</div>
<article class="post-285293 post type-post status-publish format-standard has-post-thumbnail hentry category-general tag-web-development-reading-list" vocab="http://schema.org/" typeof="TechArticle">

		<h2>
		<a property="url" href="https://www.smashingmagazine.com/2017/02/web-development-reading-list-171/" rel="bookmark" title="Read 'Web Development Reading List #171: Leaks, SHA-1 Collision, And Brotli'"><span property="name">Web Development Reading List #171: Leaks, SHA-1 Collision, And Brotli</span></a>
	</h2>

			
<ul class="pmd clearfix">
	<li class="a" property="author" typeof="person" resource="#authorname">By <a href="https://www.smashingmagazine.com/author/anselm-hannemann/" title="Posts by Anselm Hannemann" rel="author">Anselm Hannemann</a></li>
				<li class="rd" property="datePublished" content="February 24th, 2017">February 24th, 2017</li>
				<li class="tags" property="keywords"><a href="https://www.smashingmagazine.com/tag/web-development-reading-list/">Web Development Reading List</a></li>
		<li class="comments" property="discussionUrl"><a href="#comments" title="Comment on Web Development Reading List #171: Leaks, SHA-1 Collision, And Brotli">0 Comments</a> </li>
		</ul>
	
	<div class="ad ed">
	<div class="oa_zone--ad cad" id="cad" data-ad-name="Medium Rectangle" data-ad-zone="22" data-ad-media="all"></div>
</div>

	<p>Phew, what a week! Due to an HTML-parsing bug, Cloudflare experienced a major <strong>data leak</strong>, and the first practical collision for SHA-1 was revealed as well. We should take these events as an occasion to reconsider if a centralized front-end load balancer that modifies your traffic is a good idea after all. And it’s definitely time to upgrade your TLS-certificate if you still serve SHA-1, too. Here’s what else happened this week.</p>
<h3  id="news">News <a href="#news" aria-label="Link to section 'News'" class="sr hsl">Link</a></h3>
<ul>
<li>Cloudflare experienced a <a href="https://bugs.chromium.org/p/project-zero/issues/detail?id=1139">memory leak caused by its document parser</a><sup class="po" id="note-1"><a href="#1">1</a></sup>. <a href="https://blog.cloudflare.com/incident-report-on-memory-leak-caused-by-cloudflare-parser-bug/">Here is the incident report by Cloudflare</a><sup class="po" id="note-2"><a href="#2">2</a></sup>.</li>
<li>The fresh <a href="https://webkit.org/blog/7423/release-notes-for-safari-technology-preview-24/">Safari Technology Preview 24</a><sup class="po" id="note-3"><a href="#3">3</a></sup> added support for PerformanceObserver and added <code>&lt;link preload&gt;</code> as an experimental feature. Furthermore, they implemented the dynamic JavaScript <code>import</code> operator and suspended SVG animations on hidden pages.</li>
<li>It was just a matter of time until browsers would stop accepting SHA-1 certificates. But this week, things took a sudden turn as Google researchers revealed the first practical collision for SHA-1, affirming the insecurity of the algorithm. As a result of this, starting from today, Mozilla will <a href="https://blog.mozilla.org/security/2017/02/23/the-end-of-sha-1-on-the-public-web/">remote-update Firefox to not accept SHA-1 in certificates anymore</a><sup class="po" id="note-4"><a href="#4">4</a></sup>.</li>
</ul>
<h3  id="general">General <a href="#general" aria-label="Link to section 'General'" class="sr hsl">Link</a></h3>
<ul>
<li>How does your team review code? Ana Balica shares a useful <a href="https://ana-balica.github.io/2017/02/21/code-review-checklist/">checklist for reviewing your and your teammates code</a><sup class="po" id="note-5"><a href="#5">5</a></sup>.</li>
</ul>
<h3  id="tools-workflows">Tools &amp; Workflows <a href="#tools-workflows" aria-label="Link to section 'Tools &amp; Workflows'" class="sr hsl">Link</a></h3>
<ul>
<li>Joseph Zimmerman <a href="https://www.smashingmagazine.com/2017/02/a-detailed-introduction-to-webpack/">introduces us to Webpack</a><sup class="po" id="note-6"><a href="#6">6</a></sup>. What I really like about this article is that it’s not another article sharing pre-built sets of configurations but that it explains every detail step-by-step.</li>
<li><a href="http://ohshitgit.com/"><em>Oh shit, git!</em></a><sup class="po" id="note-7"><a href="#7">7</a></sup> Don’t be afraid of git anymore thanks to this emergency guide that helps you solve the most common problems with the versioning system.</li>
</ul>
<figure><a href="http://ohshitgit.com/"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/02/git-guide-opt.png" width="800" height="335" alt="Oh shit, git!" /></a><sup class="po" id="note-8"><a href="#8">8</a></sup><br />
<figcaption>Something went wrong in Git, but you don’t know how to get yourself out of the mess? “<a href="http://ohshitgit.com/">Oh shit, git!</a><sup class="po" id="note-9"><a href="#9">9</a></sup>” has got your back.</figcaption>
</figure>
<h3  id="security">Security <a href="#security" aria-label="Link to section 'Security'" class="sr hsl">Link</a></h3>
<ul>
<li>Mitigating Cross-Site Request Forgery attacks has never been easy. Luckily, it seems that we now got a proper solution for it: <a href="https://scotthelme.co.uk/csrf-is-dead/">Same-Site Cookies</a><sup class="po" id="note-10"><a href="#10">10</a></sup>. The only thing you need to do to make it work is adding <code>SameSite</code> to your existing <code>Set-Cookie</code> header. Of course, you should know how same-site cookies differ from “normal” cookies, but for most sites this should be easy to implement.</li>
<li>A joint-venture of five journalists researched how the private security industry works and <a href="https://thecorrespondent.com/10221/security-for-sale-the-price-we-pay-to-protect-europeans">what price we as citizens pay for our security</a><sup class="po" id="note-11"><a href="#11">11</a></sup>.</li>
</ul>
<h3  id="privacy">Privacy <a href="#privacy" aria-label="Link to section 'Privacy'" class="sr hsl">Link</a></h3>
<ul>
<li>It’s not your computer that is the most vulnerable device, it’s your smartphone. In fact, for a small amount of money, <a href="https://motherboard.vice.com/en_us/article/i-tracked-myself-with-dollar170-smartphone-spyware-that-anyone-can-buy">everyone can easily buy spyware</a><sup class="po" id="note-12"><a href="#12">12</a></sup> that works on most Android phones. For iOS, things look a bit better unless the device is jailbroken. But this doesn’t necessarily mean that spyware doesn’t exist for that system as well.</li>
</ul>
<h3  id="web-performance">Web Performance <a href="#web-performance" aria-label="Link to section 'Web Performance'" class="sr hsl">Link</a></h3>
<ul>
<li>Thadee Trompetter shares insights into <a href="https://www.voorhoede.nl/en/blog/static-site-implosion-with-brotli-and-gzip/">how Brotli can improve your site’s performance</a><sup class="po" id="note-13"><a href="#13">13</a></sup> and why he relies on pre-compressing rather than doing it on the fly on the server.</li>
</ul>
<figure><a href="https://www.voorhoede.nl/en/blog/static-site-implosion-with-brotli-and-gzip/"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/02/brotli-support-opt.png" width="800" height="408" alt="Brotli support" /></a><sup class="po" id="note-14"><a href="#14">14</a></sup><br />
<figcaption>With support for Chrome, Firefox, Opera and the Android browser, <a href="https://www.voorhoede.nl/en/blog/static-site-implosion-with-brotli-and-gzip/">Brotli does a better job at compressing resources</a><sup class="po" id="note-15"><a href="#15">15</a></sup> than its predecessor Gzip.</figcaption>
</figure>
<h3  id="javascript">JavaScript <a href="#javascript" aria-label="Link to section 'JavaScript'" class="sr hsl">Link</a></h3>
<ul>
<li>Manuel Matuzovic explains <a href="https://medium.com/@matuzo/writing-javascript-with-accessibility-in-mind-a1f6a5f467b9">how to write JavaScript with accessibility in mind</a><sup class="po" id="note-16"><a href="#16">16</a></sup>.</li>
</ul>
<h3  id="going-beyond">Going Beyond… <a href="#going-beyond" aria-label="Link to section 'Going Beyond…'" class="sr hsl">Link</a></h3>
<ul>
<li>A team at the MIT Media Lab invented a device that captures air pollution and <a href="https://www.kickstarter.com/projects/1295587226/air-ink-the-worlds-first-ink-made-out-of-air-pollu">turns the pollution into safe, high-quality ink for art</a><sup class="po" id="note-17"><a href="#17">17</a></sup>.</li>
<li>The Institute For Energy Efficiency’s computing solutions group has a couple of interesting projects and data to share. For example, they try to figure out solutions to selectively shut down unnecessary components while retaining access to critical data. This is only one of their ambitious projects and shows <a href="http://transit.iee.ucsb.edu/research/computing/projects">how much potential there is when it comes to improving energy efficiency in our networks</a><sup class="po" id="note-18"><a href="#18">18</a></sup>.</li>
</ul>
<figure><a href="https://www.kickstarter.com/projects/1295587226/air-ink-the-worlds-first-ink-made-out-of-air-pollu"><img src="https://www.smashingmagazine.com/wp-content/uploads/2017/02/airink-opt.png" width="679" height="383" alt="AirInk" /></a><sup class="po" id="note-19"><a href="#19">19</a></sup><br />
<figcaption>Turn something ugly into something beautiful: A team at the MIT Media Lab developed <a>artist’s ink made from air pollution</a>. (<a href="https://www.kickstarter.com/projects/1295587226/air-ink-the-worlds-first-ink-made-out-of-air-pollu">Image credit</a><sup class="po" id="note-20"><a href="#20">20</a></sup>)</figcaption>
</figure>
<p><em>And with that, I’ll close for this week. If you like what I write each week, please <a href="https://wdrl.info/donate">support me with a donation</a><sup class="po" id="note-21"><a href="#21">21</a></sup> or share this resource with other people. You can learn more <a href="https://wdrl.info/costs/">about the costs of the project here</a><sup class="po" id="note-22"><a href="#22">22</a></sup>. It’s available via email, RSS and online.</em></p>
<p><em>— Anselm</em></p>
<h4  class="po" id="footnotes">Footnotes <a href="#footnotes" aria-label="Link to section 'Footnotes'" class="sr hsl">Link</a></h4><ol class="po"><li id="#1"><a href="#note-1">1 https://bugs.chromium.org/p/project-zero/issues/detail?id=1139</a></li><li id="#2"><a href="#note-2">2 https://blog.cloudflare.com/incident-report-on-memory-leak-caused-by-cloudflare-parser-bug/</a></li><li id="#3"><a href="#note-3">3 https://webkit.org/blog/7423/release-notes-for-safari-technology-preview-24/</a></li><li id="#4"><a href="#note-4">4 https://blog.mozilla.org/security/2017/02/23/the-end-of-sha-1-on-the-public-web/</a></li><li id="#5"><a href="#note-5">5 https://ana-balica.github.io/2017/02/21/code-review-checklist/</a></li><li id="#6"><a href="#note-6">6 https://www.smashingmagazine.com/2017/02/a-detailed-introduction-to-webpack/</a></li><li id="#7"><a href="#note-7">7 http://ohshitgit.com/</a></li><li id="#8"><a href="#note-8">8 http://ohshitgit.com/</a></li><li id="#9"><a href="#note-9">9 http://ohshitgit.com/</a></li><li id="#10"><a href="#note-10">10 https://scotthelme.co.uk/csrf-is-dead/</a></li><li id="#11"><a href="#note-11">11 https://thecorrespondent.com/10221/security-for-sale-the-price-we-pay-to-protect-europeans</a></li><li id="#12"><a href="#note-12">12 https://motherboard.vice.com/en_us/article/i-tracked-myself-with-dollar170-smartphone-spyware-that-anyone-can-buy</a></li><li id="#13"><a href="#note-13">13 https://www.voorhoede.nl/en/blog/static-site-implosion-with-brotli-and-gzip/</a></li><li id="#14"><a href="#note-14">14 https://www.voorhoede.nl/en/blog/static-site-implosion-with-brotli-and-gzip/</a></li><li id="#15"><a href="#note-15">15 https://www.voorhoede.nl/en/blog/static-site-implosion-with-brotli-and-gzip/</a></li><li id="#16"><a href="#note-16">16 https://medium.com/@matuzo/writing-javascript-with-accessibility-in-mind-a1f6a5f467b9</a></li><li id="#17"><a href="#note-17">17 https://www.kickstarter.com/projects/1295587226/air-ink-the-worlds-first-ink-made-out-of-air-pollu</a></li><li id="#18"><a href="#note-18">18 http://transit.iee.ucsb.edu/research/computing/projects</a></li><li id="#19"><a href="#note-19">19 https://www.kickstarter.com/projects/1295587226/air-ink-the-worlds-first-ink-made-out-of-air-pollu</a></li><li id="#20"><a href="#note-20">20 https://www.kickstarter.com/projects/1295587226/air-ink-the-worlds-first-ink-made-out-of-air-pollu</a></li><li id="#21"><a href="#note-21">21 https://wdrl.info/donate</a></li><li id="#22"><a href="#note-22">22 https://wdrl.info/costs/</a></li></ol>
	
	
	<div class="lt"><a href="https://www.smashingmagazine.com/tag/web-development-reading-list/">Web Development Reading List</a></div>
<p>
	<a href="#top" class="top">&uarr; Back to top</a>

	<a onclick="clicky.log('#sharelink-clicked');" class="sot single" href="https://twitter.com/intent/tweet?original_referer=https://www.smashingmagazine.com/2017/02/web-development-reading-list-171/&#038;source=tweetbutton&#038;text=Web%20Development%20Reading%20List%20%23171%3A%20Leaks%2C%20SHA-1%20Collision%2C%20And%20Brotli&#038;url=https://www.smashingmagazine.com/2017/02/web-development-reading-list-171/&#038;via=smashingmag">Tweet it</a><a onclick="clicky.log('#sharelink-clicked');" class="sot single" href="http://www.facebook.com/sharer/sharer.php?u=https://www.smashingmagazine.com/2017/02/web-development-reading-list-171/">Share on Facebook</a></p>
	</p>

</article>
<div class="bio clearfix">
  <div class="grv">
    <img src="https://secure.gravatar.com/avatar/?s=78&amp;d=mm&amp;r=g" data-src="https://secure.gravatar.com/avatar/6e42ad665fb2b5579feb77328563afb5?s=78&amp;d=mm&amp;r=g" data-src-retina="https://secure.gravatar.com/avatar/6e42ad665fb2b5579feb77328563afb5?s=156&amp;d=mm&amp;r=g" class="avatar" height="78" width="78" >	</div>
	<div class="about">
		<a rel="author" class="poa" href="https://www.smashingmagazine.com/author/anselm-hannemann/?rel=author" title="Posts by Anselm Hannemann">Anselm Hannemann</a>		<p>Anselm Hannemann is a freelance <a href="https://helloanselm.com/">front-end developer and architect</a> and cares about sustainable front-end experiences and ethical choices in life. He curates the <a href="https://wdrl.info/">WDRL</a>, a weekly handcrafted web development newsletter that thousands of developers love and subscribe to.</p>
	</div>
</div>	<div class="ras clearfix">
		<h2>Related Articles</h2>
					<div class="ra clearfix">
				<a class="pp" href="https://www.smashingmagazine.com/2017/02/web-development-reading-list-170/">
					<img data-src="https://www.smashingmagazine.com/wp-content/uploads/2017/02/wdrl-170-opt.png" width="178" height="178" alt="118" class="wp-post-image" />					<h3>Web Development Reading List #170: Hamburger Alternatives, Libsodium In PHP And Choosing Profit</h3>
				</a>
			</div>
					<div class="ra clearfix">
				<a class="pp" href="https://www.smashingmagazine.com/2017/02/web-development-reading-list-169/">
					<img data-src="https://www.smashingmagazine.com/wp-content/uploads/2017/02/wdrl-169-opt.png" width="178" height="178" alt="118" class="wp-post-image" />					<h3>Web Development Reading List #169: TLS At Scale, Brotli Benefits, And Easy Onion Deployments</h3>
				</a>
			</div>
					<div class="ra clearfix">
				<a class="pp" href="https://www.smashingmagazine.com/2017/02/web-development-reading-list-168/">
					<img data-src="https://www.smashingmagazine.com/wp-content/uploads/2017/02/wdrl-168-opt.png" width="178" height="178" alt="118" class="wp-post-image" />					<h3>Web Development Reading List #168: Preload With Webpack, A Guide To Security Headers, And Service Worker Fallacies</h3>
				</a>
			</div>
			</div>
<div class="adv">
	<div class="oa_zone--ad commentspnsrtarget" id="commentspnsrtarget" data-ad-name="Comment Sponsor" data-ad-zone="26" data-ad-media="all"></div>
</div>

<ul id="comments" class="sub-tabs clearfix">
	<li><a href="#show-comments" class="active">0 Comments</a></li>
	</ul>
<div id="discussion" class="subtab-pages discussion">
	<div id="show-comments">
									<ol id="cs" class="cl">
					<li><span class="cn">00</span>
						<div class="c">
							<p>
								No comments have been posted yet. Please feel free to <a href="#respond">comment first</a>!								<br/>
								<em>
									Note: Make sure your comment is related to the topic of the article above. Let's start a personal and meaningful conversation!								</em>
							</p>
						</div>
					</li>
				</ol>
						</div>
	</div>


					<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/02/web-development-reading-list-171/#respond" style="display:none;">Click here to cancel reply.</a></small></h3>				<form action="https://www.smashingmagazine.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
					<div class="ccr right"><small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/02/web-development-reading-list-171/#respond" style="display:none;">Click here to cancel reply.</a></small></div><label for="comment">Your message</label><p>You may use simple HTML to add links or lists to your comment. Also, use <code>&lt;pre>&lt;code class="language-*">...&lt;/code>&lt;/pre></code> to mark up code snippets. We support -js, -markup and -css for comments.</p><textarea name="1f4b0-comment" id="comment" rows="10" class="input textarea" required></textarea><textarea name="comment" style="display:none" rows="1" cols="1"></textarea><div class="clearfix"><p class="input-half"><label for="comment_author">Your name</label><input type="text" name="author" id="comment_author" value="" class="input" required /></p></div>
<div class="clearfix"><p class="input-half"><label for="email">Your email</label><input type="text" name="email" id="email" value="" class="input" required /></p></div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='285293' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>				</form>
					</div><!-- #respond -->
		
			</div>		</div>		<p><a href="#top" class="top" title="Jump to the top of the page">&uarr; Back to top</a></p>
	</div></div></main>
<aside id="wpsidebar" class="sb" role="complementary">
	<div class="col side">
		<section class="mise sf clearfix" role="search">
	<form id="search_2" method="get" action="https://www.smashingmagazine.com/search-results/" target="_top">
    <label class="sl" for="searching_2">Search on Smashing Magazine</label>
		<input id="searching_2" name="q" type="text" placeholder="e.g. JavaScript" />
		<button class="search_submit" type="submit">Search</button>
		<input type="hidden" name="cx" value="partner-pub-6779860845561969:5884617103">
		<input type="hidden" name="cof" value="FORID:10">
		<input type="hidden" name="ie" value="UTF-8">
	</form>
</section>

		<section class="bw faw">
  <p class="awithus">
      <a class="ed-us" href="mailto:&#115;&#112;&#111;n&#115;oring&#64;sma&#115;&#104;i&#110;g&#109;&#97;&#103;&#97;z&#105;ne.&#99;&#111;&#109;">
	      Become a sponsor!      </a>
  </p>
  <div id="spnsrlist-a" class="oa_zone--sponsor" data-sponsor-lines="1"></div>
</section>
		
<section class="sf wg">
  <h3>
    <a href="https://www.smashingmagazine.com/the-smashing-newsletter/">
      <img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/smnl.png" alt="198,064 fine folks have signed up to our Newsletter already, when will you?" />
      Smashing Newsletter
    </a>
  </h3>
  <p>Subscribe to our email newsletter for useful tips and valuable resources, sent out every second Tuesday.</p>
  <div id="mc_embed_signup" class="mcf">
    <form action="//smashingmagazine.us1.list-manage.com/subscribe/post?u=16b832d9ad4b28edf261f34df&amp;id=a1666656e0" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate">
      <label for="mcer-EMAIL" class="sr">Please provide us with your email address:</label>
      <input id="mcer-EMAIL" name="email" autocomplete="email" type="text" placeholder="email address" />
      <button id="mc-embedded-subscribe" name="subscribe" class="submit" type="submit">Subscribe</button>
    </form>
    <a href="https://www.smashingmagazine.com/the-smashing-newsletter/"><img class="mcc" src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/mc-counter.svg" alt="Currently, we have 191728 subscribers to our newsletter" /></a>
  </div>
</section>

		<section class="bw">
  <div id="spnsrlist-b" class="oa_zone--sponsor" data-sponsor-lines="3"></div>
</section>

		<section class="so wg">
	<div class="fir">
		<a href="https://www.smashingmagazine.com/2015/03/31/real-life-responsive-web-design-smashing-book-5/?utm_source=magazine&utm_medium=sidebar-ad&utm_campaign=sb5" style="border:0;">
			<img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/sidebar-sb5.png" alt="The Smashing Book #5" width="94" height="135">
		</a>
		<p>
			Smashing Book 5: "Real-Life Responsive Web Design", our playbook to master all the tricky facets and hurdles of <strong>responsive web design</strong>. Gorgeous hardcover with 584 pages. The eBook is included. Free worldwide shipping. <a href="https://www.smashingmagazine.com/2015/03/31/real-life-responsive-web-design-smashing-book-5/?utm_source=magazine&utm_medium=sidebar-ad&utm_campaign=sb5">Get your book now!</a>
		</p>
	</div>
	<div class="sec">
		<a href="https://www.smashingmagazine.com/inclusive-design-patterns" style="border: 0;">
			<img src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/inclusive-design-patterns.png" alt="Inclusive Design Patterns by Heydon Pickering" width="94" height="135">
		</a>
		<p>
			Today, too many websites are still inaccessible. In our new book <em>Inclusive Design Patterns</em>, we explore how to craft <strong>flexible front-end design patterns</strong> and make future-proof and accessible interfaces without extra effort. Hardcover, 312 pages. <a href="https://www.smashingmagazine.com/inclusive-design-patterns">Get the book →</a>
		</p>
	</div>
	<div class="thi">
		<a href="https://www.smashingmagazine.com/sketch-handbook" style="border:0;">
			<img src="https://www.smashingmagazine.com/wp-content/uploads/2016/11/sketch-handbook-sidebar-opt-v2.png" alt="The Sketch Handbook, with tips and tricks for designing with Sketch." width="94" height="142"></a>
		<p>Meet the new <em>Sketch Handbook</em>, our brand <strong>new Smashing book</strong> that will help you master all the tricky, advanced facets of Sketch. Filled with <strong>practical examples and tutorials in 12 chapters</strong>, the book will help you become more proficient in your work. <a href="https://www.smashingmagazine.com/sketch-handbook">Get the book</a>.</p>
	</div>

</section>


		<section class="bw">
  <div id="spnsrlist-c" class="oa_zone--sponsor" data-sponsor-lines="2"></div>
</section>

		<section class="mt wg">
  <a href="http://mediatemple.net">
    <img data-src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/mediatemple.svg" alt="Media Temple Logo" width="94" height="94" />
  </a>
  <p>We are proudly hosted on<br /><a href="http://mediatemple.net/webhosting/vps/dedicated-server/">Media Temple Dedicated Servers</a>. Performance matters.</p>
</section>

		<section>
	<div class="oa_zone--ad" id="sidebar_special-1" data-ad-name="Sidebar Special 1" data-ad-zone="72"></div>
</section>
<section>
	<div class="oa_zone--ad" id="sidebar_special-2" data-ad-name="Sidebar Special 2" data-ad-zone="72"></div>
</section>
<section>
	<div class="oa_zone--ad" id="sidebar_special-3" data-ad-name="Sidebar Special 3" data-ad-zone="72"></div>
</section>
<section>
	<div class="oa_zone--ad" id="sidebar_special-4" data-ad-name="Sidebar Special 4" data-ad-zone="72"></div>
</section>

		
<section class="wg">
	<div id="jobs">
		<h3>
			<a href="http://jobs.smashingmagazine.com/?pk_campaign=sm&amp;piwik_kwd=widget">
				<span>Smashing Job Board</span>
				<img data-src="https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/images/sm-jobs.png" alt="Smashing Jobs" width="36" height="34" />
			</a>
		</h3>
		<ul class="tl"><li class="clearfix"><a href="http://feedproxy.google.com/~r/smjobs/~3/tWaNuyVbvSI/2471003">Senior Web Developer - Wire - (Berlin, Germany) - FullTime</a><p>**Job Description**&#013;
We are looking for a motivated, highly technical Senior Web Developer who loves programming with the latest technologies and enjoys buildin...</p></li><li class="clearfix"><a href="http://feedproxy.google.com/~r/smjobs/~3/F1eUXj35aCE/2470978">Web Specialist/Developer  - Union College - (Schenectady, NY) - FullTime</a><p>Web Specialist/Developer &#013;
Communications&#013;
FT-Benefit Eligible&#013;
&#013;
Summary:&#013;
The Web Specialist/Developer is an active member of the Web Work...</p></li></ul>		<a class="cr" href="http://jobs.smashingmagazine.com?pk_campaign=sm&amp;piwik_kwd=widget">
			View more job openings&hellip;		</a>
	</div>
</section>

		<section class="clearfix">
	<div class="oa_zone--ad sidebar_sky" id="sidebar_sky-1" data-ad-name="Sidebar 1" data-ad-zone="40"></div>
</section>

<section class="clearfix">
	<div class="oa_zone--ad sidebar_sky" id="sidebar_sky-2" data-ad-name="Sidebar 2" data-ad-zone="40"></div>
</section>

		<section class="so wg conf">
	<div class="thi">
		<a href="https://smashingconf.com/" style="border: 0px none;"><img alt="SmashingConf San Francisco 2017" src="https://www.smashingmagazine.com/wp-content/uploads/2016/11/smashingconf-san-francisco-2017-2.png" width="90" height="90"></a>
		<p>Meet <strong>SmashingConf San Francisco 2017</strong>, featuring <strong>front-end</strong> ingredients, <strong>UX</strong> recipes and nothing but practical beats from the hidden corners of the web. Only <strong>practical, real-life techniques</strong> and recipes you can learn from. <a href="https://smashingconf.com/"><strong>Get your ticket now!</strong></a></p>
	</div>
</section>

		<section class="bw">
  <div id="spnsrlist-d" class="oa_zone--sponsor" data-sponsor-lines="2"></div>
</section>

		<section class="clearfix">
  <div class="oa_zone--ad sidebar_sky" id="sidebar_sky-3" data-ad-name="Sidebar 3" data-ad-zone="40"></div>
</section>

	</div>
</aside>
<footer class="f" id="footer" role="contentinfo">
		<p class="stmt">
		<em>With a commitment to quality content for the design community.</em>
		<br />Founded by Vitaly Friedman and Sven Lennartz. 2006-2017.		<br />Made in Germany.		<span class="flinks">
			&#9998;
			<a href="https://www.smashingmagazine.com/write-for-us/">Write for us</a> –
			<a href="https://www.smashingmagazine.com/contact/">Contact us</a> –
			<a href="https://www.smashingmagazine.com/privacy-policy-2/">Datenschutzerklärung</a> –
			<a href="https://www.smashingmagazine.com/about/">Impressum</a>.
		</span>
	</p>
</footer>
<script type='text/javascript'>
/* <![CDATA[ */
var iec_config = {"ajax_url":"https:\/\/www.smashingmagazine.com\/wp-json\/inpsyde-extended-comments\/rate\/","nonce":"96302a9cad"};
/* ]]> */
</script>
<script id="loadjs__inpsyde_extended_comments_rating">!function(a){"use strict";a.loadOnloadJS=function(b,c){a.addEventListener("load",function(){loadJS(b,c)},!1)},a.loadJS=function(b,c){var d=a.document.createElement("script");d.src=b,d.async=c||!1,a.document.body.appendChild(d)}}(window);
 loadOnloadJS( "https://www.smashingmagazine.com/wp-content/plugins/extended-comments/assets/js/build.min.js?ver=1.0", 1 );</script><script id="inlinejs__preload-polfill">!function(t){"use strict";var e=t.document,r={};r.isPreloadSupported=function(){try{return e.createElement("link").relList.supports("preload")}catch(t){return!1}},r.init=function(){for(var t=e.getElementsByTagName("link"),r=0;r<t.length;r++){var n=t[r];"preload"===n.rel&&"style"===n.getAttribute("as")&&(loadCSS(n.href,n),n.rel=null)}},window.loadCSS&&!r.isPreloadSupported()&&r.init()}(this);</script><script id="loadjs__comment-reply"> loadOnloadJS( "https://www.smashingmagazine.com/wp-includes/js/comment-reply.min.js", 1 );</script><script id="loadjs__smash-onload"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/onload.min.js?ver=6.4.7", 1 );</script><script id="loadjs__smash-fastclick"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/fastclick.min.js?ver=6.4.7", 1 );</script><script id="loadjs__smash-lazy-images"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/lazy-images.min.js?ver=6.4.7", 1 );</script><script id="loadjs__smash-blocked"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/blocked.min.js?ver=6.4.7", 1 );</script><script id="loadjs__codepen"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/codepen.js?ver=6.4.7", 1 );</script><script id="loadjs__prism"> loadOnloadJS( "https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/prism.js?ver=6.4.7", 1 );</script><script type='text/javascript'>
/* <![CDATA[ */
var AdsI18N = {"Advertisement":"Advertisement"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.smashingmagazine.com/wp-content/themes/smashing-magazine/assets/js/ads.min.js?ver=6.4.7'></script>
<script id="inlinejs__wp-embed">!function(a,b){"use strict";function c(){if(!e){e=!0;var a,c,d,f,g=-1!==navigator.appVersion.indexOf("MSIE 10"),h=!!navigator.userAgent.match(/Trident.*rv:11\./),i=b.querySelectorAll("iframe.wp-embedded-content");for(c=0;c<i.length;c++)if(d=i[c],!d.getAttribute("data-secret")){if(f=Math.random().toString(36).substr(2,10),d.src+="#?secret="+f,d.setAttribute("data-secret",f),g||h)a=d.cloneNode(!0),a.removeAttribute("security"),d.parentNode.replaceChild(a,d)}else;}}var d=!1,e=!1;if(b.querySelector)if(a.addEventListener)d=!0;if(a.wp=a.wp||{},!a.wp.receiveEmbedMessage)if(a.wp.receiveEmbedMessage=function(c){var d=c.data;if(d.secret||d.message||d.value)if(!/[^a-zA-Z0-9]/.test(d.secret)){var e,f,g,h,i,j=b.querySelectorAll('iframe[data-secret="'+d.secret+'"]'),k=b.querySelectorAll('blockquote[data-secret="'+d.secret+'"]');for(e=0;e<k.length;e++)k[e].style.display="none";for(e=0;e<j.length;e++)if(f=j[e],c.source===f.contentWindow){if(f.removeAttribute("style"),"height"===d.message){if(g=parseInt(d.value,10),g>1e3)g=1e3;else if(200>~~g)g=200;f.height=g}if("link"===d.message)if(h=b.createElement("a"),i=b.createElement("a"),h.href=f.getAttribute("src"),i.href=d.value,i.host===h.host)if(b.activeElement===f)a.top.location.href=d.value}else;}},d)a.addEventListener("message",a.wp.receiveEmbedMessage,!1),b.addEventListener("DOMContentLoaded",c,!1),a.addEventListener("load",c,!1)}(window,document);</script>
		<script>try {
			SmashingAds.loadAds();
		} catch ( e ) {
		}</script>

		<script>try {
			SmashingAds.render( OA_output );
		} catch ( e ) {
		}</script>

	<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"86b694293f","applicationID":"11250242","transactionName":"NgMAbEZVV0cAWxZYXg9JI1tAXVZaTksLX1YNAw==","queueTime":0,"applicationTime":244,"atts":"GkQDGg5PREk=","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>
